Bug 224004 - Live migration to localhost leaves guest hung
Summary: Live migration to localhost leaves guest hung
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 246139 240441 296411 372911 429673
TreeView+ depends on / blocked
 
Reported: 2007-01-23 15:42 UTC by Markus Armbruster
Modified: 2018-10-19 21:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 13:42:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xen/xend.log since reboot (24.67 KB, text/plain)
2007-11-14 16:23 UTC, Markus Armbruster
no flags Details
xenstore-ls after boot, before virsh start (713 bytes, text/plain)
2007-11-14 16:24 UTC, Markus Armbruster
no flags Details
xenstore-ls after virsh start, before xm-migrate (5.06 KB, text/plain)
2007-11-14 16:25 UTC, Markus Armbruster
no flags Details
xenstore-ls after xm-migrate (4.17 KB, text/plain)
2007-11-14 16:25 UTC, Markus Armbruster
no flags Details

Description Markus Armbruster 2007-01-23 15:42:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061221 Fedora/1.5.0.9-1.fc5 Firefox/1.5.0.9

Description of problem:
After migrating a live guest to localhost, the guest appears to be hung.


Version-Release number of selected component (if applicable):
xen-3.0.3-21.el5

How reproducible:
Always


Steps to Reproduce:
1. xm create -c DOMNAME
2. xm migrate -l DOMNAME localhost


Actual Results:
The guest appears to hang.

xm console DOMNAME fails with message xenconsole: Could not read tty from store: No such file or directory

Guest doesn't reply to ping.

xm shutdown does nothing.


Expected Results:
Guest doesn't hang.  xm console works.  Guest replies to ping.  xm shutdown works.


Additional info:
xenstore-ls /local/domain/$(xm domid DOMNAME)/device shows all frontend devices in state 1 (XenbusStateInitialising).  That's the initial state written by xend.  Frontend devices go through intermediate states into state 4 (XenbusStateConnected) when they initialize.  Looks like they didn't (re-)initialize at all.

Found on RHEL 5 snapshot 7 updated with kernel-xen-2.6.18-2.el5.  Also reproduced on FC-6 with xen-3.0.3-3.fc6 and kernel-xen-2.6.19-1.2895.fc6.

xm save / restore works.

Comment 1 Daniel Berrange 2007-02-26 19:01:21 UTC
Setting rhel-5.1.0 to '?', because this is a blocker for bug 212662 which also
has rhel-5.1.0 set.


Comment 2 RHEL Product and Program Management 2007-03-21 22:36:45 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Markus Armbruster 2007-06-29 06:52:45 UTC
It is currently unclear whether migration to localhost works with our upstream
base version, or even with the upstream head version.

This bug no longer blocks bug 212662, so the reason why flag rhel‑5.1.0 was
requested (comment#1) no longer exists.  I recommend to push this to 5.2.


Comment 6 Brian Stein 2007-11-14 15:12:20 UTC
Markus - Please retest and update.

Comment 7 Markus Armbruster 2007-11-14 16:21:13 UTC
Retested, same behavior.

Steps to Reproduce:
1. Edit /etc/xen/xend-config.sxp to have:
    (xend-relocation-server yes)
   Default values for the other xend-relocation-* parameters should be fine,
leave them unchaged.
2. Start guest with virt-manager or virsh start.
3. xm migrate -l DOMNAME localhost

virsh list shows guest as paused.


Comment 8 Markus Armbruster 2007-11-14 16:23:12 UTC
Created attachment 258291 [details]
/var/log/xen/xend.log since reboot

Comment 9 Markus Armbruster 2007-11-14 16:24:19 UTC
Created attachment 258301 [details]
xenstore-ls after boot, before virsh start

Comment 10 Markus Armbruster 2007-11-14 16:25:05 UTC
Created attachment 258311 [details]
xenstore-ls after virsh start, before xm-migrate

Comment 11 Markus Armbruster 2007-11-14 16:25:49 UTC
Created attachment 258321 [details]
xenstore-ls after xm-migrate

Comment 13 Markus Armbruster 2007-11-14 18:49:07 UTC
This bug could be caused by our fix for bug 245960, which effectively reverted
xen-unstable cset 12576.  Need to test that.

Might also have to make the disk shareable.


Comment 15 Markus Armbruster 2007-11-15 13:29:09 UTC
Unreverting cset 12576 and making the disk shareable don't make a difference.


Comment 16 Jay Turner 2007-11-22 12:54:18 UTC
Withholding QE ack until we sort out a path forward.  Appears from comment 14
migrating to localhost isn't really a real-world event and the potential fix
might be very destabilizing.

Comment 17 Bill Burns 2007-12-10 13:37:22 UTC
Cannot fix for RHEL 5.2.

Comment 18 RHEL Product and Program Management 2007-12-10 13:42:47 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Comment 22 Don Domingo 2008-04-02 02:15:19 UTC
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don


Note You need to log in before you can comment on or make changes to this bug.