Bug 224072 - ppc64 e1000 fails to configure static IP. dhcp is ok
ppc64 e1000 fails to configure static IP. dhcp is ok
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
: 227185 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-23 16:51 EST by Mark Smith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 11:09:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diff between FC6-gold and Jan11 anaconda/network.py (1.39 KB, text/plain)
2007-01-23 18:07 EST, Mark Smith
no flags Details

  None (edit)
Description Mark Smith 2007-01-23 16:51:20 EST
Description of problem:
Attempting p5 ppc64 netboot installation.
Correct static IPv4 network address is accepted but fails to configure network.

Version-Release number of selected component (if applicable):
Jan 23 snapshot of rawhide

How reproducible: easy


Steps to Reproduce:
1. netboot ppc64 system (I used yaboot)
text or vnc install mode
power5 system has e1000 for eth0.
configure eth0 as static and point to nfs://rhlte/distros/rawhide_snap/ dir
(ipv4 only, unselect ipv6)  (ip: 9.3.117.160 255.255.255.0)
2. anaconda fails to proceed.  returns message that the nfs dir cannot be 
mounted.   ping from another system fails.
3. workaround is to back up and configure ipv4 as dhcp served.
4. following an install, upon reboot, the same network device will 
successfully configure as a static ip.  So it is only during 
installing/anaconda that the static ip fails to configure.
5. repeating install with boot: linux noprobe
and then manually selecting/loading Intel e1000 driver results in an identical 
recreate.

Actual results:
cannot install with static ipv4 address activated

Expected results:
successful install
Comment 1 Mark Smith 2007-01-23 18:07:58 EST
Created attachment 146374 [details]
diff between FC6-gold and Jan11 anaconda/network.py

Purely a hunch, but here is the diff between network.py versions for Fedora
Core6 - gold and today's rawhide.  FC6 does not recreate this problem.
In the interest of improving my test effectiveness, is there a way I can
netboot with debug versions of vmlinuz/initrd to discover root cause?
I do have Xmon available and can invoke that if it would yield any useful data.
Comment 2 David Cantrell 2007-01-29 15:03:42 EST
(Please use diff -u in the future).

network.py is not responsible for the stage you're at.  This is most likely the
same problem caused by 2.6.19 and higher where we need to explicitly set
IFF_UP|IFF_RUNNING on the interface during interface configuration.  2.6.18 and
previous versions did not present this problem, but some things changed in the
kernel networking layer that have required the change.

It was first noticed with DHCP and I fixed that, but never did anything for the
static configuration part.  I'll go and test that.
Comment 3 Chris Lumens 2007-02-09 15:07:35 EST
*** Bug 227185 has been marked as a duplicate of this bug. ***
Comment 4 Mark Smith 2007-02-15 21:22:49 EST
I am just updating that this still recreates with Feb15 rawhide, kernel 
version 2.6.20-1.2930
No worries.
Comment 5 David Cantrell 2007-02-16 11:09:46 EST
Should be fixed in libdhcp-1.20-1.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.