Bug 2240950 - No longer able to disable menu shortcut key (F10)
Summary: No longer able to disable menu shortcut key (F10)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-terminal
Version: 39
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-09-27 09:28 UTC by htd
Modified: 2023-11-25 02:53 UTC (History)
5 users (show)

Fixed In Version: xfce4-terminal-1.1.1-1.fc39 xfce4-terminal-1.1.1-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-25 02:42:18 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description htd 2023-09-27 09:28:40 UTC
Description of problem:
Enabling "Disable menu shortcut key (F10 by default)" does no longer work. Pressing F10 brings up the menu despite of this option enabled.

Version-Release number of selected component (if applicable):
1.1.0-1.fc38

How reproducible:
Always.

Steps to Reproduce:
1.Check the "Disable menu shortcut key (F10 by default)" option.
2. Press F10.
3.

Actual results:
The terminal menu shows up.

Expected results:
Nothing happens when pressing F10.

Additional info:
For example when using the Midnight Commander, F10 terminates it when F10 is disabled as described above. Now, the terminal menu shows up and mc is unaware of the F10 key being pressed. Downgrading xfce4-terminal (1.0.4-3.fc38.x86_64) resolves the problem.

Comment 1 Kevin Fenzi 2023-10-02 23:45:39 UTC
This was fixed upstream already: 

https://gitlab.xfce.org/apps/xfce4-terminal/-/issues/259#note_78740

A 1.1.1 was expected but hasn't happened yet. :(

If it doesn't we can push an update with the patch downstream...

Comment 2 Peter Bieringer 2023-10-12 06:24:47 UTC
Fedora 39 has same issue: xfce4-terminal-1.1.0-1.fc39.x86_64

Have created RPMs now for F38 and F39 with patch from https://gitlab.xfce.org/apps/xfce4-terminal/-/commit/c576281a780884f9ba1f6abe3d543a3a00f0b48d

Looks like this will not turn active after update in a running graphical session, in my case (didn't try logout-login) I did a reboot (pending other updates anyhow required it...).

F39: https://koji.fedoraproject.org/koji/taskinfo?taskID=107391667
F38: https://koji.fedoraproject.org/koji/taskinfo?taskID=107391684

BTW: didn't understand how the "%autorelease" macro is really working, had to increase "release_number"

Comment 3 Mukundan Ragavan 2023-10-17 02:33:36 UTC
I will update 1.1.1

Comment 4 Fedora Update System 2023-11-16 02:20:03 UTC
FEDORA-2023-dd8dc977e2 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dd8dc977e2

Comment 5 Fedora Update System 2023-11-16 02:20:04 UTC
FEDORA-2023-111a39a209 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-111a39a209

Comment 6 Fedora Update System 2023-11-17 03:04:36 UTC
FEDORA-2023-dd8dc977e2 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dd8dc977e2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-dd8dc977e2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-11-17 03:05:21 UTC
FEDORA-2023-111a39a209 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-111a39a209`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-111a39a209

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-11-25 02:42:18 UTC
FEDORA-2023-111a39a209 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2023-11-25 02:53:52 UTC
FEDORA-2023-dd8dc977e2 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.