Bug 2241528 (CVE-2023-42116) - CVE-2023-42116 Exim: SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability
Summary: CVE-2023-42116 Exim: SMTP Challenge Stack-based Buffer Overflow Remote Code E...
Keywords:
Status: NEW
Alias: CVE-2023-42116
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2241529 2241530
Blocks: 2241518
TreeView+ depends on / blocked
 
Reported: 2023-09-30 17:43 UTC by Nick Tait
Modified: 2023-10-05 05:47 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
The vulnerability was found in Exim within the handling of NTLM challenge requests. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the service account. Authentication is not required to exploit this vulnerability.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Comment 1 Nick Tait 2023-09-30 17:43:35 UTC
Created exim tracking bugs for this issue:

Affects: epel-all [bug 2241530]
Affects: fedora-all [bug 2241529]


Note You need to log in before you can comment on or make changes to this bug.