Bug 224153 - either a missing build requirement or a missing --disable-XXX configure option
either a missing build requirement or a missing --disable-XXX configure option
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 08:59 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-25 23:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-01-24 08:59:03 EST
Description of problem:
gettext builds a jar file when java is present in the build environment and
rpmbuild fails due to an unpackaged file:

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/gettext-0.16.1-3.fc7.src.rpm-root
error: Installed (but unpackaged) file(s) found:
   /usr/share/gettext/libintl.jar
Version-Release number of selected component (if applicable):
gettext-0.16.1-3.fc7
Comment 1 Jens Petersen 2007-01-31 21:28:14 EST
Can you attach the buildroot package list (maybe gzipped?)
I'm having trouble getting the Java compiler to be recognised
by configure.

I have these installed at least:
gcc-java-4.1.1-51.fc6
java-1.4.2-gcj-compat-1.4.2.0-40jpp.110
libgcj-4.1.1-51.fc6
libgcj-devel-4.1.1-51.fc6

(The configure behaviour for gcj seems to have changed from gettext-0.15.)
Comment 2 Jens Petersen 2007-01-31 23:05:30 EST
According to Bruno Haible on bugs-gnu-utils, gcj < 4.3 can't create
fully portable .jar files and that is why recent gettext is not compiling
libintl.jar.

Perhaps you have some java installed why is building it for you?
Comment 3 Karsten Hopp 2007-02-01 05:09:22 EST
I'm not entirely sure as I've already deleted the buildroot, but I think I had
the following packages installed:
gcc-java-4.1.1-53
java-1.4.2-gcj-compat-1.4.2.0-40jpp.111
libgcj-4.1.1-53
libgcj-devel-4.1.1-53

But the problem here is probably that you should add a 'rm -f
$RPM_BUILD_ROOT/%{_datadir}/%{name}/libintl.jar' or '--disable-java' to the
configure options if you don't want to ship this file and it just happens to
build sometimes.
Comment 4 Jens Petersen 2007-02-01 18:40:54 EST
Here is the reply on bugs-gnu-utils for the record:
http://lists.gnu.org/archive/html/bug-gnu-utils/2007-01/msg00098.html

"--disable-java" also removes other java related files
so I don't really want to do that.

Do you remember what tree you used for the test build?  It might give more clues.

It really shouldn't be possible to build that .jar file with gcj < 4.3.
Comment 5 Jens Petersen 2007-03-25 23:17:39 EDT
I added a build switch for the jar file.

Note You need to log in before you can comment on or make changes to this bug.