Bug 224156 - gimp fails to rebuild on a rawhide system
gimp fails to rebuild on a rawhide system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 09:06 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 08:09:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-01-24 09:06:43 EST
Description of problem:
error: Failed build dependencies:
	xorg-x11-devel is needed by gimp-2.2.13-1.i386
Installing src/gimp-2.2.13-1.fc6.src.rpm
Comment 1 Nils Philippsen 2007-01-31 11:55:52 EST
the gimp spec file relies on either %fedora or %redhat being set in the build
system which uses modular X for sufficiently high values of either %fedora or
%redhat. You can override the automatism by using "--with modular_x" on the
rpmbuild command line. Do you think I should change that, so it assumes modular
X by default?
Comment 2 Karsten Hopp 2007-02-01 06:32:47 EST
RHEL-3 is our only release where you still might need to update gimp and build
with a monolithic X. All other supported releases have modular X, so I think
it's save to set that as default. Just remember to change that for the
(unlikely) case that you have to do an gimp erratum for RHEL-3.
Comment 3 Nils Philippsen 2007-02-01 08:09:52 EST
Well, that's no issue because RHEL-3 has its own spec file which is very
different (gimp version 1.2.3) so I won't be tempted to just copy over stuff
from Rawhide ;-). I've checked in the changed defaults (lcms would also depend
on %fedora or %redhat), but won't build a package with this change as we're
bound to have some mass rebuilds at some point.

Note You need to log in before you can comment on or make changes to this bug.