Bug 224170 - Undesired behaviour of the Fn+BrightUp usage on ThinkPad x60s
Undesired behaviour of the Fn+BrightUp usage on ThinkPad x60s
Status: CLOSED DUPLICATE of bug 220466
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
Depends On: 235085
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 09:28 EST by Andy Shevchenko
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-Xorg-1.1.1-47.7.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-03 17:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration of the X (706 bytes, text/plain)
2007-01-24 15:01 EST, Andy Shevchenko
no flags Details
Log before bug (69.07 KB, text/plain)
2007-01-24 15:03 EST, Andy Shevchenko
no flags Details
Log after bug (104.50 KB, text/plain)
2007-01-24 15:03 EST, Andy Shevchenko
no flags Details
Log before bug (69.17 KB, text/plain)
2007-01-24 15:04 EST, Andy Shevchenko
no flags Details
Log after bug (104.66 KB, text/plain)
2007-01-24 15:04 EST, Andy Shevchenko
no flags Details
Log before bug (21.28 KB, text/plain)
2007-01-24 15:06 EST, Andy Shevchenko
no flags Details
Log after bug (71.43 KB, text/plain)
2007-01-24 15:07 EST, Andy Shevchenko
no flags Details

  None (edit)
Description Andy Shevchenko 2007-01-24 09:28:01 EST
Description of problem:
In the X environment (in gdm or opened X session) the Fn+BrightUp produces 
undesired behaviour. Screen is blank after fisrt click and Fn+Brightdown does 
not help. Pressing any keys and combinations also no help.
The some magick with Ctrl+Alt+F1 and Fn+BrightDown keys returns back sometimes.

Version-Release number of selected component (if applicable):
FC6 + All current updates

P.S. Fn+BrightDown and bright controls in gnome-power-manager work fine.
Comment 1 Matěj Cepl 2007-01-24 10:46:41 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andy Shevchenko 2007-01-24 15:01:51 EST
Created attachment 146446 [details]
Configuration of the X

Atmost default configuration
Comment 3 Andy Shevchenko 2007-01-24 15:03:01 EST
Created attachment 146447 [details]
Log before bug

Console in fb mode 0x317.
Comment 4 Andy Shevchenko 2007-01-24 15:03:36 EST
Created attachment 146448 [details]
Log after bug

Console in fb mode 0x317.
Comment 5 Andy Shevchenko 2007-01-24 15:04:20 EST
Created attachment 146449 [details]
Log before bug

Console in standart mode.
Comment 6 Andy Shevchenko 2007-01-24 15:04:53 EST
Created attachment 146450 [details]
Log after bug

Console in standart mode.
Comment 7 Andy Shevchenko 2007-01-24 15:06:08 EST
Created attachment 146451 [details]
Log before bug

X server without config file.
Console in fb mode 0x317.
X doesn't start anymore.
Comment 8 Andy Shevchenko 2007-01-24 15:07:03 EST
Created attachment 146452 [details]
Log after bug

X server without config file.
Console in standart mode.
Bug still present.
Comment 9 Andy Shevchenko 2007-01-24 15:08:53 EST
All logs before bug is a log after just started gdm (except case when X server 
doesn't start).
All logs after bug the previous case with once click to the Fn+BrightUp keys.
Comment 10 Andy Shevchenko 2007-01-24 15:18:03 EST
Additional info:

After bug is occured and switch to console mode the console fonts is broken 
(font glyphs not localized and show some abrakadabra).

In most case the killall gdm-binary command revert back to normal.

Sometimes restart from gdm is passing in unsupported graphics mode. Screen is 
built by many of strokes not normal symbols (like unequal horizontal frequency 
on CRT).

Comment 11 Paul T. Darga 2007-02-08 23:01:28 EST
I am also having issues on my Thinkpad T60 with the brightness keys.  Fedora
Core 6, all updates.

i386: everything worked fine

Then I installed x86_64 instead, and Xorg started crashing.  This happens with
Xorg driver (Radeon X1300), not with fglrx.

I get this in my dmesg:

video device notify
set_level status: 0

And here is the crash from Xorg.0.log:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x71) [0x496141]
1: /lib64/libc.so.6 [0x3b2b030210]
2: /lib64/libc.so.6 [0x3b2b03450a]
3: /usr/bin/Xorg [0x4732a0]
4: /usr/bin/Xorg(xf86HandlePMEvents+0x38) [0x474828]
5: /usr/bin/Xorg(xf86Wakeup+0x155) [0x497345]
6: /usr/bin/Xorg(WakeupHandler+0x51) [0x44dac1]
7: /usr/bin/Xorg(WaitForSomething+0x1d4) [0x5507f4]
8: /usr/bin/Xorg(Dispatch+0x9a) [0x449b6a]
9: /usr/bin/Xorg(main+0x455) [0x4325d5]
10: /lib64/libc.so.6(__libc_start_main+0xf4) [0x3b2b01da44]
11: /usr/bin/Xorg(FontFileCompleteXLFD+0x231) [0x4318c9]

Fatal server error:
Caught signal 11.  Server aborting

gnome-power-manager works just fine; just using the thinkpad keys.  I also have
tpb installed if that matters.
Comment 12 Matěj Cepl 2007-02-09 05:44:01 EST
Paul, does the crash happen when pressing Fn+BrightUp? Also, please, this is a
separate issue, file a new bug for it and attach to that your /etc/X11/xorg.conf
and /var/log/Xorg.0.log. Thanks a lot.
Comment 13 Chris Shoemaker 2007-03-14 19:59:34 EDT
I'm seeing the exact same dmesg messages and Xorg.0.log crash messages as in
comment #11.  I'm also using x86_64, but on a compaq presario v5210us, also
using the "radeon" driver.

In general, acpi works well here, even with suspend/restore, but pressing
Fn+BrightUp causes the SEGV.

However, I think I've noticed something interesting about the conditions that
cause the crash.  It seems that pressing the button once is not enough.  You
have to press the button twice quickly.

[I'm removing NEEDINFO since it looks like all the info requesting in comment #1
has been provided.]
Comment 14 Andy Shevchenko 2007-04-03 05:48:58 EDT
After today update the new regression is come.
The Fn+BrightDown now also blanking X screen.

[andy@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 
2007 i686 i686 i386 GNU/Linux

[andy@localhost ~]$ rpm -q xorg-x11-server-Xorg
xorg-x11-server-Xorg-1.1.1-47.7.fc6
Comment 15 Chris Shoemaker 2007-04-03 08:58:05 EDT
Am I misreading comment #14?  I read it as saying this bug is still present in
xorg-x11-server-Xorg-1.1.1-47.7.fc6, but Matej just closed this bug as resolved
in that exact version.

In any case, the crash in comment #11 is definitely still present in
xorg-x11-server-Xorg-1.1.1-47.7.fc6.  If these are really different Fn+BrightUp
bugs, should I open another bug, or is this issue already being tracked somewhere?
Comment 16 Matěj Cepl 2007-04-03 09:55:03 EDT
I was misreading comment 14. Sorry.
Comment 17 Andy Shevchenko 2007-04-03 14:30:17 EDT
Additional info.
I make some investigations and fill new bug #235085. I think this bug depends 
to that.
Comment 18 Adam Jackson 2007-04-03 17:42:30 EDT

*** This bug has been marked as a duplicate of 220466 ***

Note You need to log in before you can comment on or make changes to this bug.