This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 224198 - no more dri with driver i810 and 2.6.19
no more dri with driver i810 and 2.6.19
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 11:35 EST by Adrien Bustany
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 19:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg configuration file (1.17 KB, text/plain)
2007-01-25 12:31 EST, Adrien Bustany
no flags Details
Log when /etc/X11/xorg.conf is present (73.89 KB, text/plain)
2007-01-25 12:31 EST, Adrien Bustany
no flags Details
Log when there is no xorg.conf in /etc/X11/ (76.35 KB, text/plain)
2007-01-25 12:32 EST, Adrien Bustany
no flags Details

  None (edit)
Description Adrien Bustany 2007-01-24 11:35:53 EST
Description of problem:
I recently updated to kernel-2.6.19-1.2895.fc6. Since that update, I cannot use
DRI, here are the details :
xorg.conf :
Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        #Option      "SWCursor"  "yes"
EndSection

the error :
[madcat@boiteux ~]$ LIBGL_DEBUG=verbose glxgears
libGL: XF86DRIGetClientDriverName: 1.6.4 i915 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/i915_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering

running as root doesn't solve the problem (so it's not some perm problem)

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-10.fc6
xorg-x11-server-Xorg-1.1.1-47.4.fc6

How reproducible:
Update the kernel
Try to use any open gl app

Actual results:
see above

Expected results:
DRI acceleration

Additional info:
Comment 1 Matěj Cepl 2007-01-25 09:45:22 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Adrien Bustany 2007-01-25 12:31:20 EST
Created attachment 146587 [details]
xorg configuration file
Comment 3 Adrien Bustany 2007-01-25 12:31:53 EST
Created attachment 146588 [details]
Log when /etc/X11/xorg.conf is present
Comment 4 Adrien Bustany 2007-01-25 12:32:31 EST
Created attachment 146589 [details]
Log when there is no xorg.conf in /etc/X11/
Comment 5 Adrien Bustany 2007-01-25 12:34:04 EST
Hi,
I attached the files you requested. Hope this will help, as just removing
/etc/X11/xorg.conf didn't do the trick
BTW, maybe someone could change the bug's name...
Comment 6 Adam Jackson 2007-01-29 18:12:42 EST
Mmm, it's not actually the X server's fault.  The server claims DRI is enabled;
we're just failing at client setup.

Does it work if you install the mesa-libGL from rawhide?  I suspect there were
silent ABI changes for the i810 driver between 2.6.18 and 2.6.19.
Comment 7 Adrien Bustany 2007-01-30 11:04:39 EST
Tried with last mesa-libGL :
[madcat@boiteux ~]$ rpm -q mesa-libGL
mesa-libGL-6.5.2-4.fc7
Restarted the X server (just to be sure)
I get the same error :
[madcat@boiteux ~]$ LIBGL_DEBUG=verbose glxgears
libGL: XF86DRIGetClientDriverName: 1.6.4 i915 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/i915_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering

Thanks for your work anyway :)
Comment 8 Adrien Bustany 2007-01-31 12:32:29 EST
Additionnal note : since I updated mesa-libGL from rawhide I don't have "stencil
buffers" anymore, than means transparency is not working anymore. For example, I
get black windows borders instead of shadows with beryl, or square wheels on
xmoto :)
Comment 9 Adrien Bustany 2007-02-06 14:10:49 EST
Updating libdrm from rawhide fixes the problem. 
Comment 10 Matěj Cepl 2007-02-06 19:14:10 EST
per comment 9 closing as NEXTRELEASE

Note You need to log in before you can comment on or make changes to this bug.