Bug 224226 - Xorg uses 5s CPU time for screen redraw or something
Xorg uses 5s CPU time for screen redraw or something
Status: CLOSED DUPLICATE of bug 431340
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 13:12 EST by Sami Farin
Modified: 2008-02-13 05:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 05:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (12.69 KB, application/octet-stream)
2007-01-24 13:12 EST, Sami Farin
no flags Details
xorg.conf (2.40 KB, text/plain)
2007-01-30 05:42 EST, Sami Farin
no flags Details
corrupted garbage in screencap (137.23 KB, application/octet-stream)
2007-01-30 10:33 EST, Sami Farin
no flags Details
startup log with EXA (61.39 KB, text/plain)
2007-01-30 10:34 EST, Sami Farin
no flags Details
using XAA - works but some corruption (141.28 KB, text/plain)
2007-01-30 10:36 EST, Sami Farin
no flags Details
server 1.2.99.902 + intel_drv 1.9.92 + EXA (92.85 KB, text/plain)
2007-03-21 10:43 EDT, Sami Farin
no flags Details

  None (edit)
Description Sami Farin 2007-01-24 13:12:32 EST
Description of problem:
when I startup firefox 1.5.0.9 in windowmaker,
Xorg needs 5s CPU time (Pentium D) to redraw or whatever it's doing
till I can start using firefox.
also, when I change workspace and go back to workspsace where
firefox is located, 5s CPU time is needed for something again.

earlier version 1.1.1-57 needed around 0.01s CPU time.

Version-Release number of selected component (if applicable):
1.2.0-1

How reproducible:
always

Steps to Reproduce:
1. startup firefox
2.
3.
  
Actual results:
laggy as ****, when I move window it refreshes 5 times a second.

Expected results:
working like earlier (last 10 years?).

Additional info:
Xorg.0.log attached.
other programs do not cause this kind of CPU usage...
Comment 1 Sami Farin 2007-01-24 13:12:33 EST
Created attachment 146432 [details]
Xorg.0.log
Comment 2 Sami Farin 2007-01-24 13:21:17 EST
Totally screwed.

Starting up command "alsamixer -V all" in gnome-terminal: 15s CPU time in Xorg.
Starting up command "alsamixer -V all" in xterm: ~0s CPU time in Xorg.
Comment 3 Matěj Cepl 2007-01-29 21:15:46 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Sami Farin 2007-01-30 05:42:40 EST
Created attachment 146906 [details]
xorg.conf

don't you have bunzip2?
Comment 5 Sami Farin 2007-01-30 10:32:26 EST
I can't reproduce the slowdown since now when I try to startup
Xorg it stalls after starting wmaker and I have to press sysrq+k.
It works when I disable EXA:
#       Option          "AccelMethod" "EXA"

But now with 1.2.0 redrawing isn't that great,
but I don't get the 5s stalls now.
screencap of firefox, after I opened Tools menu and closed it.
xrefresh does not make any diff.
Comment 6 Sami Farin 2007-01-30 10:33:45 EST
Created attachment 146920 [details]
corrupted garbage in screencap
Comment 7 Sami Farin 2007-01-30 10:34:47 EST
Created attachment 146922 [details]
startup log with EXA
Comment 8 Sami Farin 2007-01-30 10:36:37 EST
Created attachment 146923 [details]
using XAA - works but some corruption
Comment 9 Sami Farin 2007-01-30 10:47:15 EST
Funny that when xephem is running, firefox skin is drawn just okay.
Comment 10 Sami Farin 2007-01-30 11:59:51 EST
I wasted some hours playing with different broken versions of software,
here the matrix:
             +-----+-----+
             | XAA | EXA |
-------------+-----+-----+
xorg 1.1.1 a | OK  | OK  |
xorg 1.2.0 a | OK x| 2)  |
xorg 1.1.1 b | ?)  | 1)  |
xorg 1.2.0 b | 3)  | 4)  |
-------------+-----------+

x) currently using
?) haven't tried
a) i810 modesetting from 20070103
b) i810 modesetting from 20070130
1) https://bugs.freedesktop.org/show_bug.cgi?id=9637
2) this is the 5s-delay-when-switching-to-firefox
3) the firefox redraw problem in screencap
4) crash, sysrq+k needed
Comment 11 Sami Farin 2007-02-02 13:29:44 EST
Wow. 20070202 modesetting works in XAA, but EXA is a bit broken.
Fonts do not show up in e.g. wmaker menus or firefox.

(II) intel(0): Successful allocation of EXA offscreen memory at 0x660000, size
22560 KB
(II) intel(0): Allocated 64 kB for the G965 exa state buffer at 0xbff0000 -
0xc000000.

(EE) EXA(0): driver's EXA version requirements (2.1) are incompatible with EXA
version (2.0)
(II) intel(0): EXA initialization failed; trying older version
Comment 12 Sami Farin 2007-03-21 10:40:57 EDT
Now with server 1.2.99.902 Xorg waster 0.5s of CPU time when switching
workspace in wmaker.

using 1.9.92 intel_drv.so with EXA.  later versions do not work (undefined
reference to xf86_cursors_init).
XAA segfaults:
--- snip ---
(II) intel(0): [dri] visual configs initialized
(II) intel(0): Page Flipping disabled
(==) intel(0): Write-combining range (0x40000000,0x10000000)
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000

Backtrace:
0: X(xf86SigHandler+0x85) [0x80be837]
1: X(AddScreen+0x1ff) [0x807024d]

Fatal server error:
Caught signal 11.  Server aborting
--- snip ---

profile when I switched workspace 20 times.

CPU: P4 / Xeon, speed 2797.42 MHz (estimated)
Counted GLOBAL_POWER_EVENTS events (time during which processor is not stopped)
with a unit mask of 0x01 (mandatory) count 45000
Counted FSB_DATA_ACTIVITY events (DRDY or DBSY events on the front side bus)
with a unit mask of 0x03 (multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x05
(multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x0a
(multiple flags) count 45000
samples  %        samples  %        samples  %        samples  %        linenr
info                 image name               app name                 symbol name
722165   58.9155  5632     53.4497  1670      7.9904  19        2.9688  (no
location information)   libc-2.5.so              libc-2.5.so              memcpy
154260   12.5848  24        0.2278  1341      6.4163  7         1.0938 
delay.c:42                  vmlinux                  vmlinux                 
delay_tsc
21432     1.7485  182       1.7272  74        0.3541  1         0.1562  (no
location information)   intel_drv.so             intel_drv.so            
i965_prepare_composite
10988     0.8964  1014      9.6232  43        0.2057  1         0.1562 
page_alloc.c:578            vmlinux                  vmlinux                 
prep_new_page
7390      0.6029  22        0.2088  18        0.0861  0              0  (no
location information)   vmlinux                  vmlinux                  page_fault
6230      0.5083  29        0.2752  82        0.3923  5         0.7812  (no
location information)   intel_drv.so             intel_drv.so            
I830WaitLpRing
5360      0.4373  17        0.1613  34        0.1627  1         0.1562 
time.c:165                  vmlinux                  vmlinux                 
timer_interrupt
5202      0.4244  3         0.0285  23        0.1100  1         0.1562  (no
location information)   anon (tgid:12410 range:0xeb2000-0xeb3000) Xorg         
           (no symbols)
5117      0.4175  95        0.9016  105       0.5024  0              0 
usercopy.c:717              vmlinux                  vmlinux                 
__copy_to_user_ll
4682      0.3820  187       1.7747  14        0.0670  0              0 
highmem.c:89                vmlinux                  vmlinux                 
kunmap_atomic
4321      0.3525  74        0.7023  231       1.1053  3         0.4688  (no
location information)   oprofiled                oprofiled               
odb_update_node
3845      0.3137  73        0.6928  19        0.0909  0              0 
process.c:252               vmlinux                  vmlinux                 
mwait_idle_with_hints
3685      0.3006  17        0.1613  197       0.9426  30        4.6875  (no
location information)   libc-2.5.so              libc-2.5.so             
_int_malloc
3431      0.2799  9         0.0854  310       1.4833  21        3.2812  (no
location information)   Xorg                     Xorg                     miRegionOp

that was profile for all... now for Xorg.

CPU: P4 / Xeon, speed 2797.42 MHz (estimated)
Counted GLOBAL_POWER_EVENTS events (time during which processor is not stopped)
with a unit mask of 0x01 (mandatory) count 45000
Counted FSB_DATA_ACTIVITY events (DRDY or DBSY events on the front side bus)
with a unit mask of 0x03 (multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x05
(multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x0a
(multiple flags) count 45000
samples  %        samples  %        samples  %        samples  %        linenr
info                 image name               symbol name
5202     20.7714  3         1.6575  23        1.7385  1         1.4085  (no
location information)   anon (tgid:12410 range:0xeb2000-0xeb3000) (no symbols)
3431     13.6999  9         4.9724  310      23.4316  21       29.5775  (no
location information)   Xorg                     miRegionOp
1089      4.3483  12        6.6298  69        5.2154  2         2.8169  (no
location information)   Xorg                     miUnion
806       3.2183  3         1.6575  83        6.2736  6         8.4507  (no
location information)   Xorg                     miUnionO
572       2.2840  6         3.3149  51        3.8549  4         5.6338  (no
location information)   Xorg                     ReadRequestFromClient
511       2.0404  7         3.8674  18        1.3605  1         1.4085  (no
location information)   Xorg                     Dispatch
473       1.8887  4         2.2099  43        3.2502  2         2.8169  (no
location information)   Xorg                     XaceHook
461       1.8408  3         1.6575  19        1.4361  1         1.4085  (no
location information)   Xorg                     WaitForSomething
460       1.8368  9         4.9724  23        1.7385  2         2.8169  (no
location information)   Xorg                     SecurityLookupIDByType
455       1.8168  2         1.1050  26        1.9652  1         1.4085  (no
location information)   Xorg                     miComputeCompositeRegion
419       1.6731  0              0  32        2.4187  0              0  (no
location information)   Xorg                     __i686.get_pc_thunk.bx
404       1.6132  8         4.4199  16        1.2094  0              0  (no
location information)   Xorg                     FreeResource
397       1.5852  0              0  3         0.2268  0              0  (no
location information)   Xorg                     GetTimeInMillis
331       1.3217  5         2.7624  58        4.3840  0              0  (no
location information)   Xorg                     miRectIn
Comment 13 Sami Farin 2007-03-21 10:43:41 EDT
Created attachment 150586 [details]
server 1.2.99.902 + intel_drv 1.9.92 + EXA
Comment 14 Sami Farin 2007-03-21 18:13:33 EDT
Having DRI on/off or GLX on/off makes not difference.

Also, looks like only gtk apps are causing this burning of CPU cycles.
When I cycle workspace between xterms, qt apps or motif apps, not much CPU power
is needed.
Comment 15 Dave Airlie 2007-07-31 22:06:28 EDT
currently EXA is not enabled by default, there are still some issues to be
resolved with EXA before this can be done in Fedora, so can you quantify what
the problem is with XAA?

We are working on getting EXA to a more acceptable level.
Comment 16 Matěj Cepl 2008-02-13 05:59:14 EST

*** This bug has been marked as a duplicate of 431340 ***

Note You need to log in before you can comment on or make changes to this bug.