Bug 2242271 - Change minizip-compat dependency to minizip-ng
Summary: Change minizip-compat dependency to minizip-ng
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2235710
TreeView+ depends on / blocked
 
Reported: 2023-10-05 09:18 UTC by Adam Dobes
Modified: 2023-12-06 19:02 UTC (History)
5 users (show)

Fixed In Version: chromium-120.0.6099.62-1.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-12-06 19:02:38 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Adam Dobes 2023-10-05 09:18:27 UTC
There are plans to remove `zlib` package from Fedora in favor of `zlib-ng`. This would also mean the removal of `minizip-compat` as this is zlib's subpackage. Please try to update `minizip-compat` dependencies to `minizip-ng`.

`minizip-ng` should provide backwards ABI compatibility with `minizip-compat`.

The plan to remove `zlib` has not yet been decided, so even if this dependency change is not possible, it would still provide valuable early feedback.

Reproducible: Always

Comment 1 Lukas Javorsky 2023-10-16 08:12:49 UTC
Hello,

The Fedora Change proposal (https://fedoraproject.org/wiki/Changes/MinizipNGTransition) is already being worked on, please escalate this issue.

Comment 2 Than Ngo 2023-10-18 18:34:47 UTC
I'm afraid it's not easy to switch it to minizip-ng due to missing header file ioapi.h in minizip-ng-devel. 

Do you have any idea?

Thanks!

Comment 3 Lukas Javorsky 2023-10-19 07:38:21 UTC
I've found an issue in upstream Github where it was discussed (https://github.com/zlib-ng/minizip-ng/issues/447)

However, I'm also not familiar with chromium, maybe it would be worth to try reach to the upstream to ask them if they could take a look at it, and change the dependency. Could you please do that?

Comment 4 Lukas Javorsky 2023-10-20 13:23:58 UTC
Hi Than,

Upstream just added a commit where they add the ioapi.h for compatibility: https://github.com/zlib-ng/minizip-ng/commit/0d81d2eaaec82f9f0cf298bdbbb49366bd880d39

I'm already adding it to the minizip-ng-compat-devel, would that be enough for chromium to start building with the minizip-ng-compat?

Comment 5 Than Ngo 2023-10-20 14:50:17 UTC
Hi Lukas, 

sadly it is still not enough to build chromium due missing function unzGetCurrentFileZStreamPos64 which is defined in minizip "extern ZPOS64_T ZEXPORT unzGetCurrentFileZStreamPos64 OF((unzFile file));"

We need to have this function back in mz_compat

Thanks

Comment 6 Lukas Javorsky 2023-10-25 07:28:46 UTC
Thanks Than for the review,

I asked the upstream why they don't provide it, when they claim the MZ_COMPAT should be compatible with the canonical zlib's minizip.

Comment 7 Lukas Javorsky 2023-10-25 13:06:08 UTC
Also, I can see chromium bundles minizip as well. Is our Fedora chromium package ready to switch to bundled minizip if we don't resolve this by the time of the Fedora change implementation?

Comment 8 Than Ngo 2023-10-26 07:16:42 UTC
(In reply to Lukas Javorsky from comment #7)
> Also, I can see chromium bundles minizip as well. Is our Fedora chromium
> package ready to switch to bundled minizip if we don't resolve this by the
> time of the Fedora change implementation?

Hi Lukas,
yes, it should be built with bundle minizip without any problem

Comment 9 Lukas Javorsky 2023-12-04 23:26:24 UTC
Than, please switch chromium to bundled minizip.

All other packages have been rebuilt in the side-tag and pushed to Bodhi: https://bodhi.fedoraproject.org/updates/FEDORA-2023-cea7a20e14

Expect the `minizip-compat` package to disappear within a week as zlin-ng transition is on move as well.

Comment 10 Than Ngo 2023-12-05 13:40:39 UTC
Hi Jan,

i already made this change to build with bundleminizip. Should i build it in rawhide or in side-tag?

Comment 11 Lukas Javorsky 2023-12-05 13:49:11 UTC
Hi Than,

Please build it in rawhide, the side-tag is not the right place for it.

Comment 12 Than Ngo 2023-12-06 19:02:38 UTC
it's now fixed in chromium-120.0.6099.62-1.fc40.


Note You need to log in before you can comment on or make changes to this bug.