Bug 224283 - 2.6.19-1.2895 crashes on start-up
2.6.19-1.2895 crashes on start-up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 224289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 19:46 EST by steve romero
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.19-1.2911.6.4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-04 15:44:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract and see ReadMeFirst file for explanations (149.48 KB, application/x-gzip)
2007-01-24 19:46 EST, steve romero
no flags Details
Kernel oops dump (3.91 KB, text/plain)
2007-01-29 07:45 EST, Tony Tsui
no flags Details
hda patch (468 bytes, text/x-patch)
2007-02-19 23:35 EST, steve romero
no flags Details

  None (edit)
Description steve romero 2007-01-24 19:46:15 EST
Description of problem:2.6.19-1.2895 crashes on start-up


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.update 2.6.19-1.2895.fc6 kernel
2.reboot
3.crash on start-up
  
Actual results:system crashes on start-up


Expected results:system should boot normally


Additional info:After working with this problem for a couple of days I was able
to come up with a work around to get the kernel to boot, see the attached files
for further information.
Comment 1 steve romero 2007-01-24 19:46:16 EST
Created attachment 146484 [details]
Extract and see ReadMeFirst file for explanations
Comment 2 steve romero 2007-01-24 19:52:34 EST
With regards to my work around all is still not well with the system, e.g. eth0
and sound do not work.  Also the work around is a bit ugly and not something
that you would want to do on a regular basis.

In effect the work around is;

1. Select System -> Administration -> Sound Card Detection
2. Select the Settings tab, highlight the audio card, check Disable specific
card configuration, Select Apply and quit.
3. Reboot, at the grub prompt select the 2.6.19-1.2895 kernel
4. At the point when the first crash dump appears enter 'ctl - c' and pause,
repeat until the system boot proceeds.

Not very elegant and difficult to get just right every time.

Comment 3 Walter Neumann 2007-01-26 11:04:59 EST
*** Bug 224289 has been marked as a duplicate of this bug. ***
Comment 4 Walter Neumann 2007-01-27 10:59:33 EST
If you don't mind no sound, the following gets a perfectly clean boot:

remove the whole directory /lib/modules/2.6.19-1.2895.fc6/kernel/sound/

I presume the logs posted by Romero make clear which kernel module(s) is/are
causing the problem so I won't try to explore it unless I'm told it would be
helpful.
Comment 5 Tony Tsui 2007-01-29 07:45:01 EST
Created attachment 146827 [details]
Kernel oops dump

I have the same problem. Attached is the kernel oops. I obtained this data by
renaming kernel/sound/pci/hda to kernel/sound/pci/hda-disabled so the
snd_hda_codec and snd_hda_intel module could not be loaded on boot. Then I
manually loaded these modules when the system booted.
Comment 6 Walter Neumann 2007-02-16 08:53:47 EST
The crash is gone with kernel 2.6.19-1.2911 but sound still does not work. The
sound modules now load fine without crashing the kernel but they don't seem to
associate with the sound device. 
Comment 7 Walter Neumann 2007-02-16 09:06:29 EST
See also Steve Romero's comments to bug 224289 (duplicate of this bug), giving
more detail of same experience. According to him, ethernet card is also broken
with the 2.6.19 kernel. I havn't tested this (I'm using wireless) but it is
certainly giving me some wierd device name instead of eth0.
Comment 8 Tony Tsui 2007-02-17 05:06:11 EST
Kernel 2.6.19-1.2911 also does not crash for me, however sound works for me.
Comment 9 Walter Neumann 2007-02-17 19:46:47 EST
The ethernet card works fine for me using the r1000 driver
(dkms-r1000-1.05-1.fc6.rf from dries).  I have essentially the same hardware has
Steve Romero. 

So in summary, for me only sound is broken: update from 2.6.18 to 2.6.19-1.2895
led to kernel oops as sound loaded. Update to 2.6.19-1.2911 fixed the oops but
sound is still broken. All the necessary sound modules load fine on boot, but
don't associate with the audio device: Intel Corporation 82801G (ICH7 Family).
Comment 10 Walter Neumann 2007-02-18 01:01:32 EST
The problem is discussed and solved with a kernel patch here:
http://bugs.frugalware.org/task/1505
http://bbs.archlinux.org/viewtopic.php?pid=226316


The following from my /var/log/messages pinpoints the problem:

 Feb 17 19:13:46 localhost kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22
(level, low) -> IRQ 21
 Feb 17 19:13:47 localhost kernel: si3054: cannot initialize. EXT MID = 0000
 Feb 17 19:13:47 localhost kernel: ACPI: PCI interrupt for device 0000:00:1b.0
disabled
 Feb 17 19:13:47 localhost kernel: HDA Intel: probe of 0000:00:1b.0 failed with
error -13

Comment 11 steve romero 2007-02-19 23:34:20 EST
First an apology my last inputs with regards to this bug I added comments to the
wrong bug.  If anyone has experienced cracked ribs then you know that the first
thing that you loose is sleep, my bad.

Now for the update, spun up a custom kernel from the 2911 sources with a patch
to the hda codec, see the attachment.

In any case the sound now works, as well as showing the modem which is something
that I've not seen before.

Eth0, the RTL 8101E however is still buggerd however.
Comment 12 steve romero 2007-02-19 23:35:30 EST
Created attachment 148402 [details]
hda patch
Comment 13 steve romero 2007-02-24 15:30:42 EST
Installed kernel 2.6.20-1.2917.fc6 from;
http://people.redhat.com/davej/kernels/Fedora/FC6/1.2917.fc6/i686/
and it works!  Audio and networking are good to go.  In fact this is the first
kernel that I've tried that works with Network Manager the way its supposed to
work, e.g. start laptop (eth0 disconnected) and it connects the wireless, plug
in eth0 and it switches to the internal network, disconnect eth0 and it
reconnects the wireless eth1.

One small nit however in the dmesg logs I have this;

Device 'dock.0' does not have a release() function, it is broken and must be fixed.
BUG: warning: (1) at drivers/base/core.c:104/device_release() (Not tainted)
 [<c04ec67a>] kobject_cleanup+0x3e/0x5e
 [<c04ec69a>] kobject_release+0x0/0x8
 [<c04ed1c9>] kref_put+0x8a/0x97
 [<c055a8c4>] device_del+0x1a9/0x1bd
 [<f8c256f3>] find_dock+0x1ea/0x20a [dock]
 [<c0521670>] acpi_ns_walk_namespace+0xf8/0x110
 [<c051fe5c>] acpi_walk_namespace+0x57/0x74
 [<f8c25509>] find_dock+0x0/0x20a [dock]
 [<f8bcd03c>] dock_init+0x3c/0x55 [dock]
 [<f8c25509>] find_dock+0x0/0x20a [dock]
 [<c0442827>] sys_init_module+0x1794/0x18db
 [<c0473bd0>] do_sync_read+0x0/0x10a
 [<c047451e>] vfs_read+0xa6/0x152
 [<c0403f64>] syscall_call+0x7/0xb
 [<c0620033>] packet_release+0xf9/0x17c
 =======================
No dock devices found.

Not really sure what this is about, I suspect something ACPI related given these
two links;

http://www.ussg.iu.edu/hypermail/linux/kernel/0612.3/1010.html
http://www.baldwin.cx/~phoenix/reference/docs/acpi_impguide.pdf

I'll file a new bug against the 2.6.20-1.2917.fc6 kernel.

In any case thanks to the developers as I did not think given the demands of F7
that an updated kernel for FC6 would be made available this quickly.

Again thanks!
Comment 14 steve romero 2007-02-24 15:45:24 EST
Given that the test kernel 2.6.20-1.2917.fc6 corrects these issues I would
recommend closing this bug as it is or will soon be OBE.

Comment 15 Walter Neumann 2007-03-03 13:49:45 EST
Fixed for me in released kernel 2.6.19-1.2911.6.4.fc6

Steve: you can close this bug. I can't since I didn't open it (I opened a
duplicate, now closed).

Note You need to log in before you can comment on or make changes to this bug.