Bug 2243060 - grub2-2.06-103 breaks dtb file installation
Summary: grub2-2.06-103 breaks dtb file installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 39
Hardware: aarch64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Nicolas Frayer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2243263 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-10-10 14:00 UTC by Hector Martin
Modified: 2023-11-03 18:35 UTC (History)
15 users (show)

Fixed In Version: grub2-2.06-104.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-03 18:35:19 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
trivial fix adding '-r' at the place which copies 'dtb/' on aarch64 (1.31 KB, application/mbox)
2023-10-10 18:56 UTC, Janne Grunau
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Fedora Package Sources grub2 pull-request 32 0 None None None 2023-10-10 19:08:58 UTC

Description Hector Martin 2023-10-10 14:00:29 UTC
Broken commit:

https://src.fedoraproject.org/rpms/grub2/c/8800efcb0bea5750f77f88a05ac9211a19cbc7a0?branch=rawhide

`cp -a` implies recursive copy. `dtb` is a directory. The new command fails to copy device trees, since it is no longer recursive.

```
sudo /bin/kernel-install add 6.5.6-400.asahi.fc39.aarch64+16k /lib/modules/6.5.6-400.asahi.fc39.aarch64+16k/vmlinuz
cp: -r not specified; omitting directory '/usr/lib/modules/6.5.6-400.asahi.fc39.aarch64+16k/dtb'
restorecon: lstat(/boot/dtb-6.5.6-400.asahi.fc39.aarch64+16k) failed: No such file or directory
```

This is actively breaking new kernel installation and bootloader dtb updates on Fedora Asahi, which means we can't push new kernels until it's fixed. It is also likely breaking our image autobuilds.

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2023-10-10 14:06:02 UTC
Proposed as a Blocker for 39-final by Fedora user ngompa using the blocker tracking app because:

 This violates the criterion of "No broken packages" because it results in systems that no longer correctly boot, particularly on AArch64 where DeviceTree is used instead of UEFI.

Comment 2 Davide Cavalca 2023-10-10 18:20:22 UTC
I can confirm this is actively breaking Fedora Asahi Remix builds for rawhide:

+ update-m1n1 /boot/efi/m1n1/boot.bin
Reading m1n1 config from /etc/m1n1.conf:
cat: '/boot/dtb/apple/*': No such file or directory

Comment 3 Janne Grunau 2023-10-10 18:56:20 UTC
Created attachment 1993334 [details]
trivial fix adding '-r' at the place which copies 'dtb/' on aarch64

Comment 4 Janne Grunau 2023-10-10 19:08:18 UTC
also opened as PR in https://src.fedoraproject.org/rpms/grub2/pull-request/32

Comment 5 Adam Williamson 2023-10-10 19:35:42 UTC
The broken version is not stable, and I've unpushed the update. It does not fix any blocker or FE bug, so it is not in line to go through the freeze. So this cannot really be a blocker, because the bug isn't actually in F39 stable. Unproposing.

Comment 6 Fedora Update System 2023-10-11 11:37:22 UTC
FEDORA-2023-f46483e5b5 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-f46483e5b5

Comment 7 Adam Williamson 2023-10-11 18:23:00 UTC
*** Bug 2243263 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2023-10-12 00:16:26 UTC
sigh, duping Dennis' bug made this one get re-proposed as a blocker. again, it does not need to be one, as the update that broke this never made stable.

Comment 9 Fedora Update System 2023-10-12 02:24:16 UTC
FEDORA-2023-f46483e5b5 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-f46483e5b5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f46483e5b5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-11-03 18:35:19 UTC
FEDORA-2023-f46483e5b5 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.