Bug 224320 - Unable to create sub named "" at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/XSLoader.pm line 99
Summary: Unable to create sub named "" at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-m...
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 08:47 UTC by Joachim Backes
Modified: 2008-03-17 10:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 10:23:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2007-01-25 08:47:45 UTC
Description of problem:
perlcc is broken!

Version-Release number of selected component (if applicable):perl-5.8.8-10


How reproducible:
Each time

Steps to Reproduce:
1.compile the following text with perlcc:
#!/usr/bin/perl
use strict;
my $datei;
my $i;
my @csv_dateien = glob "*.csv";
foreach $datei (@csv_dateien)
{
        open (INHALT, "+<$datei");
        open (NEU, ">>new$datei")
        or die "Kann die Datei $datei nicht oeffnen: $!";
        while(defined($i = <INHALT>)) { 
                $i =~  s/\,/\./g;
                $i =~  s/\;/\,/g;
                print NEU $i; }
        close INHALT;
        close NEU;
        }


2. Make some file named ...csv
3. start a.out
  
Actual results: Unable to create sub named "" at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/XSLoader.pm line 99.


Expected results:
a.out runs correctly

Additional info:

Comment 1 Joachim Backes 2008-02-24 10:15:15 UTC
The problem persists in Fedora 8!

Comment 2 Marcela Mašláňová 2008-03-17 10:23:12 UTC
Sorry, but I won't fix it, because upstream decided to dump whole perlcc thing.

Official Perl 5.10 release note:
Removal of the bytecode compiler and of perlcc
perlcc, the byteloader and the supporting modules (B::C, B::CC, B::Bytecode,
etc.) are no longer distributed with the perl sources. Those experimental tools
have never worked reliably, and, due to the lack of volunteers to keep them in
line with the perl interpreter developments, it was decided to remove them
instead of shipping a broken version of those. The last version of those modules
can be found with perl 5.9.4.


Note You need to log in before you can comment on or make changes to this bug.