Bug 224324 - evolution --force-shutdown requires display
evolution --force-shutdown requires display
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-25 04:26 EST by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 09:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-01-25 04:26:03 EST
Description of problem:

evolution --force-shutdown requires display

This is not very helpful when trying to "kill evolution" from a console or a
remote machine (e.g. as root).

# evolution --force-shutdown
cannot open display:
Run 'evolution --help' to see a full list of available command line options.

I encountered this issue, when the desktop of a machine had become
non-responsive because evolution had "gone-though" (evolution race, 100% cpu
load - hogging all memory) and I had tried to kill this racing evolution being
logged in as root from a remote machine.

Version-Release number of selected component (if applicable):
evolution-2.8.2.1-3.fc6
Comment 1 Matthew Barnes 2007-04-02 23:20:08 EDT
This is probably because Evolution first passes its command-line arguments to
gnome_program_init() (in libgnomeui) before taking action on them.  Not really
sure how to get around this within Evolution itself.

The --force-shutdown option simply invokes '/usr/libexec/evolution/2.x/killev',
which does not require a display.  Is that a sufficient workaround to close this
bug, or should I forward this to the upstream developers?
Comment 2 Ralf Corsepius 2007-04-03 00:01:46 EDT
(In reply to comment #1)
> Is that a sufficient workaround to close this
> bug, or should I forward this to the upstream developers?
Well, IMO, this is design flaw in evolution, which should be addressed upstream.
Comment 3 Matthew Barnes 2007-10-05 11:45:04 EDT
Hmm, I can successfully ask Evolution for --help or --version without requiring
a display, and those requests flow through gnome_program_init() as well.  I'll
take another look at this.
Comment 4 Milan Crha 2007-10-19 02:25:25 EDT
I think, in this particular case, we can safely skip gnome_program_init call and
look into parameters ourself, so no such thing like display will be required.
Comment 5 Matthew Barnes 2007-10-19 07:54:13 EDT
I took a closer look at this.

"evolution --force-shutdown" simply calls /usr/libexec/evolution/2.12/killev,
and that program does not require a display.  So you can call killev directly
from a console or remote machine.  I think this is an acceptable workaround and
it's not worth adding special logic to Evolution's option parsing just for this.
 Closing as WONTFIX.
Comment 6 Ralf Corsepius 2007-10-19 08:09:05 EDT
(In reply to comment #5)
> I took a closer look at this.
> 
> "evolution --force-shutdown" simply calls /usr/libexec/evolution/2.12/killev,
> and that program does not require a display.

I don't know what you did, and if you fixed this for FC8, but it definitely
doesn't work on FC7.
Comment 7 Ralf Corsepius 2007-10-19 08:10:37 EDT
Sorry, but  
"it" == invoking "evolution --force-shutdown" from a console (without DISPLAY).
Comment 9 Milan Crha 2007-10-19 10:34:53 EDT
Ralf, Matthew suggested a workaround for this, which is 'don't run evolution
--force-shutdown when you need to kill evolution, but run
/usr/libexec/evolution/2.12/killev on F8 instead'. Obviously, 2.12 is a current
version of evolution, which on F7 is 2.11 (check your /usr/libexec/evolution
directory for proper version number).
Comment 10 Ralf Corsepius 2007-10-19 11:16:20 EDT
(In reply to comment #9)
> Ralf, Matthew suggested a workaround for this, which is 'don't run evolution
> --force-shutdown when you need to kill evolution, but run
> /usr/libexec/evolution/2.12/killev on F8 instead'.
The issue here isn't finding a workaround, the issue is "evolution --shutdown"
to being non-functional (A bug in evolution).

=> The solution is not pointing out a work-around, the point is fixing 
"the application evolution" and to not shipping a broken application.

> Obviously, 2.12 is a current
> version of evolution, which on F7 is 2.11 (check your /usr/libexec/evolution
> directory for proper version number).

# rpm -q evolution
evolution-2.10.3-4.fc7
Comment 11 Matthew Barnes 2007-10-31 09:32:03 EDT
Closing again as WONTFIX since upstream indicated they're not interested in
fixing this either.  If you still feel this issue has not been addressed
properly, please take it up with FESCo.
Comment 12 Ralf Corsepius 2007-10-31 10:13:22 EDT
Thanks you very much for ignoring the brokenness and lack of usability of
evolution - It has once more been a pleasure being confronted with the warm
welcome and attitude of collaboration Redhat employers in Fedora are famous for.

Note You need to log in before you can comment on or make changes to this bug.