Bug 22438 - problem with capi4hylafax and tifflib
problem with capi4hylafax and tifflib
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libtiff (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-18 02:29 EST by Frank Baier
Modified: 2015-03-04 20:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 02:29:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Baier 2000-12-18 02:29:21 EST
I want to install the capi4hylafax paket from AVM and need tifflib.
the configure script get back, that tifflib is not installed but the 
installation is ok. tifflib and tifflib-devel are installed.
if I want to use ist (gcc -ltiff) i'll get an error from the compiler like:

/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o: In function 
`_start':
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o(.text+0x18): 
undefined '
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libtiff.so: undefined 
referenc'
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libtiff.so: undefined 
referenc'
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libtiff.so: undefined 
referenc'

you can get the avm packet from the avm Homepage (the package is for 
compiled for suse but can recompiled for different distibutions.
Comment 1 Phil Knirsch 2000-12-18 08:46:42 EST
I've verified your problem and came to the following conclusion:

It is a problem of the configure script that is being delivered with the tarball
of AVM. It does check for libtiff, which actually is installed, but it doesn't
check for the math library which is required for tiff programs to work and
therefore the test fails during linking as several mathematical symbols are
missing.

The solution is fairly simple.
Edit the configure.in script and prepend the line:

AC_CHECK_LIB(tiff, TIFFGetVersion, , AC_MSG_ERROR(libtiff not found))

with this line:

AC_CHECK_LIB(m, cos, , AC_MSG_ERROR(libm not found))

Afterwards run autoconf and do the rest as usual. This works for me then.

If you don't have autoconf installed or for whatever reason have to modify the
configure script directly simple search for all occurences of '-ltiff' and
change them to '-ltiff -lm', this will work as well.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.