Bug 2244291 - it does not shutdown
Summary: it does not shutdown
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 37
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://discussion.fedoraproject.org/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-10-15 14:17 UTC by Giulio
Modified: 2024-01-22 17:23 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-01-22 17:23:04 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
journal dmesg (89.56 KB, text/plain)
2023-10-16 18:03 UTC, Giulio
no flags Details

Description Giulio 2023-10-15 14:17:06 UTC
1. Please describe the problem:

When I initiate a shutdown in Fedora, the screen goes black, but my PC remains hot, indicating that it might not be shutting down properly. 

2. What is the Version-Release number of the kernel:

kernel-core-6.5.6-100.fc37 

I've tried also by booting from usb with Fedora 38 Live kernel 6.5.5-200 version F38-KDE-x86_64-LIVE-20230930.iso and the shutdown issue persists.

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

It is working on 6.4.15-100.fc37.x86_64 

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

I simply start the shutdown (from ui or command) and it does not complete.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

I've not tried

6. Are you running any modules that not shipped with directly Fedora's kernel?:

Nope

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Attached

Reproducible: Always

Comment 1 Giulio 2023-10-16 17:58:23 UTC
I confirm that the issue persists with Fedora 38 Live version 20230930 kernel 6.5.5-200.

Comment 2 Giulio 2023-10-16 18:03:05 UTC
Created attachment 1994201 [details]
journal dmesg

Comment 3 Giulio 2023-10-16 20:45:02 UTC
Related F38 issue: https://bugzilla.redhat.com/show_bug.cgi?id=2241279

Because it's an **strong text**upstream kernel bug: https://bugzilla.kernel.org/show_bug.cgi?id=217995

Comment 4 Adam Williamson 2023-10-16 21:41:16 UTC
A downstream bug report isn't really necessary, then, because the fix will naturally make its way into Fedora. It will be fixed in Rawhide when Rawhide gets 6.6-rc6, and in stable releases with the next 6.5.y upstream release, which will be released downstream.

Comment 5 Giulio 2023-10-17 14:19:51 UTC
It's the other way around, upstream teams often recognize their bugs by reading the issues opened downstream.

I've already tested 6.5.8-0.rc2.150.vanilla.fc37 and while it fixes the issue with the shutdown, it introduces another problem with my internal wifi, that is no longer recognize when I apply the patch.

Please, let me know if you need further info from me.

Comment 6 Aoife Moloney 2023-11-23 01:51:22 UTC
This message is a reminder that Fedora Linux 37 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 37 on 2023-12-05.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '37'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 37 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 7 Aoife Moloney 2024-01-22 17:23:04 UTC
Fedora Linux 37 entered end-of-life (EOL) status on 2023-12-05.

Fedora Linux 37 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.