Bug 2244744 - POSTIN scriptlet dbus-common
Summary: POSTIN scriptlet dbus-common
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: 40
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: BetaBlocker, F40BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2023-10-18 03:13 UTC by George R. Goffe
Modified: 2024-04-08 16:05 UTC (History)
40 users (show)

Fixed In Version: postfix-3.8.5-4.fc41 postfix-3.8.5-4.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2266335 (view as bug list)
Environment:
Last Closed: 2024-03-01 18:13:25 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Failed install logs Fedora-Everything-netinst-x86_64-40-20240219.n.0.iso (295.59 KB, application/octet-stream)
2024-02-20 22:57 UTC, Ian Laurie
no flags Details
strace output of the install (14.62 MB, application/x-xz)
2024-02-23 05:02 UTC, Orion Poplawski
no flags Details
screenshot of chroot failing (26.27 KB, image/png)
2024-02-23 05:32 UTC, Orion Poplawski
no flags Details
kickstart package list (3.44 KB, text/plain)
2024-02-23 18:23 UTC, Orion Poplawski
no flags Details

Description George R. Goffe 2023-10-18 03:13:44 UTC
Description of problem:
Install of .iso files Fedora-Everything-netinst-x86_64-Rawhide-20231015.n.0.iso.

Version-Release number of selected component (if applicable):
Multiple versions for the past week all fail with this scriptlet error message.

How reproducible:
All for "KDE work station"

Steps to Reproduce:
1.
2.
3.

Actual results:
Failure

Expected results:
Success

Additional info:

For the past week I have seen this failure. Here's the latest failure "Fedora-Everything-netinst-x86_64-Rawhide-20231015.n.0.iso". Starting with 20231009, ALL fail in VirtualBox.

Comment 1 Aoife Moloney 2024-02-15 22:59:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 40 development cycle.
Changing version to 40.

Comment 2 Ian Laurie 2024-02-18 03:32:14 UTC
Same issue here trying to install Xfce with dev tools from the "Everything" ISO.  The following images failed for me:

Fedora-Everything-netinst-x86_64-40-20240215.n.1.iso  
Fedora-Everything-netinst-x86_64-40-20240217.n.0.iso

Fedora-Everything-netinst-x86_64-Rawhide-20240216.n.0.iso

The exact error was:

===
The following error occurred while installing the payload.  This is a
fatal error and the installation will be aborted.

An error occurred during the transaction: Error in POSTIN scriptlet in
rpm package dbus-common
===

In my case I was also installing into a VirtualBox VM.

Comment 3 Ian Laurie 2024-02-18 23:38:13 UTC
I can confirm the exact same error happens when installing the above ISO on a Windows 10 hosted VirtualBox, so that pretty much eliminates host OS/kernel compatibility issues.  To be clear, the Linux host in my Comment#2 was Fedora 39, and in both cases VirtualBox is 7.0.14.

Currently the only work around I know of is to install Fedora 39 (which works) and do an in-place upgrade to 40 (which also works).

Comment 4 Ian Laurie 2024-02-19 22:44:47 UTC
FWIW UEFI (secure boot disabled though) installs fail with the same error.

Comment 5 Ian Laurie 2024-02-20 05:28:17 UTC
Apparently the Xfce Live images will install.  I booted and installed to HD the following images into a VirtualBox VM:

Fedora-Xfce-Live-x86_64-40-20240219.n.0.iso
Fedora-Xfce-Live-x86_64-Rawhide-20240219.n.0.iso

This is a more viable workaround than installing 39 then upgrading.

This doesn't prove anything, but it makes this less likely to be a VirtualBox problem and more likely to be a compose issue with the "Everything" ISO images, both Rawhide and Fedora 40 beta branch (not necessarily a dbus-common issue though).

Comment 6 Adam Williamson 2024-02-20 17:33:16 UTC
It doesn't really mean that. The difference is that live image installs perform no package transactions. They just, more or less, dump the live image onto the target disk.

An install from the network install images actually downloads RPMs and performs a package transaction, and it's during this that you're hitting the problem. It's natural the same would not happen on a live install.

Comment 7 Adam Williamson 2024-02-20 17:37:03 UTC
This seems pretty mysterious, honestly. dbus-common 's %post is just this:

if [ $1 -eq 1 ] && [ -x "/usr/lib/systemd/systemd-update-helper" ]; then 
    # Initial installation 
    /usr/lib/systemd/systemd-update-helper install-system-units dbus.socket || : 
fi 


 
if [ $1 -eq 1 ] && [ -x "/usr/lib/systemd/systemd-update-helper" ]; then 
    # Initial installation 
    /usr/lib/systemd/systemd-update-helper install-user-units dbus.socket || : 
fi

that's a couple of simple condition checks, and a couple of commands that end `|| :`, which is the Fedora recommended style for "exit 0 regardless of what the 'real' command did". It's hard to see how those could be doing anything wrong.

Can you get the output of `journalctl` from the installer env after the failure, and also /tmp/*log ?

Comment 8 Ian Laurie 2024-02-20 22:57:15 UTC
Created attachment 2017899 [details]
Failed install logs Fedora-Everything-netinst-x86_64-40-20240219.n.0.iso

Failed Xfce install logs from Fedora-Everything-netinst-x86_64-40-20240219.n.0.iso

Comment 9 Ian Laurie 2024-02-20 22:58:59 UTC
OK I used the image Fedora-Everything-netinst-x86_64-40-20240219.n.0.iso for this.

I got the logs off the system through the console on CTL+ALT+F5 and mounting an external USB device (flash drive) to /home.

# journalctl > /home/journalctl.log
# cp /tmp/*log /home

Comment 10 Adam Williamson 2024-02-21 01:12:36 UTC
Hmm, this is weird.

INFO:anaconda.modules.payloads.payload.dnf.transaction_progress:Installed: bash-5.2.26-3.fc40.x86_64 1707490454 156e073308cb28a5a699d6ffafc71cbd28487628fd05471e1978e4b9a5c7a802
INFO:anaconda.modules.payloads.payload.dnf.transaction_progress:Configuring (running scriptlet for): bash-5.2.26-3.fc40.x86_64 1707490454 156e073308cb28a5a699d6ffafc71cbd28487628fd05471e1978e4b9a5c7a802
INFO:anaconda.modules.payloads.payload.dnf.transaction_progress:Installed: dbus-common-1:1.14.10-3.fc40.noarch 1706087027 81bade4072aca4f5d22be29a916d9d0cfc9262a6c5d92ddfe750f7b8bf03f7c9
INFO:anaconda.modules.payloads.payload.dnf.transaction_progress:Configuring (running scriptlet for): dbus-common-1:1.14.10-3.fc40.noarch 1706087027 81bade4072aca4f5d22be29a916d9d0cfc9262a6c5d92ddfe750f7b8bf03f7c9
INFO:dnf.rpm:error: failed to exec scriptlet interpreter /bin/sh: No such file or directory

so we install bash, then we install dbus-common and run dbus-common's %post scriptlet, which calls /bin/sh , which isn't there. That seems pretty odd. There are actually several subsequent errors too:

ERROR:anaconda.modules.payloads.payload.dnf.transaction_progress:Error in POSTIN scriptlet in rpm package dbus-common
INFO:dnf.rpm:error: lua script failed: [string "%prein(authselect-libs-1.5.0-3.fc40.x86_64)"]:9: attempt to index a nil value (global 'f')

ERROR:dnf.rpm:Error in PREIN scriptlet in rpm package authselect-libs
INFO:dnf.rpm:error: authselect-libs-1.5.0-3.fc40.x86_64: install failed

INFO:dnf.rpm:error: failed to exec scriptlet interpreter /bin/sh: No such file or directory
warning: %post(hostname-3.23-12.fc40.x86_64) scriptlet failed, exit status 127

ERROR:dnf.rpm:Error in POSTIN scriptlet in rpm package hostname
INFO:dnf.rpm:error: failed to exec scriptlet interpreter /bin/sh: No such file or directory
warning: %post(p11-kit-trust-0.25.3-4.fc40.x86_64) scriptlet failed, exit status 127

ERROR:dnf.rpm:Error in POSTIN scriptlet in rpm package p11-kit-trust
INFO:dnf.rpm:error: failed to exec scriptlet interpreter /bin/sh: No such file or directory
error: %prein(ca-certificates-2023.2.62_v7.0.401-6.fc40.noarch) scriptlet failed, exit status 127

ERROR:dnf.rpm:Error in PREIN scriptlet in rpm package ca-certificates
INFO:dnf.rpm:error: ca-certificates-2023.2.62_v7.0.401-6.fc40.noarch: install failed

INFO:dnf.rpm:touch: cannot touch '/var/lib/rpm-state/systemd-resolved.initial-installation': No such file or directory

it almost seems like writing to the filesystem just is not happening correctly, or something.

Comment 11 Adam Williamson 2024-02-21 01:13:32 UTC
Definitely not dbus' fault, anyway.

Comment 12 Orion Poplawski 2024-02-23 04:12:20 UTC
Failing for me with a kickstart install to libvirt kvm VM on EL7 host.  Is dnf trying some strange parallel install stuff?  rpm not fsyncing after the bash install? i.e. could /bin/sh really not be (briefly) present when the dbus-common scriptlet is run?

Comment 13 Orion Poplawski 2024-02-23 05:02:03 UTC
Created attachment 2018265 [details]
strace output of the install

Well, it seems like /bin/sh should have existed:

  File: /mnt/sysroot/bin/sh -> bash
  Size: 4               Blocks: 0          IO Block: 4096   symbolic link
Device: 8,3     Inode: 531520      Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Context: system_u:object_r:bin_t:s0
Access: 2024-02-23 04:45:11.765996322 +0000
Modify: 2024-02-09 00:00:00.000000000 +0000
Change: 2024-02-23 04:45:11.141000818 +0000
 Birth: 2024-02-23 04:45:10.559005004 +0000

And then from the strace output:

3388  04:45:11.141877 renameat(38, "sh;65d82231", 38, "sh" <unfinished ...>

is when the rpm file is moved into place.

and this is when it fails to execute:

3436  04:45:11.826490 execve("/bin/sh", ["/bin/sh", "/var/tmp/rpm-tmp.WZQROB", "1"], 0x7ffcab5d6f68 /* 31 vars */ <unfinished ...>
3436  04:45:11.829394 <... execve resumed>) = -1 ENOENT (No such file or directory)

I've attached the full strace logs that was started during the transaction setup phase in case anyone else has some good ideas of what to look for.

Comment 14 Orion Poplawski 2024-02-23 05:11:34 UTC
Just to confirm the chroot order:

3388  04:45:11.680774 chroot("/mnt/sysroot/" <unfinished ...>
3388  04:45:11.680923 <... chroot resumed>) = 0
3388  04:45:11.762106 <... clone resumed>, child_tidptr=0x7f7245a00990) = 3436
3436  04:45:11.763495 <... getpid resumed>) = 3436
3388  04:45:11.848989 <... wait4 resumed>[{WIFEXITED(s) && WEXITSTATUS(s) == 127}], 0, NULL) = 3436
3388  04:45:11.860979 chroot("." <unfinished ...>

Comment 15 Orion Poplawski 2024-02-23 05:32:13 UTC
Created attachment 2018266 [details]
screenshot of chroot failing

So this is odd - I think in a previous install attempt the chroot succeeded but now it is failing with essentially the same error.  /bin/bash is clearly there but the chroot fails saying it doesn't exist.

Above is the strace output from another chroot attempt.

Comment 16 Orion Poplawski 2024-02-23 05:49:13 UTC
I think the problem is that glibc hasn't been installed yet as so no /lib64/ld-linux-x86_64.so.2 and libc.so.6.

I'm guessing we have some kind of new circular dependency that dnf/rpm is breaking in an unworkable order.

Comment 17 Orion Poplawski 2024-02-23 05:51:59 UTC
Assigning to rpm to start bringing in some other perspectives.

Comment 18 Adam Williamson 2024-02-23 15:55:29 UTC
Orion: what does the package list in your kickstart look like?

Comment 19 Orion Poplawski 2024-02-23 18:23:19 UTC
Created attachment 2018350 [details]
kickstart package list

Here's my %packages section

Comment 20 Orion Poplawski 2024-02-26 04:47:20 UTC
Is there a way to modify the dnf.conf that anaconda uses to add some debug options?

Comment 21 Panu Matilainen 2024-02-26 07:14:47 UTC
Yes, someone/something has introduced a dependency loop which blew up the delicate early bootstrap package set.

The best method for dealing with these is to find out a cut-off date where the breakage started, diff up the package set and look the new dependencies introduced. If that's not possible...

Rpm can output details with --deploops switch, but I don't know if there's any way to do that from current anaconda (it should be the default there too really). What I do is feed the package set into dnf download and then 'rpm -U --deploops --root /srv/test *.rpm'. It wont pinpoint the problem in any convenient way but it'll reduce the package set you need to look at a bit.

Comment 22 traxtopel 2024-02-26 10:20:34 UTC
Not sure if this helps but during my tests, I found that including fail2ban and its related packages (fail2ban-firewalld, fail2ban-selinux,fail2ban-sendmail, fail2ban-server) resulted in the same error
However, when I removed fail2ban, the issue was no longer present.

Package difference between good and bad build is 9 packages.
+fail2ban-1.0.2-12.fc40.noarch.rpm
+fail2ban-firewalld-1.0.2-12.fc40.noarch.rpm
+fail2ban-selinux-1.0.2-12.fc40.noarch.rpm
+fail2ban-sendmail-1.0.2-12.fc40.noarch.rpm
+fail2ban-server-1.0.2-12.fc40.noarch.rpm
+openssl-3.2.1-2.fc40.x86_64.rpm
+postfix-3.8.5-3.fc40.x86_64.rpm
+python3-pyasynchat-1.0.2-3.fc40.noarch.rpm
+python3-pyasyncore-1.0.2-3.fc40.noarch.rpm

Installing the other packages I do not see the problem
+openssl-3.2.1-2.fc40.x86_64.rpm
+postfix-3.8.5-3.fc40.x86_64.rpm
+python3-pyasynchat-1.0.2-3.fc40.noarch.rpm
+python3-pyasyncore-1.0.2-3.fc40.noarch.rpm

Not saying that fail2ban is the cause here, just I can reproduce the problem with it included in my package list.

Comment 23 traxtopel 2024-02-26 11:26:49 UTC
I am using the default template from the latest rawhide.
Add fail2ban fail, remove fail2ban succeeds.

%packages
@^workstation-product-environment
@anaconda-tools
aajohan-comfortaa-fonts
anaconda
anaconda-install-env-deps
anaconda-live
anaconda-webui
dracut-live
glibc-all-langpacks
gnome-initial-setup
kernel
kernel-modules
kernel-modules-extra
livesys-scripts
fail2ban
-@dial-up
-@input-methods
-@standard
-device-mapper-multipath
-fcoe-utils
-gfs2-utils
-reiserfs-utils
-sdubby
%end

Comment 24 traxtopel 2024-02-26 13:01:28 UTC
It appears that if I make sure that postfix is not installed, then the issue does not occur. I can build my custom image.

Comment 25 Panu Matilainen 2024-02-26 14:08:49 UTC
Okay this appears to be reproducable with just:
# dnf -y --releasever=40 --installroot=/srv/test install postfix

This is what rpm has to say about it:

warning: 1 Strongly Connected Components
warning: SCC #1: 105 members (20 external dependencies)
warning: 	xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	rpm-libs-4.19.1.1-1.fc40.x86_64
warning: 		-> libzstd-1.5.5-5.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> sqlite-libs-3.45.1-2.fc40.x86_64
warning: 		-> rpm-sequoia-1.6.0-2.fc40.x86_64
warning: 		-> popt-1.19-6.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> lua-libs-5.4.6-5.fc40.x86_64
warning: 		-> libcap-2.69-3.fc40.x86_64
warning: 		-> bzip2-libs-1.0.8-18.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	rpm-4.19.1.1-1.fc40.x86_64
warning: 		=> sed-4.9-1.fc40.x86_64
warning: 		-> rpm-libs-4.19.1.1-1.fc40.x86_64
warning: 		-> popt-1.19-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libarchive-3.7.2-3.fc40.x86_64
warning: 		=> findutils-1:4.9.0-8.fc40.x86_64
warning: 		-> curl-8.6.0-7.fc40.x86_64
warning: 		=> coreutils-9.4-6.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	policycoreutils-3.6-3.fc40.x86_64
warning: 		-> util-linux-2.40-0.9.rc1.fc40.x86_64
warning: 		-> sed-4.9-1.fc40.x86_64
warning: 		-> rpm-4.19.1.1-1.fc40.x86_64
warning: 		-> libsepol-3.6-3.fc40.x86_64
warning: 		-> libsemanage-3.6-3.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> libselinux-utils-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 		-> grep-3.11-7.fc40.x86_64
warning: 		-> gawk-5.3.0-3.fc40.x86_64
warning: 		-> diffutils-3.10-5.fc40.x86_64
warning: 		-> coreutils-9.4-6.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	postfix-2:3.8.5-3.fc40.x86_64
warning: 		=> systemd-255.3-1.fc40.x86_64
warning: 		-> policycoreutils-3.6-3.fc40.x86_64
warning: 		-> cyrus-sasl-lib-2.1.28-19.fc40.x86_64
warning: 		-> libnsl2-2.0.1-1.fc40.x86_64
warning: 		-> libicu-74.2-1.fc40.x86_64
warning: 		-> libdb-5.3.28-61.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		=> hostname-3.23-12.fc40.x86_64
warning: 		-> findutils-1:4.9.0-8.fc40.x86_64
warning: 		-> diffutils-3.10-5.fc40.x86_64
warning: 		=> alternatives-1.26-3.fc40.x86_64
warning: 		=> openssl-1:3.2.1-2.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	filesystem-3.18-8.fc40.x86_64
warning: 		-> postfix-2:3.8.5-3.fc40.x86_64
warning: 		=> setup-2.14.5-2.fc40.noarch
warning: 	gawk-5.3.0-3.fc40.x86_64
warning: 		-> readline-8.2-8.fc40.x86_64
warning: 		-> mpfr-4.2.1-3.fc40.x86_64
warning: 		-> gmp-1:6.2.1-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> filesystem-3.18-8.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	krb5-libs-1.21.2-5.fc40.x86_64
warning: 		-> sed-4.9-1.fc40.x86_64
warning: 		-> libverto-0.3.2-8.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> libcom_err-1.47.0-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> keyutils-libs-1.6.3-3.fc40.x86_64
warning: 		-> gawk-5.3.0-3.fc40.x86_64
warning: 		-> coreutils-9.4-6.fc40.x86_64
warning: 	libssh-0.10.6-4.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> krb5-libs-1.21.2-5.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libcurl-8.6.0-7.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> libssh-0.10.6-4.fc40.x86_64
warning: 		-> libpsl-0.21.5-3.fc40.x86_64
warning: 		-> libnghttp2-1.59.0-2.fc40.x86_64
warning: 		-> openldap-2.6.7-1.fc40.x86_64
warning: 		-> libidn2-2.3.7-1.fc40.x86_64
warning: 		-> krb5-libs-1.21.2-5.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libbrotli-1.1.0-3.fc40.x86_64
warning: 	curl-8.6.0-7.fc40.x86_64
warning: 		-> libcurl-8.6.0-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libtirpc-1.3.4-1.rc2.fc40.2.x86_64
warning: 		-> krb5-libs-1.21.2-5.fc40.x86_64
warning: 		-> libcom_err-1.47.0-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libnsl2-2.0.1-1.fc40.x86_64
warning: 		-> libtirpc-1.3.4-1.rc2.fc40.2.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	pam-1.6.0-2.fc40.x86_64
warning: 		-> setup-2.14.5-2.fc40.noarch
warning: 		-> libtirpc-1.3.4-1.rc2.fc40.2.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> libpwquality-1.4.5-9.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> libnsl2-2.0.1-1.fc40.x86_64
warning: 		-> gdbm-libs-1:1.23-6.fc40.x86_64
warning: 		-> libeconf-0.5.2-3.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> gdbm-1:1.23-6.fc40.x86_64
warning: 		-> authselect-1.5.0-4.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	util-linux-2.40-0.9.rc1.fc40.x86_64
warning: 		-> systemd-255.3-1.fc40.x86_64
warning: 		-> util-linux-core-2.40-0.9.rc1.fc40.x86_64
warning: 		-> pam-1.6.0-2.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libutempter-1.2.1-13.fc40.x86_64
warning: 		-> systemd-libs-255.3-1.fc40.x86_64
warning: 		-> libsmartcols-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> readline-8.2-8.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> ncurses-libs-6.4-12.20240127.fc40.x86_64
warning: 		-> libmount-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libfdisk-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libcap-ng-0.8.4-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 		=> coreutils-9.4-6.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 		-> authselect-libs-1.5.0-4.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	systemd-255.3-1.fc40.x86_64
warning: 		-> libpwquality-1.4.5-9.fc40.x86_64
warning: 		-> pcre2-10.42-2.fc40.2.x86_64
warning: 		-> libidn2-2.3.7-1.fc40.x86_64
warning: 		-> diffutils-3.10-5.fc40.x86_64
warning: 		-> systemd-pam-255.3-1.fc40.x86_64
warning: 		-> systemd-libs-255.3-1.fc40.x86_64
warning: 		-> libzstd-1.5.5-5.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> libseccomp-2.5.3-8.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> libmount-2.40-0.9.rc1.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> lz4-libs-1.9.4-6.fc40.x86_64
warning: 		-> kmod-libs-31-5.fc40.x86_64
warning: 		-> libfdisk-2.40-0.9.rc1.fc40.x86_64
warning: 		=> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> libcap-2.69-3.fc40.x86_64
warning: 		-> bzip2-libs-1.0.8-18.fc40.x86_64
warning: 		-> libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 		=> grep-3.11-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> dbus-1:1.14.10-3.fc40.x86_64
warning: 		=> coreutils-9.4-6.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 		-> util-linux-2.40-0.9.rc1.fc40.x86_64
warning: 		-> util-linux-core-2.40-0.9.rc1.fc40.x86_64
warning: 	authselect-libs-1.5.0-4.fc40.x86_64
warning: 		-> systemd-255.3-1.fc40.x86_64
warning: 		-> sed-4.9-1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> coreutils-9.4-6.fc40.x86_64
warning: 	authselect-1.5.0-4.fc40.x86_64
warning: 		-> popt-1.19-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> authselect-libs-1.5.0-4.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	systemd-pam-255.3-1.fc40.x86_64
warning: 		-> systemd-255.3-1.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> libcap-2.69-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libutempter-1.2.1-13.fc40.x86_64
warning: 		-> systemd-255.3-1.fc40.x86_64
warning: 		=> shadow-utils-2:4.15.0rc2-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	fedora-gpg-keys-40-0.3.noarch
warning: 		-> filesystem-3.18-8.fc40.x86_64
warning: 	fedora-repos-40-0.3.noarch
warning: 		-> fedora-release-40-0.34.noarch
warning: 		-> fedora-gpg-keys-40-0.3.noarch
warning: 	fedora-release-common-40-0.34.noarch
warning: 		-> fedora-repos-40-0.3.noarch
warning: 		-> fedora-release-40-0.34.noarch
warning: 	fedora-release-40-0.34.noarch
warning: 		-> fedora-release-common-40-0.34.noarch
warning: 	setup-2.14.5-2.fc40.noarch
warning: 		-> fedora-release-40-0.34.noarch
warning: 	shadow-utils-2:4.15.0rc2-1.fc40.x86_64
warning: 		-> setup-2.14.5-2.fc40.noarch
warning: 		-> libsemanage-3.6-3.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> libeconf-0.5.2-3.fc40.x86_64
warning: 		-> libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libattr-2.5.2-3.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 	dbus-broker-35-4.fc40.x86_64
warning: 		=> shadow-utils-2:4.15.0rc2-1.fc40.x86_64
warning: 		-> systemd-libs-255.3-1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> expat-2.6.0-1.fc40.x86_64
warning: 		-> libcap-ng-0.8.4-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 		-> dbus-common-1:1.14.10-3.fc40.noarch
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	dbus-1:1.14.10-3.fc40.x86_64
warning: 		-> dbus-broker-35-4.fc40.x86_64
warning: 	basesystem-11-20.fc40.noarch
warning: 		=> setup-2.14.5-2.fc40.noarch
warning: 		=> filesystem-3.18-8.fc40.x86_64
warning: 	glibc-2.39-2.fc40.x86_64
warning: 		-> glibc-minimal-langpack-2.39-2.fc40.x86_64
warning: 		-> glibc-common-2.39-2.fc40.x86_64
warning: 		=> basesystem-11-20.fc40.noarch
warning: 	gdbm-libs-1:1.23-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	gdbm-1:1.23-6.fc40.x86_64
warning: 		-> readline-8.2-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> gdbm-libs-1:1.23-6.fc40.x86_64
warning: 	cyrus-sasl-lib-2.1.28-19.fc40.x86_64
warning: 		-> gdbm-libs-1:1.23-6.fc40.x86_64
warning: 		-> libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	openldap-2.6.7-1.fc40.x86_64
warning: 		-> cyrus-sasl-lib-2.1.28-19.fc40.x86_64
warning: 		-> libtool-ltdl-2.4.7-10.fc40.x86_64
warning: 		-> libevent-2.1.12-12.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libunistring-1.1-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libidn2-2.3.7-1.fc40.x86_64
warning: 		-> libunistring-1.1-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libpsl-0.21.5-3.fc40.x86_64
warning: 		-> libunistring-1.1-7.fc40.x86_64
warning: 		-> libidn2-2.3.7-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	cracklib-2.9.11-5.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> gzip-1.13-1.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	libpwquality-1.4.5-9.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> cracklib-2.9.11-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	grep-3.11-7.fc40.x86_64
warning: 		-> pcre2-10.42-2.fc40.2.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	ca-certificates-2023.2.62_v7.0.401-6.fc40.noarch
warning: 		=> sed-4.9-1.fc40.x86_64
warning: 		=> p11-kit-trust-0.25.3-4.fc40.x86_64
warning: 		=> p11-kit-0.25.3-4.fc40.x86_64
warning: 		=> grep-3.11-7.fc40.x86_64
warning: 		=> coreutils-9.4-6.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> ca-certificates-2023.2.62_v7.0.401-6.fc40.noarch
warning: 	libevent-2.1.12-12.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	kmod-libs-31-5.fc40.x86_64
warning: 		-> libzstd-1.5.5-5.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	rpm-sequoia-1.6.0-2.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	openssl-1:3.2.1-2.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> coreutils-9.4-6.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	coreutils-9.4-6.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> gmp-1:6.2.1-8.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> libcap-2.69-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libattr-2.5.2-3.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 	gzip-1.13-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> coreutils-9.4-6.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	libarchive-3.7.2-3.fc40.x86_64
warning: 		-> libzstd-1.5.5-5.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> libxml2-2.12.5-1.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> lz4-libs-1.9.4-6.fc40.x86_64
warning: 		-> openssl-libs-1:3.2.1-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> bzip2-libs-1.0.8-18.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 	libeconf-0.5.2-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> libeconf-0.5.2-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 	libcap-2.69-3.fc40.x86_64
warning: 		-> pam-libs-1.6.0-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	systemd-libs-255.3-1.fc40.x86_64
warning: 		-> libzstd-1.5.5-5.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> lz4-libs-1.9.4-6.fc40.x86_64
warning: 		-> libcap-2.69-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	util-linux-core-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> ncurses-libs-6.4-12.20240127.fc40.x86_64
warning: 		-> systemd-libs-255.3-1.fc40.x86_64
warning: 		-> libsmartcols-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> libmount-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 	readline-8.2-8.fc40.x86_64
warning: 		-> ncurses-libs-6.4-12.20240127.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	expat-2.6.0-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libmount-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 	libfdisk-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libblkid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> libuuid-2.40-0.9.rc1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	gmp-1:6.2.1-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	mpfr-4.2.1-3.fc40.x86_64
warning: 		-> gmp-1:6.2.1-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libxcrypt-4.4.36-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	findutils-1:4.9.0-8.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	sed-4.9-1.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libacl-2.3.2-1.fc40.x86_64
warning: 	libsepol-3.6-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libselinux-utils-3.6-4.fc40.x86_64
warning: 		-> libsepol-3.6-3.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> pcre2-10.42-2.fc40.2.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libsemanage-3.6-3.fc40.x86_64
warning: 		-> libsepol-3.6-3.fc40.x86_64
warning: 		-> libselinux-3.6-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> bzip2-libs-1.0.8-18.fc40.x86_64
warning: 		-> audit-libs-4.0-8.fc40.x86_64
warning: 	libselinux-3.6-4.fc40.x86_64
warning: 		-> libsepol-3.6-3.fc40.x86_64
warning: 		-> pcre2-10.42-2.fc40.2.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	alternatives-1.26-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	p11-kit-trust-0.25.3-4.fc40.x86_64
warning: 		-> libtasn1-4.19.0-6.fc40.x86_64
warning: 		-> p11-kit-0.25.3-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		=> alternatives-1.26-3.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	libacl-2.3.2-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> libattr-2.5.2-3.fc40.x86_64
warning: 	libcap-ng-0.8.4-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	audit-libs-4.0-8.fc40.x86_64
warning: 		-> libcap-ng-0.8.4-4.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libseccomp-2.5.3-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libxml2-2.12.5-1.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> xz-libs-5.4.6-1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	sqlite-libs-3.45.1-2.fc40.x86_64
warning: 		-> zlib-ng-compat-2.1.6-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libattr-2.5.2-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	lz4-libs-1.9.4-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	popt-1.19-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	ncurses-libs-6.4-12.20240127.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	bash-5.2.26-3.fc40.x86_64
warning: 		-> ncurses-libs-6.4-12.20240127.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> filesystem-3.18-8.fc40.x86_64
warning: 	dbus-common-1:1.14.10-3.fc40.noarch
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	hostname-3.23-12.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		=> bash-5.2.26-3.fc40.x86_64
warning: 	glibc-common-2.39-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 		-> bash-5.2.26-3.fc40.x86_64
warning: 	glibc-minimal-langpack-2.39-2.fc40.x86_64
warning: 		-> glibc-common-2.39-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libverto-0.3.2-8.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	bzip2-libs-1.0.8-18.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libnghttp2-1.59.0-2.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libffi-3.4.4-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	p11-kit-0.25.3-4.fc40.x86_64
warning: 		-> libtasn1-4.19.0-6.fc40.x86_64
warning: 		-> libffi-3.4.4-7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libzstd-1.5.5-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libtasn1-4.19.0-6.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	pcre2-10.42-2.fc40.2.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libcom_err-1.47.0-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	lua-libs-5.4.6-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libicu-74.2-1.fc40.x86_64
warning: 		-> libstdc++-14.0.1-0.7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libstdc++-14.0.1-0.7.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	keyutils-libs-1.6.3-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libsmartcols-2.40-0.9.rc1.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	diffutils-3.10-5.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libdb-5.3.28-61.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libtool-ltdl-2.4.7-10.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64
warning: 	libbrotli-1.1.0-3.fc40.x86_64
warning: 		-> glibc-2.39-2.fc40.x86_64

Comment 26 Panu Matilainen 2024-02-26 14:28:24 UTC
And here's the smoking gun:

warning: 	filesystem-3.18-8.fc40.x86_64
warning: 		-> postfix-2:3.8.5-3.fc40.x86_64

There is no such literal dependency in filesystem of course, but...

%attr(775,root,mail) /var/spool/mail
               ^^^^

...which now turns into a dependency:

# repoquery -q --disablerepo="*" --enablerepo=fedora --releasever=40 --recommends filesystem
group(mail)

# repoquery -q --disablerepo="*" --enablerepo=fedora --releasever=40 --whatprovides "group(mail)"
cyrus-imapd-0:3.8.1-8.fc40.x86_64
postfix-2:3.8.5-3.fc40.x86_64
setup-0:2.14.5-2.fc40.noarch

The "mail" group must be present before filesystem can be properly installed. It's normally satisfied by setup, which is okay. But for some reason it resolves to postfix when it happens to be around. The same exact issue is reproducable with cyrus-imapd, for the same reason.

This is like any dependency with multiple providers: random things happen at inconvenient times. There can really only be one provider for users and groups.

Comment 27 Panu Matilainen 2024-02-26 15:18:00 UTC
Hmm, probably the reason why it ends up picking either of those two over the setup packages is that rpm's dependency resolution is tuned to favor native arch packages. That's what you want for choosing between i386 and x86_64 packages for example, but for this particular case a better result would probably achieved by favoring fewer dependencies.

So it's possible some other algorithm could behave better, but between multiple equal providers it's always a lottery in the end.

Comment 28 Orion Poplawski 2024-02-27 02:27:22 UTC
Is there every a reason one would not want to pull in the setup package?  It seems that the easiest would be for postfix and cyrus-imapd to stop providing group(mail) and just depend on setup for that.  I suppose some kind of container case?

Comment 29 Panu Matilainen 2024-02-27 06:55:57 UTC
Setup is a mandatory package, always been. It's a hard dependency of the filesystem package.

It seems that both those packages only added the mail group sometime last year. In both cases it's a locally maintained sysusers file so dropping it is really easy, and the right thing to do.

Comment 30 Petr Pisar 2024-02-27 10:03:55 UTC
Why does postfix provide "group(mail)"? 

"%attr(775,root,mail) /var/spool/mail" should turn into "Requires: group(mail)". Not a Provides.

According to guidelines "group(mail)" is statically allocated by "setup" <https://docs.fedoraproject.org/en-US/packaging-guidelines/UsersAndGroups/#_list_of_statically_allocated_uidgid_and_corresponding_package>.

Comment 31 Panu Matilainen 2024-02-27 10:09:35 UTC
As I said in my previous comment:

> In both cases it's a locally maintained sysusers file so dropping it is really easy, and the right thing to do.

[pmatilai🎩︎localhost postfix]$ cat postfix.sysusers
u postfix 89 - /var/spool/postfix /sbin/nologin
g postdrop 90
g mail 12
m postfix mail

[pmatilai🎩︎localhost cyrus-imapd]$ cat cyrus-imapd.sysusers
#Type Name     ID             GECOS                 Home directory Shell
g     saslauth 76
g     mail     12
u     cyrus    76:mail        "Cyrus IMAP Server"   /var/lib/imap  /sbin/nologin
m     cyrus    saslauth

As to why these have been added, I don't know. But good point on the static allocations, then it's really just a simple bug in both packages and this should assigned to one and cloned for the other.

Comment 32 František Zatloukal 2024-02-27 10:44:42 UTC
Discussed during the 2024-02-26 blocker review meeting: [1]

The decision to classify this bug as a AcceptedBlocker (Beta) was made:

"When installing with the generic network install image, interactively selecting a package set other than the default must work."

[1] https://meetbot.fedoraproject.org/blocker-review_matrix_fedoraproject-org/2024-02-26/f40-blocker-review.2024-02-26-17.01.log.html

Comment 33 Orion Poplawski 2024-02-27 14:43:53 UTC
Okay, alerting cyrus-imapd and postfix to remove mail from their sysusers setups.

Comment 34 Martin Osvald 🛹 2024-02-27 15:38:34 UTC
Regarding the cyrus-imapd, not sure why I ended up creating the mail group by that line at that time (I guess didn't realize it was already in /etc/group provided by setup), it was part of systemd sysusers switch change:

commit: https://src.fedoraproject.org/rpms/cyrus-imapd/c/6b9850d1a9e56db03f5be62dfe1776fa2f1cb864
~~~
g     mail     12
~~~

Also didn't foresee this could create such a dependency loop. :/

Comment 35 Fedora Update System 2024-02-27 16:14:29 UTC
FEDORA-2024-ce1fb5a0db (postfix-3.8.5-4.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-ce1fb5a0db

Comment 36 Martin Osvald 🛹 2024-02-27 16:22:42 UTC
cloned this for cyrus-imapd: https://bugzilla.redhat.com/show_bug.cgi?id=2266335

Comment 37 Fedora Update System 2024-02-27 16:33:13 UTC
FEDORA-2024-5d99498b67 (postfix-3.8.5-4.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-5d99498b67

Comment 38 Fedora Update System 2024-02-28 22:40:55 UTC
FEDORA-2024-5d99498b67 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-5d99498b67`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-5d99498b67

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 39 Ian Laurie 2024-02-28 22:54:22 UTC
We really need a composed ISO to test this, and on bohdi both packages at least appear to be stuck as part of the beta branch freeze (despite this being a beta blocker).

Comment 40 Adam Williamson 2024-02-28 23:03:17 UTC
That boxout on Bodhi is shown on all updates, it doesn't know or care whether they're blocker/FE fixes. Blocker/FE fixes will get pushed through the freeze, but they have to meet karma or time requirements first. That one also is stuck in gating because of a whole big mess I've been helping to fix all day.

Comment 41 Adam Williamson 2024-02-28 23:04:15 UTC
I would *think* this should be testable by adding an additional repository with the fixed postfix and cyrus-imapd packages in it to the kickstart...

Comment 42 Adam Williamson 2024-02-28 23:04:41 UTC
...or just using updates-testing once they're pushed there, I guess.

Comment 43 Fedora Update System 2024-02-29 00:17:19 UTC
FEDORA-2024-ce1fb5a0db (postfix-3.8.5-4.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 44 Orion Poplawski 2024-02-29 02:21:27 UTC
My test with current koji/rawhide shows this to be resolved.  Thank you everyone for working on this issue - I think it was a good example of a number of people pitching in with their own expertise.

Comment 45 Martin Osvald 🛹 2024-02-29 08:35:08 UTC
(In reply to Orion Poplawski from comment #44)
> My test with current koji/rawhide shows this to be resolved.  Thank you
> everyone for working on this issue - I think it was a good example of a
> number of people pitching in with their own expertise.

which iso did you test? It contradicts https://bugzilla.redhat.com/show_bug.cgi?id=2266335#c7

Comment 46 Orion Poplawski 2024-02-29 15:45:14 UTC
on my rawhide box:

dnf --releasever=40 --disablerepo=rawhide\* --enablerepo=fedora,updates --installroot=/srv/test -y groupinstall 'System Tools' -> fails with error: failed to exec scriptlet interpreter /bin/sh: No such file or directory

dnf --releasever=40 --disablerepo=rawhide\* --enablerepo=fedora,updates,updates-testing --installroot=/srv/test -y groupinstall 'System Tools' -> succeeds

Re-opening because this is an F40 issue, not rawhide.

Comment 47 Fedora Update System 2024-03-01 18:13:25 UTC
FEDORA-2024-5d99498b67 (postfix-3.8.5-4.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.