Bug 224608 - Allow unique attributes in resources to collide if the resources will never coexist
Summary: Allow unique attributes in resources to collide if the resources will never c...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 17:48 UTC by Lon Hohberger
Modified: 2009-04-16 20:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 15:08:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lon Hohberger 2007-01-26 17:48:08 UTC
Description of problem:  First appearance of this feature is here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=224462

A user was attempting to use the same mountpoint for two different file systems
as part of two independent services which would never coexist due to restricted
failover domain configurations.

Actual results: Illegal configuration.

Expected results: Not fully explored.

This might not be possible since rgmanager was designed to allow coexistence of
all resources on a single node for a given configuration - even if the requisit
device(s) were not present for all nodes.

Since placement of resources is separate from resource definitions, this is
difficult to solve using failover domains.  However, it may be possible to solve
this at least partially using the inter-service dependencies which are being
explored:  If two services have 'colocate' set to 'never', it may be permissable
to allow collisions of "unique" attributes between those services' private
resources.

[Note: Primary attributes will *not* be allowed to collide, their resource
placement policies notwithstanding.]

This is a feature request.

Comment 1 Lon Hohberger 2007-01-26 17:56:58 UTC
Additionally, clurgmgrd should log things (not just print to stdout) when
resource collisions are found.

Comment 2 Lon Hohberger 2007-01-26 22:41:31 UTC
Logging part is in CVS in all branches that are not frozen or obsolete.

Comment 3 Lon Hohberger 2007-05-03 15:08:24 UTC
This would be a complicated change for little actual benefit.


Note You need to log in before you can comment on or make changes to this bug.