Bug 224645 - cups ignores configured job options
cups ignores configured job options
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-01-26 15:51 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 08:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-01-26 15:51:46 EST
Description of problem:

If I will print like that:

   lp -o cpi=9.25 -o lpi=5.5 -o page-left=18 -o page-right=18 \
     -o page-top=36 -o page-bottom=36 \
     -o wrap=true /etc/cups/pstoraster.convs

then printing results are as expected.  That means bigger fonts
and smaller margin than those used by default.

OTOH if I will edit accordingly /etc/cups/printers.conf, or
/etc/cups/lpoptions or edit those values using system-config-printer
then results are completely ignored and does not matter which values
I am using a printout comes exactly the same in a default layout -
whatever that happens to be.

This is a sharp regression in a comparison with FC5 when changing
configuration in a similar way actually causes print changes.
I am not sure what is a situation on FC6, and I cannot check it at
this moment, but I suspect that similar like in rawhide.

Version-Release number of selected component (if applicable):
cups-1.2.7-7.fc7

How reproducible:
always
Comment 1 Tim Waugh 2007-02-05 09:04:29 EST
For the 'completely ignored' case, how are you submitting the print job?
Comment 2 Michal Jaegermann 2007-02-05 10:58:58 EST
One of possible ways to submit and have options ignored would be
'lpr /etc/cups/pstoraster.convs',  That, to be sure, after job options
were set and cups service restarted.
Comment 3 Tim Waugh 2007-02-08 08:39:10 EST
I can't reproduce this.  Setting those values in the 'Job Options' tab using
system-config-printer gives me exactly the same results when printing using
'lpr' or 'lp', either on the same server or on a different client machine.

Perhaps you edited /etc/cups/lpoptions and printed from a different machine?  In
that case, it is expected behaviour (and the reason for the 'Job Options' tab
being introduced).
Comment 4 Michal Jaegermann 2007-02-08 13:04:48 EST
> Perhaps you edited /etc/cups/lpoptions and printed from a different 
> machine?

:-) Nope.  I have only one machine with a rawhide installation.

'system-config-printer' on FC6 and later apparently does not edit
/etc/cups/lpoptions at all but only /etc/cups/printers.conf writing
option lines to the bottom of a description of a given printer.
Only when I got nowhere with that I edited myself /etc/cups/lpoptions
in the same style as this was happening in FC5 to see if this will
change anything.  After that I restarted cups and tried to print
again.  No changes.  I still have printouts.  Do you want to see
scans?

In any case - recent changes of 'system-config-printer' (now in 'testing'
for FC5 and FC6) may have some effects here.  A bit later I will try to
retest and I will see what I am getting.

There are various "mysteries" in the whole system and they apparently
can be of "now you see it, now you don't" kind.  Like what I described
in bug 225537.
Comment 5 Michal Jaegermann 2007-02-08 17:43:24 EST
Clearly something changed in the meantime at least on a rawhide
installation. cups and foomatic are the same as they were before
(cups-1.2.7-7.fc7, foomatic-3.0.2-45.fc7) while
system-config-printer-0.7.50-1.fc7 was installed today.  Is anything
else which may affect results.

In the meantime I also deleted and reinstalled from scratch the
print queue in question, which is the _only_ one present on that
installation and what bugs me is that results of such actions
appear to be mostly unpredictable.

So here are results as for today.
A reinstalled from scratch a queue which is printing on a printer
located on a network, using built-in JetDirect server, and
Samsung ML-2250 pxlmono driver.  All tests are printed as
'lpr /etc/cups/pstoraster.convs'.

1.  A newly installed, from scratch, printer queue; no touching
of job options - a printer prints in quite a big font and attempts
to do that from the left margin loosing leading two characters on
every line.

2.  Job options with default values are added for cpi, lpi and
page margins - fonts get smaller, although not that small as on
older trials, I get left and right margins so the whole text is there,
and also 'wrap' is clearly set to "true" even if it was not touched.
Quite a few lines is wrapped making results rather unacceptable.

Nothing in 'lpoptions'.  New options show up in printers.conf.
Exiting from 'system-config-printer' after options were changed does
not restart cups so new configuration is available only after
an explicit 'service cups restart'.

3. After I edit "Job Options" to values like those in the original
report I am getting a printout in a shape I tried to achieve in the
first place.  Hopefuly the next time I will see something similar.
Comment 6 Tim Waugh 2007-02-09 04:33:25 EST
> In the meantime I also deleted and reinstalled from scratch the
> print queue in question

*sigh* I wish you'd kept it so we could try to diagnose the problem.

> Nothing in 'lpoptions'.  New options show up in printers.conf.
> Exiting from 'system-config-printer' after options were changed
> does not restart cups so new configuration is available only after
> an explicit 'service cups restart'.

No, you're wrong about this.  CUPS does not need restarting here.  CUPS itself
wrote printers.conf from its in-memory configuration.

There is a separate bug report against paps for better defaults for text printouts.
Comment 7 Michal Jaegermann 2007-02-09 12:23:37 EST
> *sigh* I wish you'd kept it so we could try to diagnose the problem.

I am afraid that I did that at a time when I was trying to figure out
why sometimes I am getting a scaled printouts and sometimes I don't.
It is impossible to tell if somebody will start to ask questions
about a bug report in a week, or a month, or in a year, or never.

All that unpredictable behaviour of CUPS is extremely frustrating.
Over years on many installations, not necessarily Fedora or Red Hat,
it gave me many so many troubles that now I simply expect that
something bad will surely happen and nobody will know why or will
come with clues how to diagnose the thing.

Note You need to log in before you can comment on or make changes to this bug.