Bug 2247508 - ldconfig: /lib64/libproxy.so.1 is not a symbolic link
Summary: ldconfig: /lib64/libproxy.so.1 is not a symbolic link
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libproxy
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-11-01 17:49 UTC by Vadim Raskhozhev
Modified: 2023-11-07 01:39 UTC (History)
3 users (show)

Fixed In Version: libproxy-0.5.3-3.fc39
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-07 01:39:32 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Vadim Raskhozhev 2023-11-01 17:49:11 UTC
After upgrading to Fedora 39 ldconfig(8) on each invocation complains the /lib64/libproxy.so.1 is not a symbolic link.

Reproducible: Always

Steps to Reproduce:
1. Upgrade an installation of F38 to 39.
2. Launch ldconfig

Actual Results:  
ldconfig: /lib64/libproxy.so.1 is not a symbolic link

Expected Results:  
Nothing

Haven't tested the fresh F39 installation. Cannot reproduce the behaviour with `docker run --rm fedora:39 sh -c 'dnf -y install libproxy && stat /lib64/libproxy.* && ldconfig` — libproxy.so.1 still is not a link but ldconfig does not object.

Comment 1 Fedora Update System 2023-11-02 11:45:35 UTC
FEDORA-2023-48f29a33af has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-48f29a33af

Comment 2 Fedora Update System 2023-11-03 02:08:25 UTC
FEDORA-2023-48f29a33af has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-48f29a33af`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-48f29a33af

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2023-11-07 01:39:32 UTC
FEDORA-2023-48f29a33af has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.