Bug 22487 - Mount Error when attempting to mount fat16 partion.
Summary: Mount Error when attempting to mount fat16 partion.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-19 03:51 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-04 14:21:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-19 03:51:38 UTC
I created a fat16 disk partion /dev/sda2 using fdisk.  I then attempted to mount it with Linuxconf.  I received a "wrong major or minor number"
error.  I was not able to mount the partition.

Comment 1 Bernhard Rosenkraenzer 2000-12-21 13:10:53 UTC
Did you make a filesystem on the new partition?
Did you get a warning from fdisk saying "device busy, reboot to ensure the
partition table is updated"?

Comment 2 Need Real Name 2000-12-21 22:45:02 UTC
Yes I did create a new partition and yes I did receive this message and the 
machine was rebooted.  A friend said he was able to get this to work with 5.2
but he has IDE drives.  I have SCSI.  I don't know if this could make a 
difference.  I am running the 2.2.16 kernel.

Comment 3 Need Real Name 2000-12-26 19:02:29 UTC
I was hoping this was something simple.  Like maybe I need an updated version 
of mount or something.  I really would like to get this thing up and running.  
Could you give me a solution.  I will provide more detail to assist you.  I am 
running a Adaptec 29160 SCSI adapter with an IBM drive @ 80 Mb per sec.  I 
replaced my existing adapter with this new one.  The Linux was already 
installed when I made this change.  When I boot it does see and use a 160 Mb 
transfer speed Adaptec driver.  I can run Linux with no other difficulties.


Comment 4 Derek Tattersall 2000-12-26 20:02:26 UTC
Doing a 6.2 install I created a 50M dos partition.  On reboot the partition was
not mounted.  I use mkdosfs to make a dos filesystem on /dev/sda2.  I made a
mount point /mnt/dos.  I went into linuxconf and down to the local filesystems
menu, mount, and then specified the device was
/dev/sda2, they type was msdos and the mount point was /mnt/dos.  linuxconf had
no trouble mounting the partition.  

Did you 
1  make a dos filesystem on the partition?
2   create a mount point?
3   Fill in the required parameters on the mount menu?

if you have set up all of the above, you should be able to write at a prompt:
mount -t msdos /dev/sda2 /mnt/dos

Comment 5 Need Real Name 2000-12-27 09:24:40 UTC
Some additional information that may help in this case:

I went into fdisk.  Created a parition of type 6 with no problems.  Rebooted the machine.  Confirmed the partion was there.
Went into linuxconf and created the filesystem under Linux.  Established the mount point as /mnt/data.  chmod 775.
I recieved the following errors when attempting to mount this partion as type msdos.

Checking base configuration
Checkin Kernel's modules
Mounting local volumes
Executing /bin/mount -t msdos -o exec, dev, suid, rw /dev/sda2 /mnt/data
* mount fs type msdos not supported by kernel
* return 32

Checking file permissions
Checking LILO
Executing some Sysv init scripts
Executing /dev/rc.d/rc5.d/S10network.reload
Executing /dev/rc.d/rc5.d/S14nfslock.restart

Restarting NFS file locking services.rpc.lockd [FAILED] locksvr: Function not implemented
[FAILED] rpc.statd [OK] [OK] done.

Hopefully this helps you identify my problem.

Comment 6 Bernhard Rosenkraenzer 2001-01-04 14:21:06 UTC
Try using mount -t vfat instead of mount -t msdos.
Are you still getting any errors?

Comment 7 Bernhard Rosenkraenzer 2001-01-12 14:17:16 UTC
Closing due to lack of feedback

Comment 8 Need Real Name 2001-01-19 09:07:04 UTC
I didn't respond because it took too long to get any answers.  I didn't want to wait any longer and decided to buy
the 7.0 version.  Great marketing tool.  Just buy the new version when something doesn't work.  Anyway,
I just wanted to let you know that I solved the problem by purchasing version 7.0.




Note You need to log in before you can comment on or make changes to this bug.