Bug 2248743 - libvterm 0.3 is starting to get behind
Summary: libvterm 0.3 is starting to get behind
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvterm
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/agriffis/neovim/is...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-11-08 16:35 UTC by Hécate
Modified: 2024-03-25 04:25 UTC (History)
5 users (show)

Fixed In Version: libvterm-0.3.3-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-25 02:43:00 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Fedora Package Sources libvterm pull-request 4 0 None None None 2023-11-22 13:10:47 UTC

Description Hécate 2023-11-08 16:35:30 UTC
Software projects are starting to move to 0.3.3 (see https://github.com/neovim/neovim/pull/25777) and this is preventing nightly builds COPRs from working.

See ticket at https://github.com/agriffis/neovim/issues/24

Reproducible: Always

Comment 1 Aron Griffis 2023-11-08 17:48:42 UTC
Next neovim (after 0.9.4) will require 0.3.3 though I don't know the details why.

Upstream project is a little wonky, with outdated home page at http://www.leonerd.org.uk/code/libvterm/

and latest release at https://github.com/neovim/libvterm/archive/v0.3.3.tar.gz

and I have no idea where to find a changelog

Comment 2 Aron Griffis 2023-11-08 18:22:29 UTC
I filed a bug report against libvterm to update its home page with the latest tarball

https://bugs.launchpad.net/libvterm/+bug/2043041

Comment 3 Andreas Schneider 2023-11-09 16:19:45 UTC
You can find the changelog here: https://bazaar.launchpad.net/~libvterm/libvterm/trunk/changes/839

I've talked to Dundar looks like people thoguht 0.3 is buggy and it should be updated to 0.3.3. Do you want to create a PR?

https://src.fedoraproject.org/rpms/libvterm/pull-requests

Comment 4 Andreas Schneider 2023-11-09 17:29:39 UTC
Ok, it fixes bugs with neovim, so we should package it for all distros.

Comment 5 Aron Griffis 2023-11-15 18:12:00 UTC
Sure, I'll take a stab at it

Comment 6 Aron Griffis 2023-11-15 18:29:33 UTC
Well I succeeded locally, and I made a fork at https://src.fedoraproject.org/fork/agriffis/rpms/libvterm

but I can't figure out how to push to it. It's been a number of years since I've pushed to src.fedoraproject.org and I've lost how to authenticate.

Any suggestions for where I should look or who I should ask for help? The pagure docs mention SSH stuff that doesn't appear in my settings, and the package maintainer docs say to make an API key with capabilities that aren't listed in the UI.

Comment 7 Andreas Schneider 2023-11-22 10:18:12 UTC
Normally it should display a SSH git url somehwere on that page.

git remote add agriffis <url>
git push agriffis

Comment 8 Zephyr Lykos 2023-11-22 15:56:53 UTC
Merged to rawhide.

Comment 9 Fedora Update System 2023-11-23 11:45:31 UTC
FEDORA-2023-e9831e76f8 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-e9831e76f8

Comment 10 Fedora Update System 2023-11-24 01:43:52 UTC
FEDORA-2023-e9831e76f8 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-e9831e76f8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-e9831e76f8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-11-25 02:43:00 UTC
FEDORA-2023-e9831e76f8 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Red Hat Bugzilla 2024-03-25 04:25:06 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 120 days


Note You need to log in before you can comment on or make changes to this bug.