Bug 22494 - glibc-2.2-9
glibc-2.2-9
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-19 06:38 EST by Andrej Filipcic
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-28 09:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrej Filipcic 2000-12-19 06:38:52 EST
Latest glibc-2.2-9 update has serious problems on alpaev67 UP2000 SMP RH
7.0. Several system commands crash (core dump with sigsegv), like uptime,
top etc. The system does not work after reboot.
Comment 1 Jakub Jelinek 2000-12-19 07:04:07 EST
Was it alphaev6.rpm which you updated to or was it alpha.rpm?
I could not reproduce it with alpha.rpm on 4way AlphaServer ES40 in a chroot,
neither could I reproduce it with alphaev6 glibc unpacked to some directory
and running ./ld-linux.so.2 --library-path ./ `which uptime`
I hope somebody with physical access to some alpha will try to reproduce this
soon.
Comment 2 Andrej Filipcic 2000-12-19 07:17:55 EST
It was glibc-2.2-9.alphaev6.rpm. The funny thing is that those commands
do not always crash. They do in 70% of cases and it depends on system load.
They crash more often if run by root than by some other user. Also system
daemons like sshd or mysqld start to behave very odd.
Comment 3 Jakub Jelinek 2000-12-19 07:25:31 EST
Are you able to see the crashes when you boot that box into UP kernel?
It might as well be a kernel bug (especially if it is not reproduceable
100% of the time). I think Richard Henderson spoke recently about some ASN
handling bug in kernel.
Comment 4 Jakub Jelinek 2000-12-19 07:50:42 EST
The ASN patches are in 2.4.0-test13-pre3, could you by chance try that
kernel to see if the random crashes go away?
Comment 5 Andrej Filipcic 2000-12-19 08:16:25 EST
Well, I will try to do that over the weekend, probably with 2.2.18 and
patches... It is a production machine...
Comment 6 Marc Schmitt 2000-12-20 05:32:25 EST
Hi there

Just updated my ES40 test system this morning with glibc-2.2-9.alphaev6.rpm and
I have the same problems as Andrej.

Here is the bootup log with SMP:

P00>>>b -fl 0
(boot dka0.0.0.3.0 -flags 0)
block 0 of dka0.0.0.3.0 is a valid boot block
reading 163 blocks from dka0.0.0.3.0
bootstrap code read in
base = 200000, image_start = 0, image_bytes = 14600
initializing HWRPB at 2000
initializing page table at 3fb7e000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code
aboot: Linux/Alpha SRM bootloader version 0.7
aboot: switching to OSF/1 PALcode version 1.79
aboot: booting from device 'SCSI 0 3 0 0 0 0 0'
aboot: valid disklabel found: 5 partitions.
aboot: loading uncompressed boot/vmlinuz-2.2.17-4smp...
aboot: loading compressed boot/vmlinuz-2.2.17-4smp...
aboot: segment 0, 2685088 bytes at 0xfffffc0000310000
aboot: zero-filling 353840 bytes at 0xfffffc000059f8a0
aboot: starting kernel boot/vmlinuz-2.2.17-4smp with arguments root=/dev/sda4
console=ttyS0
Linux version 2.2.17-4smp (root@george.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 SMP Mon Oct 23 15:03:57 EDT
2000
Booting GENERIC on Tsunami variation Clipper using machine vector Clipper from
SRM
Command line: root=/dev/sda4 console=ttyS0
1024MB BIGMEM available
SMP: 3 CPUs probed -- cpu_present_mask = 7
Console: colour VGA+ 80x25
Calibrating delay loop... 1203.77 BogoMIPS
Memory: 3104992k available
Dentry hash table entries: 262144 (order 9, 4096k)
Buffer cache hash table entries: 524288 (order 9, 4096k)
Page cache hash table entries: 262144 (order 8, 2048k)
VFS: Diskquotas version dquot_6.4.0 initialized
POSIX conformance testing by UNIFIX
SMP starting up secondaries.
recv_secondary_console_msg: on 0 message is 'P01>>>START  P01>>>'
recv_secondary_console_msg: on 1 message is 'P01>>>START  P01>>>'
Calibrating delay loop... 1325.40 BogoMIPS
recv_secondary_console_msg: on 0 message is 'P02>>>START  P02>>>'
recv_secondary_console_msg: on 1 message is 'P02>>>START  P02>>>'
recv_secondary_console_msg: on 2 message is 'P02>>>START  P02>>>'
Calibrating delay loop... 1342.18 BogoMIPS
SMP: Total of 3 processors activated (3871.34 BogoMIPS).
Alpha PCI BIOS32 revision 0.04
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 524288 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
RAM disk driver initialized:  16 RAM disks of 8192K size
PCI_IDE: unknown IDE controller on PCI bus 00 device 78, VID=10b9, DID=5229
PCI_IDE:not 100% native mode: will probe irqs later
buffer.c:43 spinlock stuck in kflushd at fffffc00003568c4(1) owner swapper at
fffffc00003102dc(0) init/main.c:43
PCI_IDE: simplex device:  DMA disabled
buffer.c:43 spinlock stuck in kupdate at fffffc0000356cc8(2) owner swapper at
fffffc00003102dc(0) init/main.c:43
ide0: PCI_IDE Bus-Master DMA disabled (BIOS)
PCI_IDE: simplex device:  DMA disabled
ide1: PCI_IDE Bus-Master DMA disabled (BIOS)
hda: TOSHIBA CD-ROM XM-6302B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
io_request_lock is fffffc0000579af0
buffer.c:43 spinlock grabbed in kflushd at fffffc00003568c4(1) 4130 ticks
buffer.c:43 spinlock grabbed in kupdate at fffffc0000356cc8(2) 4218 ticks
hda: ATAPI 32X CD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 2.88M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
linear personality registered
raid0 personality registered
raid1 personality registered
raid5 personality registered
raid5: measuring checksumming speed
   8regs     :  2640.000 MB/sec
   32regs    :  1408.000 MB/sec
using fastest function: 8regs (2640.000 MB/sec)
qlogicisp : new isp1020 revision ID (5)
DC390: 0 adapters found
scsi0 : QLogic ISP1020 SCSI on PCI bus 00 device 18 irq 32 I/O base 0x8000
scsi : 1 host.
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdc at scsi0, channel 0, id 2, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdd at scsi0, channel 0, id 3, lun 0
scsi : detected 4 SCSI disks total.
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdd: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
Partition check:
 sda: sda1 sda2 sda3 sda4 sda5
 sdb: sdb1
 sdc: sdc1
 sdd:
md.c: sizeof(mdp_super_t) = 4104
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 208k freed
INIT: version 2.78 booting
			Welcome to Red Hat Linux
Mounting proc filesystem:  [  OK  ]
Configuring kernel parameters:  [  OK  ]
Setting clock  (utc): Wed Dec 20 12:04:10 MET 2000 [  OK  ]
Activating swap partitions:  [  OK  ]
Setting hostname test1-a26:  [  OK  ]
Setting NIS domain name cos.inf.ethz.ch:  [  OK  ]
Checkingroot filesystem
/: clean, 17118/52416 files, 96323/208845 blocks
[/sbin/fsck.ext2 -- /] fsck.ext2 -a /dev/sda4 
[  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]
Finding module dependencies:  [  OK  ]
Checking filesystems
/local was not cleanly unmounted, check forced.
/.afs_cache was not cleanly unmounted, check forced.
/.afs_cache: 11/26208 files (0.0% non-contiguous), 3328/104422 blocks
/tmp was not cleanly unmounted, check forced.
/tmp: 18/128520 files (0.0% non-contiguous), 16261/514080 blocks
/usr was not cleanly unmounted, check forced.
/local: 11/1109760 files (0.0% non-contiguous), 34839/2218978 blocks
/usr: 76747/256512 files (0.2% non-contiguous), 378531/512071 blocks
/var was not cleanly unmounted, check forced.
/var: 501/128520 files (4.6% non-contiguous), 35825/514080 blocks
Checking all file systems.
[/sbin/fsck.ext2 -- /.afs_cache] fsck.ext2 -a /dev/sda5 
[/sbin/fsck.ext2 -- /local] fsck.ext2 -a /dev/sdb1 
[/sbin/fsck.ext2 -- /tmp] fsck.ext2 -a /dev/sda2 
[/sbin/fsck.ext2 -- /usr] fsck.ext2 -a /dev/sda1 
[/sbin/fsck.ext2 -- /var] fsck.ext2 -a /dev/sda3 
[PASSED]
Mounting local filesystems:  [  OK  ]
INIT: Entering runlevel: 3quotas
Entering non-interactive startup
Setting network parameters:  [  OK  ]
Bringing up interface lo:  [FAILED]
Bringing up interface eth0:  [FAILED]
Starting system logger: [  OK  ]
Starting kernel logger: [  OK  ]
Starting portmapper: [  OK  ]
Starting NFS file locking services: 
Starting NFS lockd: /etc/rc.d/rc: line 108:   215 Segmentation fault      $i
start
Binding to the NIS domain... [  OK  ]
/etc/rc.d/rc: line 108:   220 Segmentation fault      $i start
Starting automounter:[  OK  ]
/etc/rc3.d/S20random: line 58:   262 Segmentation fault      touch $random_seed
Initializing random number generator:  [  OK  ]
chmod: /var/run/random-seed: No such file or directory
Mounting NFS filesystems:  mount: can't get address for fileserver
[FAILED]
/etc/rc3.d/S25netfs: line 110:   294 Segmentation fault      touch
/var/lock/subsys/netfs
Mounting other filesystems:  [  OK  ]
Starting identd: [  OK  ]
/etc/rc.d/rc: line 108:   317 Segmentation fault      egrep -q "(daemon |action
)" $i
Starting sshd:  [  OK  ]
Starting xinetd: [FAILED]
Starting lpd: [  OK  ]
Starting rusers services: [  OK  ]
Starting amd: amd(393): unaligned trap at 0000000120005c84: 000000011ffffb3a 2c
31
amd(393): unaligned trap at 0000000120005d08: 000000011ffffb0a 2c 31
amd(393): unaligned trap at 0000000120005d0c: 000000011ffffb0e 2c 31
amd(393): unaligned trap at 0000000120005d10: 000000011ffffb12 2c 31
                                                           [  OK  ]
Starting netupdate:  [FAILED]
Starting keytable:  [  OK  ]
Starting console mouse services: /etc/rc.d/rc: line 108:   423 Segmentation
fault      $i start
Starting cron daemon: [  OK  ]
Starting X Font Server:                                    [  OK  ]
Running Linuxconf hooks: [  OK  ]

I can access the system over the console, not over the network though. I did not
test much, but most programs crash immediatly with a Segmentation Fault. It
seems to be random, how far I can boot with SMP, another time, I had the
following situation:
.
.
.
Remounting root filesystem in read-write mode:  [  OK  ]
Finding module dependencies:  [  OK  ]
Checking filesystems
/local: clean, 11/1109760 files, 34839/2218978 blocks
/.afs_cache: clean, 11/26208 files, 3328/104422 blocks
/tmp: clean, 18/128520 files, 16261/514080 blocks
/usr: clean, 76747/256512 files, 378531/512071 blocks
/var: clean, 505/128520 files, 35834/514080 blocks
Checking all file systems.
[/sbin/fsck.ext2 -- /.afs_cache] fsck.ext2 -a /dev/sda5 
[/sbin/fsck.ext2 -- /local] fsck.ext2 -a /dev/sdb1 
[/sbin/fsck.ext2 -- /tmp] fsck.ext2 -a /dev/sda2 
[/sbin/fsck.ext2 -- /usr] fsck.ext2 -a /dev/sda1 
[/sbin/fsck.ext2 -- /var] fsck.ext2 -a /dev/sda3 
[  OK  ]
Mounting local filesystems:  [  OK  ]
Turning on user and group quotas for local filesystems:  [  OK  ]
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
.
.
.

With UP kernel, I get:

aboot: starting kernel boot/vmlinuz-2.2.17-4 with arguments root=/dev/sda4
console=ttyS0
Linux version 2.2.17-4 (root@george.devel.redhat.com) (gcc version egcs-2.91.66
19990314/Linux (egcs-1.1.2 release)) #1 Mon Oct 23 15:19:13 EDT 2000
Booting GENERIC on Tsunami variation Clipper using machine vector Clipper from
SRM
Command line: root=/dev/sda4 console=ttyS0
1024MB BIGMEM available
Console: colour VGA+ 80x25
Calibrating delay loop... 1203.77 BogoMIPS
Memory: 3105080k available
Dentry hash table entries: 262144 (order 9, 4096k)
Buffer cache hash table entries: 524288 (order 9, 4096k)
Page cache hash table entries: 262144 (order 8, 2048k)
VFS: Diskquotas version dquot_6.4.0 initialized
POSIX conformance testing by UNIFIX
Alpha PCI BIOS32 revision 0.04
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 524288 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
RAM disk driver initialized:  16 RAM disks of 8192K size
PCI_IDE: unknown IDE controller on PCI bus 00 device 78, VID=10b9, DID=5229
PCI_IDE: not 100% native mode: will probe irqs later
PCI_IDE: simplex device:  DMA disabled
ide0: PCI_IDE Bus-Master DMA disabled (BIOS)
PCI_IDE: simplex device:  DMA disabled
ide1: PCI_IDE Bus-Master DMA disabled (BIOS)
hda: TOSHIBA CD-ROM XM-6302B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 32X CD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 2.88M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
linear personality registered
raid0 personality registered
raid1 personality registered
raid5 personality registered
raid5: measuring checksumming speed
   8regs     :  2648.000 MB/sec
   32regs    :  1408.000 MB/sec
using fastest function: 8regs (2648.000 MB/sec)
qlogicisp : new isp1020 revision ID (5)
DC390: 0 adapters found
scsi0 : QLogic ISP1020 SCSI on PCI bus 00 device 18 irq 32 I/O base 0x8000
scsi : 1 host.
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdc at scsi0, channel 0, id 2, lun 0
  Vendor: DEC       Model: RZ2DD-LS (C) DEC  Rev: 0306
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdd at scsi0, channel 0, id 3, lun 0
scsi : detected 4 SCSI disks total.
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
SCSI device sdd: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB] [8.7 GB]
Partition check:
 sda: sda1 sda2 sda3 sda4 sda5
 sdb: sdb1
 sdc: sdc1
 sdd:
md.c: sizeof(mdp_super_t) = 4104
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 208k freed
INIT: version 2.78 booting
			Welcome to Red Hat Linux
Mounting proc filesystem:  [  OK  ]
Configuring kernel parameters:  [  OK  ]
Setting clock  (utc): Wed Dec 20 12:20:57 MET 2000 /etc/rc.sysinit: line 4:   
28 Segmentation fault      initlog $INITLOG_ARGS -c "$*"
[FAILED]
Activating swap partitions:  [  OK  ]
Setting hostname test1-a26:  [  OK  ]
Setting NIS domain name cos.inf.ethz.ch:  [  OK  ]
Checking root filesystem
/: clean, 17119/52416 files, 96950/208845 blocks
[/sbin/fsck.ext2 -- /] fsck.ext2 -a /dev/sda4 
/etc/rc.sysinit: line 242:    50 Segmentation fault      initlog -c "fsck -T -a
$fsckoptions /"
[FAILED]

*** An error occurred during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.
Give root password for maintenance
(or type Control-D for normal startup): 
(typing Control-D)
Unmounting file systems
INIT: Entering runlevel: 3
Setting network parameters:  [  OK  ]
Bringing up interface lo:  /etc/rc3.d/S10network: line 2:   138 Segmentation
fault      initlog $INITLOG_ARGS -n $0 -s "$1" -e 1
[  OK  ]
Bringing up interface eth0:  [  OK  ]
touch: /var/lock/subsys/network: No such file or directory
Starting system logger: [FAILED] (this step takes about 10mins, till it produces
the FAILED)
Starting kernel logger: [  OK  ]
Starting portmapper: [  OK  ]
touch: /var/lock/subsys/portmap: No such file or directory
Starting NFS file locking services: 
Starting NFS lockd: /etc/rc.d/rc: line 108:   248 Segmentation fault      $i
start
Binding to the NIS domain... Could not create /var/yp: Read-only file system
[FAILED]
touch: /var/lock/subsys/ypbind: No such file or directory
touch: /var/run/random-seed: No such file or directory
Initializing random number generator:  [  OK  ]
chmod: /var/run/random-seed: No such file or directory
/etc/rc3.d/S20random: line 58:   287 Segmentation fault      dd if=/dev/urandom
of=$random_seed count=1 bs=512 2>/dev/null
touch: /var/lock/subsys/random: No such file or directory
Starting portmapper: 
touch: /var/lock/subsys/portmap: No such file or directory
Mounting NFS filesystems:  mount: can't get address for fileserver
[FAILED]
/etc/rc3.d/S25netfs: line 110:   329 Segmentation fault      touch
/var/lock/subsys/netfs
Mounting other filesystems:  [  OK  ]
Starting identd: [  OK  ]
Starting sshd: [  OK  ]
Starting xinetd: [  OK  ]
Starting lpd: [  OK  ]
Starting rusers services: [  OK  ]
Starting amd: amd(433): unaligned trap at 0000000120005c84: 000000011ffffb3a 2c
31
amd(433): unaligned trap at 0000000120005d08: 000000011ffffb0a 2c 31
amd(433): unaligned trap at 0000000120005d0c: 000000011ffffb0e 2c 31
amd(433): unaligned trap at 0000000120005d10: 000000011ffffb12 2c 31
amd[433]: switched to logfile "syslog"
amd[433]: AM-UTILS VERSION INFORMATION:
amd[433]: Copyright (c) 1997-2000 Erez Zadok
amd[433]: Copyright (c) 1990 Jan-Simon Pendry
amd[433]: Copyright (c) 1990 Imperial College of Science, Technology & Medicine
amd[433]: Copyright (c) 1990 The Regents of the University of California.
amd[433]: am-utils version 6.0.4s5 (build 1).
amd[433]: Built by prospector@george.devel.redhat.com on date Thu Sep 14
17:00:42 EDT 2000.
amd[433]: cpu=alpha (little-endian), arch=alpha, karch=alpha.
amd[433]: full_os=linux, os=linux, osver=2.2.14-5.0smp, vendor=redhat.
amd[433]: Map support for: root, passwd, ldap, union, nisplus, nis, ndbm, file,
error.
amd[433]: AMFS: nfs, link, nfsx, nfsl, host, linkx, program, union, inherit,
ufs, 
amd[433]:       cdfs, auto, direct, toplvl, error.
amd[433]: FS: iso9660, nfs, ext2.
amd[433]: Network: wire="inf-stab.inf.ethz.ch" (netnumber=129.132.10).
amd[433]: My ip addr is 129.132.10.55
amd[435]: released controlling tty using setsid()
amd[435]: file serverlocalhost type local starts up
amd[435]: setmntent("/etc/mtab", "r+"): Read-only file system
amd[435]: Trying mount of /etc/amd.net on /net fstype toplvl
amd[435]: /net: mount (amfs_auto_cont): No such file or directory
[  OK  ]
Starting netupdate:  [FAILED]
Starting keytable:  [  OK  ]
Starting console mouse services: [  OK  ]
gpm: oops() invoked from gpm.c(1012)
/dev/gpmctl: No such file or directory
Starting cron daemon: [  OK  ]
Starting X Font Server: [  OK  ]
Running Linuxconf hooks: [  OK  ]
/etc/rc3.d/S99local: /etc/issue: Read-only file system
cp: cannot create regular file `/etc/issue.net': Read-only file system
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
INIT: PANIC: segmentation violation! sleeping for 30 seconds.
etc etc etc...

I`ll see if I can check it with kernel 2.4.0.

Regards,
Marc
Comment 7 Jakub Jelinek 2000-12-20 07:10:19 EST
Actually, it might as well be a bug in some alphaev6 optimized routines
which appeared in glibc recently, I'll build now glibc-2.2-9.1 with all the
alphaev6 specific assembly disabled and will make it available to you then.
I had only 2-3 tests failing during alphaev6 make check and those did not fail
when I ran them for the second time, so I thought it is because of the ASN
issues. But as the above log makes it clear it crashes on UP as well, it might
as well be some weird bug in ev6 assembly, we'll see.
Comment 8 Jakub Jelinek 2000-12-20 09:40:28 EST
If you want, glibc-2.2-9.1 (ie. ev6 without new ev6 optimized assembly) can be
had at ftp://ultra.linux.cz/private/alphaev6/ (as soon as scp finishes).
I've done no testing on it so far though.
Comment 9 Andrej Filipcic 2000-12-20 10:27:36 EST
I have tried glibc-2.2-9.1.alphaev6.rpm from ultra.linux.cz. I have installed
this and the "offical" update into separate temporary dirs and tried
./ld-linux.so.2 --library-path ./ /usr/bin/uptime
on both. The 2.2-9 dumps core as before, while 2.2-9.1 works OK!!!
So it seems to be alphaev6[7] issue of glibc.
Thanks for help.
Comment 10 Marc Schmitt 2000-12-20 11:01:32 EST
I`m running glibc-2.2-9.1.alphaev6.rpm from ultra.linux.cz now and it looks
good, no Segmentation Faults so far.

Regards,
Marc
Comment 11 Jakub Jelinek 2000-12-28 09:03:48 EST
I found the bug in alpha/alphaev6/memcpy.S plus one bug in realloc which
was triggered by the new memcpy, it will be fixed as soon as new glibc-2.2-10 is
built.
Comment 12 Jakub Jelinek 2001-01-11 17:59:54 EST
Should be fixed in glibc-2.2-12.

Note You need to log in before you can comment on or make changes to this bug.