Bug 225008 - Yum Extender crashed when installing totem or xine
Yum Extender crashed when installing totem or xine
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-27 06:28 EST by Kevin K
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 02:32:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin K 2007-01-27 06:28:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061221 Fedora/1.5.0.9-1.fc5 Firefox/1.5.0.9

Description of problem:
I don't know a lot about how to report this bug, but I was told to by the Yumex program before it crashed.  This crash has happened twice--both times as I was trying to "Process the Queue" with a few minor package installs.  Yumex performed a successful install between the two crashes.

Version-Release number of selected component (if applicable):
yumex-1.0.3-3.0.fc5

How reproducible:
Didn't try


Steps to Reproduce:
1. add a package to the Queue
2. process the Queue
3.

Actual Results:
got a crash error and an opportunity to save the crash dump file (pasted below into "Additional Information"

Expected Results:
Yumex should have proceeded with downloading and installing packages

Additional info:
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 137, in on_queueProcess_clicked
    self.yumexbase.reset_ts()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 128, in reset_ts
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 313, in doUpdateSetup
    self.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 232, in doRepoSetup
    repo.getRepoXML( text=repo )
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 673, in getRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 620, in get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: None
url: None
text: dries
self: dries
cache: True
reget: None
relative: repodata/repomd.xml
headers: None
checkfunc: (<bound method Repository._checkRepoXML of <yum.repos.Repository instance at 0xb1774e6c>>, (), {})
copy_local: 1
end: None
Comment 1 Tim Lauridsen 2007-01-30 02:32:10 EST
This error happens because yum metadata can't be loaded from the Dries repository.
in yumex 1.2.x & yumex 1.9.x, these kind of errors is catched and shown in a
more user friendly way.
I have no plans to fix it in yumex 1.0.x, i have limited time and will use it on
the most recent versions of yumex, Sorry.

Note You need to log in before you can comment on or make changes to this bug.