Bug 225062 - Suspend fails with latest kernel
Suspend fails with latest kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-01-28 08:43 EST by Adam Huffman
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 19:07:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2007-01-28 08:43:31 EST
Description of problem:
When I try to suspend to RAM with the latest Fedora kernel, the screen goes
blank but otherwise suspending doesn't seem to work.  The laptop (a Vaio SZ3XWP)
does not switch off.  Suspending did work with the 2869 kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Choose suspend from the System menu
2.
3.
  
Actual results:
Screen goes blank but laptop does not suspend

Expected results:
Screen goes blank, blinking cursor appears for a few seconds and then the laptop
switches off, with the power light blinking orange to indicate it has been
suspended.

Additional info:
lspci output

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express
Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA
Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
07:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 PCI-E Fast
Ethernet Controller (rev 15)
09:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
09:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394
Host Controller
09:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
(SD/MMC/MS/MS PRO/xD)
Comment 1 Tru Huynh 2007-02-16 12:39:11 EST
same here SZ3XP core duo2 

I looks like a regression issue:
2.6.18-1.2869.fc6 suspend works fine but 2.6.19-1.2911.fc6 and the previous 2.6.19
version (2.6.19-1.2895.fc6) exhibit the same behaviour.

nothing strange is loogged in /var/log/messages:
Feb 16 17:32:13 woodstock gnome-power-manager: (tru) DPMS blanking screen
because the lid has been closed on ac power
Feb 16 17:32:14 woodstock gnome-power-manager: (tru) Turning LCD panel back on
because laptop lid re-opened
Feb 16 17:32:22 woodstock gnome-power-manager: (tru) Suspending computer because
user clicked suspend from tray menu
Feb 16 17:32:23 woodstock hidd[2883]: Exit
Feb 16 17:32:23 woodstock sdpd[2812]: terminating...   
Feb 16 17:32:24 woodstock hcid[2806]: Unregister path:/org/bluez
Feb 16 17:32:24 woodstock hcid[2806]: Exit
Feb 16 17:32:24 woodstock kernel: NET: Unregistered protocol family 31
Feb 16 17:32:25 woodstock kernel: Disabling non-boot CPUs ...

-> reboot log

on 2.6.18:
Feb 16 18:26:03 woodstock kernel: Disabling non-boot CPUs ...
Feb 16 18:26:03 woodstock kernel: Breaking affinity for irq 1
Feb 16 18:26:03 woodstock kernel: Breaking affinity for irq 9
Feb 16 18:26:03 woodstock kernel: Breaking affinity for irq 14
Feb 16 18:26:03 woodstock kernel: Breaking affinity for irq 58
Feb 16 18:26:03 woodstock kernel: Breaking affinity for irq 66
Feb 16 18:26:03 woodstock kernel: CPU 1 is now offline
Feb 16 18:26:03 woodstock kernel: SMP alternatives: switching to UP code
Feb 16 18:26:09 woodstock kernel: CPU1 is down
Feb 16 18:26:09 woodstock kernel: Stopping tasks:
==========================================================================================================================|
Feb 16 18:26:09 woodstock kernel:  usbdev3.2_ep83: PM: suspend 0->2, parent
3-1:1.0 already 1
Feb 16 18:26:09 woodstock kernel:  usbdev3.2_ep02: PM: suspend 0->2, parent
3-1:1.0 already 1
Feb 16 18:26:09 woodstock kernel:  usbdev3.2_ep81: PM: suspend 0->2, parent
3-1:1.0 already 1
Feb 16 18:26:09 woodstock kernel:  usbdev5.4_ep86: PM: suspend 0->2, parent
5-6:1.0 already 1
Feb 16 18:26:09 woodstock kernel:  usbdev5.4_ep81: PM: suspend 0->2, parent
5-6:1.0 already 1
Feb 16 18:26:09 woodstock kernel: ACPI: PCI interrupt for device 0000:09:04.0
disabled
Feb 16 18:26:09 woodstock kernel: sky2 eth0: disabling interface
Feb 16 18:26:09 woodstock kernel: eth%d: Going into suspend...
Feb 16 18:26:09 woodstock kernel: ACPI: PCI interrupt for device 0000:06:00.0
disabled
Feb 16 18:26:09 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1f.2
disabled
Feb 16 18:26:09 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1d.7
disabled
Feb 16 18:26:12 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1d.3
disabled
Feb 16 18:26:12 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1d.2
disabled
Feb 16 18:26:12 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1d.1
disabled
Feb 16 18:26:12 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1d.0
disabled
Feb 16 18:26:12 woodstock kernel: ACPI: PCI interrupt for device 0000:00:1b.0
disabled
Feb 16 18:26:12 woodstock kernel: PCI: Enabling device 0000:00:1b.0 (0000 -> 0002)
Feb 16 18:26:12 woodstock kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21
(level, low) -> IRQ 82
Feb 16 18:26:12 woodstock kernel: PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)
Feb 16 18:26:12 woodstock kernel: ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 19
(level, low) -> IRQ 193
Feb 16 18:26:12 woodstock kernel: usb usb1: root hub lost power or was reset
Feb 16 18:26:12 woodstock kernel: PCI: Enabling device 0000:00:1d.1 (0000 -> 0001)
Feb 16 18:26:12 woodstock kernel: ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 19
(level, low) -> IRQ 193
Feb 16 18:26:12 woodstock kernel: usb usb2: root hub lost power or was reset
Feb 16 18:26:12 woodstock kernel: PCI: Enabling device 0000:00:1d.2 (0000 -> 0001) 
...
Feb 16 18:26:12 woodstock kernel: PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
Feb 16 18:26:12 woodstock kernel: ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 17
(level, low) -> IRQ 177
Feb 16 18:26:12 woodstock kernel: sky2 eth0: enabling interface
Feb 16 18:26:12 woodstock kernel: ACPI: PCI Interrupt 0000:09:04.0[A] -> GSI 20
(level, low) -> IRQ 201
Feb 16 18:26:12 woodstock kernel: pnp: Failed to activate device 00:07.
Feb 16 18:26:12 woodstock kernel: pnp: Device 00:09 does not support activation.
Feb 16 18:26:12 woodstock kernel: pnp: Device 00:0a does not support activation.
Feb 16 18:26:12 woodstock kernel: ATA: abnormal status 0x7F on port 0x18CF
Feb 16 18:26:12 woodstock kernel:  usbdev5.4_ep81: PM: resume from 0, parent
5-6:1.0 still 1
Feb 16 18:26:12 woodstock kernel:  usbdev5.4_ep86: PM: resume from 0, parent
5-6:1.0 still 1
Feb 16 18:26:12 woodstock kernel:  usbdev3.2_ep81: PM: resume from 0, parent
3-1:1.0 still 1
Feb 16 18:26:12 woodstock kernel:  usbdev3.2_ep02: PM: resume from 0, parent
3-1:1.0 still 1
Feb 16 18:26:12 woodstock kernel:  usbdev3.2_ep83: PM: resume from 0, parent
3-1:1.0 still 1
Feb 16 18:26:12 woodstock kernel: Restarting tasks...<6>usb 3-1: USB disconnect,
address 2
Feb 16 18:26:12 woodstock kernel:  done
Feb 16 18:26:12 woodstock kernel: Enabling non-boot CPUs ...
Feb 16 18:26:12 woodstock kernel: SMP alternatives: switching to SMP code
Feb 16 18:26:12 woodstock kernel: Booting processor 1/2 APIC 0x1
Feb 16 18:26:12 woodstock kernel: Initializing CPU#1
Feb 16 18:26:12 woodstock kernel: Calibrating delay using timer specific
routine.. 3999.74 BogoMIPS (lpj=1999872)
Feb 16 18:26:12 woodstock kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Feb 16 18:26:12 woodstock kernel: CPU: L2 cache: 4096K
Feb 16 18:26:12 woodstock kernel: CPU 1/1 -> Node 0
Feb 16 18:26:12 woodstock kernel: CPU: Physical Processor ID: 0
Feb 16 18:26:12 woodstock kernel: CPU: Processor Core ID: 1
Feb 16 18:26:12 woodstock kernel: Intel(R) Core(TM)2 CPU         T7200  @
2.00GHz stepping 06
Feb 16 18:26:12 woodstock kernel: CPU1 is up
Feb 16 18:26:12 woodstock kernel: usb 5-4: reset high speed USB device using
ehci_hcd and address 2
Feb 16 18:26:12 woodstock kernel: usb 3-1: new full speed USB device using
uhci_hcd and address 3
Feb 16 18:26:12 woodstock kernel: usb 3-1: configuration #1 chosen from 1 choice
Feb 16 18:26:12 woodstock kernel: sky2 eth0: Link is up at 100 Mbps, full
duplex, flow control none
Feb 16 18:26:12 woodstock kernel: ata1.00: configured for UDMA/100
Feb 16 18:26:12 woodstock kernel: SCSI device sda: 195371568 512-byte hdwr
sectors (100030 MB)
Feb 16 18:26:12 woodstock kernel: sda: Write Protect is off
Feb 16 18:26:12 woodstock kernel: SCSI device sda: drive cache: write back
Feb 16 18:26:12 woodstock kernel: ACPI: Lid Switch [LID0]
Feb 16 18:26:12 woodstock kernel: ACPI: Power Button (CM) [PWRB]
Feb 16 18:26:12 woodstock kernel: ohci1394: fw-host0: OHCI-1394 1.1 (PCI):
IRQ=[82]  MMIO=[dc005000-dc0057ff]  Max Packet=[2048]  IR/IT contexts=[4/8]
Feb 16 18:26:12 woodstock kernel: Bluetooth: Core ver 2.10
Feb 16 18:26:12 woodstock kernel: NET: Registered protocol family 31
Feb 16 18:26:12 woodstock kernel: Bluetooth: HCI device and connection manager
initialized
Feb 16 18:26:12 woodstock kernel: Bluetooth: HCI socket layer initialized
Feb 16 18:26:12 woodstock kernel: Bluetooth: L2CAP ver 2.8
Feb 16 18:26:12 woodstock kernel: Bluetooth: L2CAP socket layer initialized
Feb 16 18:26:12 woodstock kernel: Bluetooth: HIDP (Human Interface Emulation)
ver 1.1
Feb 16 18:26:12 woodstock kernel: Bluetooth: RFCOMM socket layer initialized
Feb 16 18:26:12 woodstock kernel: Bluetooth: RFCOMM TTY layer initialized
Feb 16 18:26:12 woodstock kernel: Bluetooth: RFCOMM ver 1.8
Feb 16 18:26:12 woodstock hcid[4757]: Bluetooth HCI daemon
Feb 16 18:26:12 woodstock sdpd[4761]: Bluetooth SDP daemon
Feb 16 18:26:12 woodstock hcid[4757]: Register path:/org/bluez fallback:1
Feb 16 18:26:12 woodstock hidd[4776]: Bluetooth HID daemon
Feb 16 18:26:17 woodstock gnome-power-manager: (tru) Screen resume because idle
mode ended
Comment 2 Tru Huynh 2007-02-16 12:54:25 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223604 

stopping cpuspeed before suspending helped :P
Comment 3 Jon Stanley 2008-01-07 20:53:36 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 4 Adam Huffman 2008-01-08 18:48:13 EST
In my case these symptoms no longer persist with the latest Fedora 8 kernel.

Note You need to log in before you can comment on or make changes to this bug.