Bug 225081 - Sharing/publishing is confusing and needs to be clearer
Sharing/publishing is confusing and needs to be clearer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-28 13:05 EST by Michael White
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.7.52-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 04:54:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2217 None None None Never
CUPS Bugs and Features 2233 None None None Never

  None (edit)
Description Michael White 2007-01-28 13:05:26 EST
Description of problem:
After installing Fedora Core 6, I was no longer able to share my printer.  Both
the "system-config-printer" and the http://localhost:631/ web page simply set
the "Shared" row to "Yes" in printers.conf.  This does not seem to be
sufficient, as this does not allow access to the printer from non-local
machines, even with all firewalls shut off.  I popped over into my Fedora Core 5
partition, and noticed the following was at the end of the Fedora Core 5
cupsd.conf file:

<Location /printers/printer>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from All
</Location>

I added a modified version to the bottom of the Fedora Core 6 cupsd.conf:

<Location /printers/printer>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from 192.168.128.0/24
</Location>

I then turned on the firewall, and all was good (minus a few handfuls of hair
missing from my head :).

Version-Release number of selected component (if applicable):
system-config-printer-0.7.32-1

How reproducible:
Try to share a printer.  See URL for details.

Steps to Reproduce:
1.  Add a printer.
2.  Share a printer.
3.  Pull your hair out trying to figure out why a FC5 machine can't print to the
shared printer.
  
Actual results:
No pages printed.

Expected results:
Pages printed.

Additional info:
I thought this would be a CUPS issue, but Michael Sweet of CUPS says it's an
issue with the Linux distribution.  If this is not a system-config-printer
issue, please let me know who to direct this to (except for CUPS, who has
already dis-owned this issue).
Comment 1 Tim Waugh 2007-02-05 09:13:00 EST
Click on 'Server Settings' in the system-config-printer tool.  Is the 'share
published printers connected to this system' check-box checked or unchecked?
Comment 2 Michael White 2007-02-05 22:57:00 EST
Sorry - missed that new tab.  It was unchecked.
Comment 3 Tim Waugh 2007-02-06 05:03:15 EST
It needs to be made clearer in the interface I think.
Comment 4 Tim Waugh 2007-02-07 11:30:45 EST
Fixed in CVS.
Comment 5 Tim Waugh 2007-02-08 05:26:39 EST
Please try 0.7.50-1.fc6 from updates-testing:

yum --enablerepo=updates-testing update 'system-config-printer*'
Comment 6 Michael White 2007-02-11 23:41:02 EST
Looks good - got rid of the tabs, right?  Looks like you basically open up the
system completely.  Is that the preferred way, rather than just opening up
"/printers/printer" (like above)?
Comment 7 Tim Waugh 2007-02-12 07:01:49 EST
The change I made for this to add a label underneath the 'Shared' check-box, so
that it could say 'Not published -- see server settings' when it knew that the
server settings were set not to publish shared printers.
Comment 8 Fedora Update System 2007-02-14 14:59:27 EST
Fixed in update: system-config-printer-0.7.52-1.fc6

Note You need to log in before you can comment on or make changes to this bug.