Bug 225095 - chemical-mime-data: useless debuginfo package
chemical-mime-data: useless debuginfo package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chemical-mime-data (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-28 17:26 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.1.93-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 10:26:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Updated spec (2.52 KB, text/plain)
2007-01-28 18:16 EST, Julian Sikorski
no flags Details
Install to /usr/share/pkgconfig, change to noarch (1.14 KB, patch)
2007-01-28 18:29 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2007-01-28 17:26:13 EST
chemical-mime-data produces a useless empty debuginfo package, apparently
due to (rightfully) being noarch content in an arch specific package due to
install paths.

Fix: disable -debuginfo with %define debug_package %{nil}
http://fedoraproject.org/wiki/Packaging/Debuginfo
Comment 1 Julian Sikorski 2007-01-28 18:13:25 EST
Well, the install paths thing is a bit weird. Upstream suggests that the
pkgconfig file should go to %{_datadir}/pkgconfig rather than to
%{_libdir}/pkgconfig. On the other hand, shared-mime-info and gnome-mime-data
install their .pc files to %{_libdir}/pkgconfig. I'm not sure which approach is
correct.
As for the fix, I'll attach a new spec but due to the nature of the internet
connection I'm currently using (HTTP proxy), I won't be able to commit that.
Feel free to do this.
Comment 2 Julian Sikorski 2007-01-28 18:16:13 EST
Created attachment 146796 [details]
Updated spec
Comment 3 Ville Skyttä 2007-01-28 18:29:09 EST
Created attachment 146798 [details]
Install to /usr/share/pkgconfig, change to noarch

Actually, I think installing to /usr/share/pkgconfig and changing to noarch is
a much better solution.  The pkgconfig file contains an unnecessary libdir
which varies between archs and should be pruned (upstream should be interested
in this) - this patch takes care of that and it should be good to go IMO.  Let
me know if you'd like me to commit this one instead.
Comment 4 Ville Skyttä 2007-01-28 18:33:19 EST
Oh, and bugs against shared-mime-info and gnome-mime-data should probably be
filed, I'll look into it.  shared-mime-info installs an arch dependent
executable so it doesn't benefit much, but gnome-mime-data looks like a noarch
candidate after the fix.
Comment 5 Julian Sikorski 2007-01-28 20:17:50 EST
OK, please commit your version. One of the packages mentioned above contains a
notice in spec that it is not noarch, I think that was shared-mime-info.
Comment 6 Julian Sikorski 2007-01-28 20:18:32 EST
OK, please commit your version. One of the packages mentioned above contains a
notice in spec that it is not noarch, I think that was shared-mime-info. I'll
contact upstream about pruning the libdir.
Comment 7 Ville Skyttä 2007-01-29 10:26:11 EST
Done for devel, build in progress:
http://buildsys.fedoraproject.org/build-status/job.psp?uid=26611

I already submitted a (messy) shared-mime-info bug report upstream,
https://bugs.freedesktop.org/show_bug.cgi?id=9789 , but it'd be great if you
could do it for gnome-mime-data.
Comment 8 Julian Sikorski 2007-01-30 17:12:28 EST
Quoting gnome bugzilla:
“Sorry, entering bugs into the product gnome-mime-data has been disabled.”
Comment 9 Julian Sikorski 2007-02-05 06:52:51 EST
Upstream chemical-mime removed unnecessary .pc entries.
Comment 10 Ville Skyttä 2007-02-06 15:12:06 EST
gnome-mime-data: bug 227553

Note You need to log in before you can comment on or make changes to this bug.