Bug 225145 - Please update beagle to 0.2.16
Please update beagle to 0.2.16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-29 06:52 EST by drago01
Modified: 2007-12-29 06:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 06:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2007-01-29 06:52:42 EST
Description of problem:

FC6 is using beagle 0.2.13 while upstream has released 0.2.15.1 which includes
fixes that prevents beagle from using to much cpu time.
It would be nice to have this as an update for FC6.
Comment 1 Alexander Larsson 2007-02-05 07:46:12 EST
I'm upgrading beagle in rawhide/f7, but it requires a later mono than what is in
fc6, and I saw some bugreports for regressions on the list. I'm not sure just
upgrading it for fc6 is a great idea.
Comment 2 drago01 2007-02-05 07:50:24 EST
ok, than what about pushing it  (including new mono) to updates-testing and see
how well it works. (I will test it and I am sure others will too). If its broken
(regressions) we could wait until its fixed upstream before moving it to
updates-final.
Comment 3 Alexander Larsson 2007-02-06 06:15:57 EST
It sounds very much like you want to turn updates-testing into some sort of
mini-rawhide. Development is done in rawhide, and doing massive upgrades of the
whole mono stack and just to test things out smells very much like development.

For instance, if we upgrade mono we could break any mono app in core, extras or
a third party app, so there would need to be a lot of testing before that can be
considered safe. I'm pretty sure we won't get that much testing in updates-testing.
Comment 4 drago01 2007-02-06 06:32:51 EST
ok your right, the mono update could break random mono apps so leave it in
rawhide/f7 for now.
Comment 5 drago01 2007-02-08 03:17:34 EST
0.2.16 is out which is a bugfix release (should fix regressions mentioned above)
and do not require a new mono anymore.
>1.1.13.5 and we have 1.1.17.1 in fc6.
Comment 6 Alexander Larsson 2007-02-08 05:57:18 EST
Yes, that sounds better. I'm building 0.2.16 in rawhide. Lets have it cook there
for a while and see how it does.
Comment 7 drago01 2007-03-04 11:54:23 EST
whats the status of it? 
is it ready for updates-testing and later fc6-stable ?
Comment 8 drago01 2007-03-25 06:59:10 EDT
ping ;)
Comment 9 drago01 2007-04-21 04:57:38 EDT
any updates on this?
please look at
http://beagle-project.org/Troubleshooting_CPU
"Beagle version 0.2.13 and older are buggy

The first thing is to ensure that you're running at least Beagle 0.2.14 or
newer. You can get this info usually by looking at the version of the package
you have installed on your Linux system, or by running beagle-ping. Bugs in
older versions existed that could cause directories to be continuously
reindexed. If that directory was created on-demand with a number of files in it
(such as untarring a tarball), this can cause 100% CPU utilization. "
thats seems to be the problem that I have, any plans to get a newer beagle
atleast in updates testing?
Comment 10 Oliver Henshaw 2007-07-31 12:59:02 EDT
Is it feasible to package newer versions of beagle for FC6? There doesn't seem
to be anything in the spec file that prevents this, apart from the F7 version
being built against python 2.5.

Note You need to log in before you can comment on or make changes to this bug.