Bug 22517 - No shutdown logout
Summary: No shutdown logout
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-19 15:27 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 03:46:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-19 15:27:01 UTC
When I hit the logout button on my GNOME desktop and check off shutdown the
OS does the normal shutdown procedures but it does not turn the computer
off.  The system is halted and I must do a hard reset and boot into MS-Win
in order to shutdown the machine.  I checked bugzilla for similar reports
and found some that said to change a line in the /etc/inittab file from
"respawn" to "once".  Bug report number 11323. After making that change the
problem still exists.

Comment 1 bcling 2000-12-21 03:46:35 UTC
Been trying to validate this on several machines but only have tried two so far
(Gateway 9300 laptop and AMD K6-2/400 w/ ASUS P5-A).  Both exhibit the same
problem.  Shutdown from command line as root halts properly, with power off.

Comment 2 Owen Taylor 2000-12-21 04:15:45 UTC
Fixed in our development version.

A (untested, but approximately right) workaround is (as root):

# rm /usr/bin/halt
# cat > /usr/bin/halt
#!/bin/sh
/usr/bin/poweroff
^D
# chmod 0755 /usr/bin/halt

The problem is that the shutdown is invoking /usr/bin/halt instead
of /usr/bin/poweroff, and halt, for reasons understood only by the
maintainers of SysV init, doesn't power off any more.


Note You need to log in before you can comment on or make changes to this bug.