Bug 225252 - Merge Review: apmd
Merge Review: apmd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 16:01 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-26 10:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 09:13:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-29 16:01:39 EST
Fedora Merge Review: apmd

http://cvs.fedora.redhat.com/viewcvs/devel/apmd/
Comment 1 Gwyn Ciesla 2008-02-05 12:03:39 EST
rpmlint on srpm:

apmd.src:17: W: prereq-use chkconfig
The use of PreReq is deprecated. In the majority of cases, a plain Requires
is enough and the right thing to do. Sometimes Requires(pre), Requires(post),
Requires(preun) and/or Requires(postun) can also be used instead of PreReq.

Fix.

apmd.src: W: summary-ended-with-dot Advanced Power Management (APM) BIOS
utilities for laptops.
Summary ends with a dot.

Fix.

apmd.src: W: invalid-license GPL
The value of the License tag was not recognized.  Known values are:
"Adobe", "AFL", "AGPLv1", "AGPLv3", "AMPAS BSD", "ARL", "ASL 1.0", "ASL 1.0+",
"ASL 1.1", "ASL 1.1+", "ASL 2.0", "ASL 2.0+", "APSL 2.0", "APSL 2.0+",
"Artistic 2.0", "Artistic clarified", "BitTorrent", "Boost", "BSD", "BSD with
advertising", "CeCILL", "CDDL", "CPL", "Condor", "Copyright only", "Cryptix",
"Crystal Stacker", "EPL", "eCos", "EFL 2.0", "EFL 2.0+", "EU Datagrid", "FTL",
"Giftware", "Glide", "gnuplot", "GPL+", "GPL+ or Artistic", "GPLv2+ or
Artistic", "GPLv2", "GPLv2 with exceptions", "GPLv2+", "GPLv2+ with
exceptions", "GPLv3", "GPLv3 with exceptions", "GPLv3+", "GPLv3+ with
exceptions", "IBM", "IJG", "ImageMagick", "iMatix", "Imlib2", "Intel ACPI",
"Interbase", "ISC", "Jabber", "JasPer", "LGPLv2", "LGPLv2 with exceptions",
"LGPLv2+", "LGPLv3", "LGPLv3+", "libtiff", "LPL", "LPPL", "mecab-ipadic",
"MIT", "MPLv1.0", "MPLv1.0+", "MPLv1.1", "MPLv1.1+", "NCSA", "NGPL", "NOSL",
"Netscape", "Nokia", "OpenLDAP", "OpenPBS", "OReilly", "OSL 1.0", "OSL 1.0+",
"OSL 1.1", "OSL 1.1+", "OSL 2.0", "OSL 2.0+", "OSL 3.0", "OSL 3.0+",
"OpenSSL", "Phorum", "PHP", "Public Domain", "Python", "QPL", "RPSL", "Ruby",
"Sleepycat", "SISSL", "SLIB", "SPL", "TCL", "UCD", "Vim", "VNLSL", "VSL",
"W3C", "WTFPL", "wxWindows", "xinetd", "Zend", "ZPLv1.0", "ZPLv1.0+",
"ZPLv2.0", "ZPLv2.0+", "ZPLv2.1", "ZPLv2.1+", "zlib", "CDL", "FBSDDL", "GFDL",
"IEEE", "OFSFDL", "Open Publication", "CC-BY", "CC-BY-SA", "DSL", "Free Art",
"Arphic", "Baekmuk", "Bitstream Vera", "mplus", "OFL", "STIX", "Utopia",
"XANO", "Redistributable, no modification permitted", "Freely redistributable
without restriction".

Fix, should be GPLv2+

apmd.src: W: no-url-tag
The URL tag is missing.

Fix.

apmd.src: W: strange-permission apmscript 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

apmd.src: W: strange-permission apmd.init 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

apmd.src: W: strange-permission laptopmode 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

Ok.


apmd.i386: E: executable-marked-as-config-file /etc/rc.d/init.d/apmd
Executables must not be marked as config files because that may
prevent upgrades from working correctly. If you need to be able to
customize an executable, make it for example read a config file in
/etc/sysconfig.

apmd.i386: E: executable-marked-as-config-file /etc/sysconfig/apm-scripts/laptopmode
Executables must not be marked as config files because that may
prevent upgrades from working correctly. If you need to be able to
customize an executable, make it for example read a config file in
/etc/sysconfig.

apmd.i386: E: executable-marked-as-config-file /etc/sysconfig/apm-scripts/apmscript
Executables must not be marked as config files because that may
prevent upgrades from working correctly. If you need to be able to
customize an executable, make it for example read a config file in
/etc/sysconfig.

These are fine for this package.

apmd.i386: W: conffile-without-noreplace-flag /etc/rc.d/init.d/apmd
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


apmd.i386: W: conffile-without-noreplace-flag /etc/sysconfig/apm-scripts/apmscript
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


apmd.i386: W: conffile-without-noreplace-flag /etc/sysconfig/apm-scripts/laptopmode
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


apmd.i386: W: service-default-enabled /etc/rc.d/init.d/apmd
The service is enabled by default after "chkconfig --add"; for security
reasons, most services should not be. Use "-" as the default runlevel in the
init script's "chkconfig:" line and/or remove the "Default-Start:" LSB keyword
to fix this if appropriate for this service.

apmd.i386: W: service-default-enabled /etc/rc.d/init.d/apmd
The service is enabled by default after "chkconfig --add"; for security
reasons, most services should not be. Use "-" as the default runlevel in the
init script's "chkconfig:" line and/or remove the "Default-Start:" LSB keyword
to fix this if appropriate for this service.

These are also fine.

Otherwise, looks good, no other blockers.
Comment 2 Gwyn Ciesla 2008-05-16 11:03:02 EDT
Any updates?
Comment 3 Phil Knirsch 2008-05-27 08:31:19 EDT
Adding zprikryl@redhat.com to the CC list as he's the current maintainer of apmd.

Read ya, Phil
Comment 4 Zdenek Prikryl 2008-05-28 05:05:51 EDT
Hello,
I committed updated version of the spec file into CVS. Please check it.
Comment 5 Gwyn Ciesla 2008-05-28 08:38:12 EDT
Looks great.  Just commit a version documenting the changes and we're set!
Comment 6 Zdenek Prikryl 2008-06-18 04:00:48 EDT
I'm not sure, so I should commit only spec file with additional notes in the
changelog, right?. And do I have to build a new package?
Comment 7 Gwyn Ciesla 2008-06-18 08:43:13 EDT
Correct.  And build just for rawhide.
Comment 8 Zdenek Prikryl 2008-06-18 08:59:57 EDT
Done.
Comment 9 Gwyn Ciesla 2008-06-18 09:13:15 EDT
Works for me.  Approved.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.