Bug 225290 - Merge Review: attr
Summary: Merge Review: attr
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Zdenek Prikryl
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 21:07 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 08:14:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dan: fedora-review+


Attachments (Terms of Use)
fix the discussed issues in the spec file (2.17 KB, patch)
2007-02-04 15:37 UTC, Dan Horák
no flags Details | Diff

Description Nobody's working on this, feel free to take it 2007-01-29 21:07:18 UTC
Fedora Merge Review: attr

http://cvs.fedora.redhat.com/viewcvs/devel/attr/

Comment 1 Dan Horák 2007-02-04 15:35:59 UTC
OK	source files match upstream:
	    397f565e427e9237537d10345a3b1b09a5f988c4b4035e3bfc1ff5260f20a11d 
attr_2.4.32-1.tar.gz
OK	package meets naming and versioning guidelines.
OK	specfile is properly named, is cleanly written and uses macros consistently.
OK	license is open source-compatible. License text included in package.
OK	latest version is being packaged.
OK	BuildRequires are proper.
OK	compiler flags are appropriate.
OK	%clean is present.
OK	package builds in mock (i386).
OK	package installs properly
OK	debuginfo package looks complete.
OK	final provides and requires looks sane.
OK	shared libraries are added to the regular linker search paths, ldconfig is run.
OK	owns the directories it creates.
OK	doesn't own any directories it shouldn't.
OK	no duplicates in %files.
OK	file permissions are appropriate.
OK	scriptlets are present and they are sane.
OK	code, not content.
OK	documentation is small, so no -docs subpackage is necessary.
OK	%docs are not necessary for the proper functioning of the package.
OK	no libtool .la are packaged.
OK	not a GUI app.

MUST FIX:

BAD	headers and .so are in devel subpackage, but the dependency on the lib
subpackage is not correct

SHOULD FIX:

BAD	dist tag is NOT present.
BAD	not suggested build root is used.

BAD	rpmlint is NOT silent.

I: attr checking
W: attr summary-ended-with-dot Utilities for managing filesystem extended
attributes.
W: attr prereq-use /sbin/ldconfig
W: attr prereq-use /sbin/ldconfig
	these are found automagically

W: attr macro-in-%changelog defattr
	macro is not escaped

I: libattr-devel checking
W: libattr-devel no-version-dependency-on libattr 2.4.32
	see MUST FIX
	
W: libattr-devel summary-ended-with-dot Extended attribute static libraries and
headers.
W: libattr-devel symlink-should-be-relative /usr/lib/libattr.so /lib/libattr.so
	could be linked from ../../%{_lib}/libattr.so

I: libattr checking
W: libattr summary-ended-with-dot Dynamic library for extended attribute support.
W: libattr no-documentation

You could also use %doc macro in the %files section instead of %{_datadir}/doc/...


Comment 2 Dan Horák 2007-02-04 15:37:06 UTC
Created attachment 147305 [details]
fix the discussed issues in the spec file

Comment 3 Karsten Hopp 2007-02-23 10:12:45 UTC
fixed in attr-2.4.32-2.fc7

Comment 4 Dan Horák 2007-02-24 08:55:23 UTC
You should remove the explicit Requires(post + postun), because they are found
automagically from the %post(+un) scripts. Sorry, when it wasn't clear from the
review.

With this issue fixed, package will be APPROVED.

Comment 5 Dan Horák 2007-10-28 10:08:09 UTC
Looks like there was a maintainer change. Zdenek, can you check the package so
we can finish the review and close this bug?

Comment 6 Zdenek Prikryl 2007-10-30 08:14:00 UTC
Fixed in attr-2.4.38-2.fc9.

Zdenek

Comment 7 Fedora Update System 2007-11-06 16:11:13 UTC
attr-2.4.38-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Jason Tibbitts 2007-11-17 22:09:44 UTC
Could someone set fedora-review to '+' if this was approved?


Note You need to log in before you can comment on or make changes to this bug.