Bug 2253756 - Fail to enter s2idle suspend - wpa_supplicant task
Summary: Fail to enter s2idle suspend - wpa_supplicant task
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 39
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2253789 (view as bug list)
Depends On:
Blocks: Framework
TreeView+ depends on / blocked
 
Reported: 2023-12-09 07:29 UTC by Dimitris
Modified: 2023-12-14 01:52 UTC (History)
20 users (show)

Fixed In Version: kernel-6.6.6-200.fc39 kernel-6.6.6-100.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-12-14 01:31:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Failed suspend attempt(s) (7.57 KB, text/plain)
2023-12-09 07:32 UTC, Dimitris
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 218247 0 P3 NEW brcmfmac wifi stopped working with kernel 6.6.5 2023-12-10 18:27:34 UTC

Description Dimitris 2023-12-09 07:29:24 UTC
1. Please describe the problem:

Attempt to suspend (s2idle) fails with a stack trace in the mpa_supplicant task.

2. What is the Version-Release number of the kernel:

6.6.5-200.fc39.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

This is a new regression.  6.6.4 and previous 6.6 and 6.5 series kernels did not have this problem.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Suspend using either the GNOME power menu button or the physical power button on the machine.

If it matters, this is a Framework AMD 7840U laptop using a AMD/Mediatek MT7922 wireless adapter.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

N/A (haven't tried yet)

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Reproducible: Always

Comment 1 Dimitris 2023-12-09 07:32:10 UTC
Created attachment 2003428 [details]
Failed suspend attempt(s)

log looks like two events back to back, I probably git the power button again after it was obvious that the first suspend attempt was in trouble.

Comment 2 Dimitris 2023-12-09 19:23:38 UTC
Couple of new observations:

- Could not reproduce with kernel 6.7.0-0.rc4.20231208git5e3f5b81de80.38.fc40 from rawhide.

- Back to being booted with 6.6.5-200.fc39, I thought to try putting the laptop into airplane mode before suspending.  The attempt to enable airplane mode failed, putting the machine in a state similar to what it's in after the failed suspend: Unresponsive UI/screen for a long time, leading me to do a hard shutdown by holding the power button.  I can't see anything interesting in that boot's journal (kernel or otherwise).

Comment 3 Dimitris 2023-12-09 20:58:26 UTC
This seems to be related to the Mediatek wireless/bluetooth adapter.  If I disable it from BIOS, I can suspend/resume in 6.6.5 without incident.

01:00.0 Network controller: MEDIATEK Corp. MT7922 802.11ax PCI Express Wireless Network Adapter
	Subsystem: MEDIATEK Corp. Device e616
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 126
	IOMMU group: 1
	Region 0: Memory at 8810900000 (64-bit, prefetchable) [size=1M]
	Region 2: Memory at 90b00000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: <access denied>
	Kernel driver in use: mt7921e
	Kernel modules: mt7921e

Comment 4 Dimitris 2023-12-10 18:27:34 UTC
This looks like upstream https://bugzilla.kernel.org/show_bug.cgi?id=218247, associated kernel mailing list discussion https://lore.kernel.org/all/87sf4belmm.fsf@turtle.gmx.de/

Comment 5 Justin M. Forbes 2023-12-11 12:40:31 UTC
*** Bug 2253789 has been marked as a duplicate of this bug. ***

Comment 6 Mario Limonciello 2023-12-11 16:15:56 UTC
This should be fixed by upgrading to kernel 6.6.6 which picks up this revert commit.
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-6.6.y&id=9099d0682462e8664c8cbbe8989de65e50f62b17

Comment 7 Adam Williamson 2023-12-11 16:34:16 UTC
But *does* run the risk of tainting your immortal soul, of course...

Comment 8 Fedora Update System 2023-12-11 20:30:40 UTC
FEDORA-2023-4df366ee80 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4df366ee80

Comment 9 Fedora Update System 2023-12-11 20:30:42 UTC
FEDORA-2023-a8afe852a3 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-a8afe852a3

Comment 10 Fedora Update System 2023-12-12 01:30:53 UTC
FEDORA-2023-4df366ee80 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-4df366ee80`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-4df366ee80

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-12-12 02:39:55 UTC
FEDORA-2023-a8afe852a3 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-a8afe852a3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-a8afe852a3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-12-14 01:31:31 UTC
FEDORA-2023-4df366ee80 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2023-12-14 01:52:20 UTC
FEDORA-2023-a8afe852a3 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.