Bug 225387 - please add support for booting into a x64 system with a x64 kernel
please add support for booting into a x64 system with a x64 kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-30 05:10 EST by Suhan Andrei
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 11:24:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhan Andrei 2007-01-30 05:10:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Description of problem:
By default in a x64 suystem that crashed/ (unable to boot)  the rescue shall load a x64 kernel so that after chroot into /mnt/sysimage we can run x64 binaries present into system.

I am not sure if this problem belongs to anaconda but it is my best guess.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. damage some kernel module so that system will not be able to boot normally
2. boot with fedora CD and type linux rescue
3. linux rescue finds the system
4. chroot /mnt/sysimage
5. binaries cannot be run because the kernel is x32 and binaries are x64.

Actual Results:
binaries cannot be run because the kernel is x32 and binaries are x64.

Expected Results:
we shall be able to run existing binaries from damaged system.

Additional info:
Comment 1 Jeremy Katz 2007-01-30 11:24:20 EST
If you use the x86_64 rescue mode, then the right thing happens.  

Note You need to log in before you can comment on or make changes to this bug.