Bug 225406 - split out libcom_err and libuuid?
split out libcom_err and libuuid?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Eric Sandeen
David Lawrence
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-30 08:53 EST by Silvio Ziegelwanger
Modified: 2010-07-15 14:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 16:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to e2fsprogs.spec (7.35 KB, patch)
2009-02-20 12:25 EST, Richard W.M. Jones
no flags Details | Diff
Proposed patch to e2fsprogs.spec (7.18 KB, patch)
2009-03-10 08:10 EDT, Richard W.M. Jones
no flags Details | Diff
Proposed patch to e2fsprogs.spec (7.21 KB, patch)
2009-05-12 08:50 EDT, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Silvio Ziegelwanger 2007-01-30 08:53:44 EST
You might want to split out libcom_err and libuuid.
Currently the e2fsprogs-devel(!) contains the shared object files (O_o).
Might also be useful for non-devel and isn't really tied to e2fsprogs (for
example libcom_err is apparently used by openssh, php, cyrus-sasl, wget, curl,
...; for libuuid almost any program needing a globally unique ID comes to mind).
Comment 1 Eric Sandeen 2007-05-29 17:26:36 EDT
Silvio, I agree that this would be good.  It'll need to get upstream into Ted's
repository first; if you have a patch, feel free to send it. :)
Comment 2 Eric Sandeen 2007-09-19 14:22:23 EDT
Er, right, we could just split this in the rpm, of course :)

I'm going to put this on Fedora, not RHEL, as we probably would not make such a
change for RHEL.  If you feel this is critical for RHEL, pls comment.

Thanks,

-Eric
Comment 3 Bug Zapper 2008-04-03 14:59:39 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Bug Zapper 2008-05-06 21:07:22 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 5 Eric Sandeen 2008-05-06 21:20:27 EDT
This is still a good idea & nice to have eventually IMHO.  Reopening, just low
priority for now.
Comment 6 Bug Zapper 2008-05-13 22:34:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Richard W.M. Jones 2009-02-20 12:25:41 EST
Created attachment 332736 [details]
Proposed patch to e2fsprogs.spec

Here is a copy of an email I sent to Eric on this subject.
    -  -  -  -

I would like to propose that e2fsprogs generate four subpackages for
the independent libraries that it contains.  These four libraries are
used by other packages that don't need the whole of e2fsprogs-devel
(eg. krb5_workstation uses libss, qpid uses libuuid, and many programs
use libcom_err).

Our specific use case is to help with ongoing work porting libraries
to MinGW (http://fedoraproject.org/wiki/MinGW) where we would prefer
to package mingw32-libuuid for mingw32-qpidc without needing to port
the whole of e2fsprogs.

I looked at Debian's package, and would like to propose a split along
the same lines:

  http://packages.debian.org/source/lenny/e2fsprogs

Despite the apparent complexity, there are only really four
subpackages.  For the Fedora package we would create:

  libblkid      libblkid-devel
  libcom_err    libcom_err-devel       [note 1]
  libss         libss-devel
  libuuid	libuuid-devel

There are no conflicting package names in Fedora at the moment, except
for the similarly named libss7 (a library implementing Signalling
System 7 telephone switching protocol).

I have attached a patch against Rawhide which does the above split.  I
set up the dependencies so there should be no loss of functionality
for users who install just e2fsprogs or e2fsprogs-devel.

What remains is to advertize the split on fedora-devel-list and
encourage package maintainers to replace:

  BuildRequires: e2fsprogs-devel

with

  BuildRequires: lib<uuid|ss|blkid|com_err>-devel

where appropriate.

[1]
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Common_Character_Set_for_Package_Naming
Comment 8 Richard W.M. Jones 2009-03-10 08:10:40 EDT
Created attachment 334626 [details]
Proposed patch to e2fsprogs.spec

Rebased the patch to latest Rawhide.
Comment 9 Eric Sandeen 2009-03-11 01:11:27 EDT
Thanks.  I think that at this point in the F11 cycle I am not going to try to split this up (sorry) ... but perhaps once F11 is cloned we can give it a go in Rawhide.  I hope that's acceptable...

Thanks,
-Eric
Comment 10 Richard W.M. Jones 2009-05-12 08:50:25 EDT
Created attachment 343582 [details]
Proposed patch to e2fsprogs.spec

Patch updated against latest devel branch.
Comment 11 Karel Zak 2009-06-04 05:58:03 EDT
Just note, the libblkid has been moved to util-linux-ng. I'll follow Richard's suggestion and create libblkid and libblkid-devel subpackages.

We are going to move libuuid to u-l-ng too -- probably next month or so.
Comment 12 Bug Zapper 2009-06-09 05:12:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Eric Sandeen 2009-06-18 16:47:34 EDT
I still hope to address this in F12, don't despair.  Just haven't gotten to it yet ....

uuid & blkid are in the process of moving out of e2fsprogs, so that'll be fewer subpackages owned by e2fsprogs at least.
Comment 14 Eric Sandeen 2009-06-30 16:54:05 EDT
Done in 1.41.6-6 and beyond.

Note You need to log in before you can comment on or make changes to this bug.