Bug 225408 - Reconnect fails to find host
Summary: Reconnect fails to find host
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat-gnome   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 14:27 UTC by Simon Goodall
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.18-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 17:58:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 441613 None None None Never

Description Simon Goodall 2007-01-30 14:27:04 UTC
Description of problem:
When I suspend my laptop and move to a new network, xchat-gnome is unable to
find the irc hosts. I usually have to manually initiate a reconnect with the
/reconnect command as the NetworkManager plugin does not appear to work. This
results in an unknown host message and I have to restart xchat-gnome to be able
to log back in. Reconnecting while on the same network is fine.

I have the OSD, NM and notification plugins enabled and I use NetworkManager to
manage my network connections.

Version-Release number of selected component (if applicable):
xchat-gnome-0.15-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Log in to an irc server.
2. Move machine onto a new network
3. xchat fails to notice loss of connection, so initiate manual reconnect
  
Actual results:
Unknown host messages

Expected results:
xchat-gnome should find the host and reconnect.

Additional info:

Comment 1 Brian Pepple 2007-01-31 14:49:46 UTC
I've pushed 0.16 for FC6 earlier today, and if I remember correctly Guillaume
fixed some regression regarding NM in it.  When it becomes available can you
check to see if this bug still occurs?  My laptop went toes-up over the
holidays, so I can't easily reproduce this bug, and verify that it's fixed.  Thanks.

Comment 2 Simon Goodall 2007-01-31 20:32:59 UTC
There is no change in behaviour with the update.

Comment 3 Simon Goodall 2007-06-27 19:40:37 UTC
Still a problem with xchat-gnome-0.17-4.fc7

Comment 4 Kevin Kofler 2007-09-14 15:16:49 UTC
Any idea if this affects the regular xchat too?

Comment 5 Brian Pepple 2007-09-14 17:13:59 UTC
(In reply to comment #4)
> Any idea if this affects the regular xchat too?

No, I'm not sure if xchat experiences this bug also.

Though, taking a guess I would think it would, since x-g just adds a gnome
front-end, and some plugins to xchat.


Comment 6 Fedora Update System 2007-09-18 03:14:29 UTC
xchat-gnome-0.18-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-09-24 17:58:35 UTC
xchat-gnome-0.18-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.