Bug 2254813 - Default waybar configuration results in Failed to connect to MPD: Connection refused
Summary: Default waybar configuration results in Failed to connect to MPD: Connection ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: waybar
Version: 39
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Aleksei Bavshin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-12-16 13:36 UTC by Robert Hubinak
Modified: 2024-03-15 01:05 UTC (History)
2 users (show)

Fixed In Version: waybar-0.9.24-3.fc41 waybar-0.9.24-3.fc40 waybar-0.9.24-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-25 04:07:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github Alexays Waybar issues 430 0 None closed Errors with the default config if "mpd" isn't installed 2023-12-16 22:37:45 UTC
Gitlab fedora/sigs/sway SIG issues 11 0 None opened Configuration and style for waybar 2023-12-16 22:37:45 UTC

Description Robert Hubinak 2023-12-16 13:36:07 UTC
Installed Fedora 39 sway spin. Journalctl is spammed with:

```
Dec 08 09:44:45 rh waybar[1795]: [2023-12-08 09:44:45.120] [error] mpd: Failed to connect to MPD: Connection refused
```

This is due to mpd not installed by default and the following block in waybar config:

```
rg mpd /etc/xdg/waybar/config
47:    "mpd": {
```


Reproducible: Always

Steps to Reproduce:
1. Install Fedora 39 sway spin
2. journalctl -f

Actual Results:  
[error] mpd: Failed to connect to MPD: Connection refused

Expected Results:  
No mpd error

Comment 1 Aleksei Bavshin 2023-12-16 22:37:45 UTC
That's not the only thing that is wrong with the default config of waybar. Nevertheless, we're trying to avoid divergence from upstream defaults[1] in Fedora, and upstream thinks it's reasonable because you can just change the config.

Maybe we really should've added our own waybar configuration for the Sway spin, just like we did for Sway in `sway-config-fedora`. The bug is a good point in favor of doing so.
I'll keep the bug open while I'm pondering on that.

[1]: https://docs.fedoraproject.org/en-US/package-maintainers/Staying_Close_to_Upstream_Projects/

Comment 2 Fedora Update System 2024-02-25 04:02:59 UTC
FEDORA-2024-3d4abb1d5f (waybar-0.9.24-3.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-3d4abb1d5f

Comment 3 Fedora Update System 2024-02-25 04:07:33 UTC
FEDORA-2024-3d4abb1d5f (waybar-0.9.24-3.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2024-02-25 04:29:09 UTC
FEDORA-2024-a1f19d11a1 (waybar-0.9.24-3.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-a1f19d11a1

Comment 5 Fedora Update System 2024-02-25 04:31:52 UTC
FEDORA-2024-a1f19d11a1 (waybar-0.9.24-3.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2024-03-06 06:52:29 UTC
FEDORA-2024-8f046dac13 (waybar-0.9.24-3.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-8f046dac13

Comment 7 Fedora Update System 2024-03-07 02:27:34 UTC
FEDORA-2024-8f046dac13 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-8f046dac13`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-8f046dac13

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2024-03-15 01:05:27 UTC
FEDORA-2024-8f046dac13 (waybar-0.9.24-3.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.