Bug 225494 - Application Stack v.1.1 Channels
Application Stack v.1.1 Channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-30 17:01 EST by Matt Webbink
Modified: 2008-10-21 02:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 02:42:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Channel Description File (7.48 KB, text/csv)
2007-02-05 14:09 EST, Benjamin Kahn
no flags Details

  None (edit)
Description Matt Webbink 2007-01-30 17:01:14 EST
Please create the new Red Hat Application Stack v.1.1 channels in QA, per
revision # 110086 of rh-stack-channels.csv.

If you have any questions related to these product offerings, please contact
Aaron Darcy (adarcy@redhat.com) or Benjamin Kahn (bkahn@redhat.com) for
additional details.
Comment 1 Aaron Darcy 2007-02-02 14:01:58 EST
Any update on ETA for push to RHN QA? Thanks
Comment 2 Aaron Darcy 2007-02-05 13:09:52 EST
Grateful if you could push this to RHN QA as soon as possible, we have a release
dependent on this. Thanks
Comment 3 Benjamin Kahn 2007-02-05 14:09:31 EST
Created attachment 147392 [details]
Channel Description File
Comment 4 Todd Sanders 2007-02-05 17:25:59 EST
Reassigning to Bret, as jslagle is on PTO.
Comment 5 Bret McMillan 2007-02-05 18:05:17 EST
(Note to self:

I got confused by:
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=225494#c0
revision # 110086 of rh-stack-channels.csv are the *mappings*, not the channel
definitions)

Ben,

the attached channel description file doesn't work.  The file *must* be in a
form similar to the files here for our tools to work on it appropriately:

  http://svn.rhndev.redhat.com/viewcvs/trunk/pm/channels/

Please either attach a fixed version, or (preferably) work w/ mattwebb to follow
the standard procedure of checking-in the correct version of the csv file into
svn and referencing the appropriate revision number within this bug.

Once either of those happens, I'll be able to try to create the channels again.
Comment 6 Bret McMillan 2007-02-05 20:52:37 EST
Hm.  Looks like I just got confused by comment #3, from tsanders:

> Bret:
> 
> I must be missing something, but it seems to me that as referenced in 
> the bugzilla (#225494) comment 0...these are the channel definitions:
> 
>
http://svn.rhndev.redhat.com/viewcvs/trunk/pm/channels/rh-stack-channels.csv?rev=110086&sortby=date&view=log

> 
> 
> There are no new channel families, just additional 1.1 channels to the 
> existing families.  This file was updated by mattwebb last week, and 
> appropriately checked into SVN.

> The mappings (SKU definitions) are here:
> 
>
http://svn.rhndev.redhat.com/viewcvs/trunk/pm/mappings/rh-stack-mappings.csv?rev=101696&view=log



So, I'm presuming at this point that the only thing y'all want run is the
revision from the initial bug report.  Running that against webdev ran with the
following output:

[bretm@potential channels]$ python ~/svn/rhn/eng/scripts/create-channel.py
--verbose --csv=./rh-stack-channels-110086.csv --db=[censored]
Connecting to [censored]@webdev
Creating channel rhel-i386-as-4-appstk-1.1
  Channel rhel-i386-as-4-appstk-1.1 membership updated
Channel family rhel-appstk-beta does not exist
Creating channel rhel-i386-es-4-appstk-1.1
  Channel rhel-i386-es-4-appstk-1.1 membership updated
Channel family rhel-appstk-beta does not exist
Creating channel rhel-x86_64-as-4-appstk-1.1
  Channel rhel-x86_64-as-4-appstk-1.1 membership updated
Channel family rhel-appstk-beta does not exist
Creating channel rhel-x86_64-es-4-appstk-1.1
  Channel rhel-x86_64-es-4-appstk-1.1 membership updated
Channel family rhel-appstk-beta does not exist
Rolling back (--commit was not specified)


I went ahead and re-ran it, forcing the creation of those channel families,
output was:

Connecting to [censored]@webdev
Creating channel rhel-i386-as-4-appstk-1.1
  Channel rhel-i386-as-4-appstk-1.1 membership updated
Creating channel rhel-i386-as-4-appstk-1.1-beta
  Channel rhel-i386-as-4-appstk-1.1-beta membership updated
Creating channel rhel-i386-es-4-appstk-1.1
  Channel rhel-i386-es-4-appstk-1.1 membership updated
Creating channel rhel-i386-es-4-appstk-1.1-beta
  Channel rhel-i386-es-4-appstk-1.1-beta membership updated
Creating channel rhel-x86_64-as-4-appstk-1.1
  Channel rhel-x86_64-as-4-appstk-1.1 membership updated
Creating channel rhel-x86_64-as-4-appstk-1.1-beta
  Channel rhel-x86_64-as-4-appstk-1.1-beta membership updated
Creating channel rhel-x86_64-es-4-appstk-1.1
  Channel rhel-x86_64-es-4-appstk-1.1 membership updated
Creating channel rhel-x86_64-es-4-appstk-1.1-beta
  Channel rhel-x86_64-es-4-appstk-1.1-beta membership updated
Committing

I need to be certain of a few things before I move this to webqa though:
1) if the beta channel family didn't exist before, it (probably) won't have been
provided by any sku's... are there sku mappings that still need to get applied,
or is this just channel creation?
2) mattwebb & bkahn:  please confirm that tsanders interpreted the scenario
correctly, and I applied the desired changes

If we get answers to those two tomorrow, I should be in the office tomorrow @
x44387 and we can move those changes to webqa pretty quickly.
Comment 7 Matt Webbink 2007-02-06 12:20:54 EST
If the rhel-appstk-beta has not been previously created, then I assume it is
required now.  Currently, it's only a channel creation, but it will need to be
added to the Application Stack SKU mappings at some point in the future (TBD by
Aaron).

Yes - I believe you've correctly applied the desired changes.

Note You need to log in before you can comment on or make changes to this bug.