Bug 225541 - font errors in skencil
font errors in skencil
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: skencil (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 03:46 EST by Andrew Baumann
Modified: 2008-02-05 08:57 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.17-10.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-03 15:53:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Baumann 2007-01-31 03:46:24 EST
I have just installed skencil-0.6.17-8.fc6 on an up-to-date FC6 system. When I 
start it, it gives the following errors on the console:

$ skencil
shared memory images supported
Could not load font '-misc-fixed-medium-*-*-*-11-*-*-*-*-*-iso8859-1' for 
ruler. using defaults.
Could not load font '-misc-fixed-medium-*-*-*-11-*-*-*-*-*-iso8859-1' for 
ruler. using defaults.
Could not load font '-misc-fixed-medium-*-*-*-[0 11 ~11 
0]-*-*-*-*-*-iso8859-1' for ruler. using defaults.

However, the ruler seems ok. The bigger problem is when I go to enter text, as 
soon as I type the first character, I get a dialog box with the error message:

Cannot load '-adobe-times-medium-r-normal--1385785-*-*-*-*-*-iso8859-1 [70]': 
no such font

If I use the UI to change the font to another size, I get a similar error 
message about a different non-existent font. The preview display of fonts in 
the font-selection dialog is fine, however.

I have read a few things in the Skencil user guide about setting up fonts and 
font paths etc, but in my opinion this should work out of the box for a Fedora 
Extras package on a fairly standard Fedora system.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Baumann 2007-01-31 03:49:14 EST
Sorry, I should note that as well as the error messages the actual text 
displayed is awful; it's some fallback font and is the same regardless of what 
I select in the font dialog.
Comment 2 Gérard Milmeister 2007-02-01 13:56:27 EST
Font handling in skencil is horrible. I fiddled with it a long time ago. I can
try and see if it is possible to create some reasonable default configuration.
However I fear that the font system is simply broken.
Comment 3 Gérard Milmeister 2007-02-01 13:57:55 EST
The first thing you can do is to add the following entries to /etc/X11/fs/config
at the end of the catalogue property:
  /usr/share/X11/fonts/75dpi
  /usr/share/X11/fonts/100dpi
Comment 4 Andrew Baumann 2007-02-01 18:43:01 EST
Ok, that has fixed the initial error messages. I can now create text in Times 
Roman and Helvetica and it appears roughly correct, although is very badly 
bitmapped because the fonts are now being scaled up.

If I select a different font, I get more error messages. For example, 
selecting Nimbus Sans gives:
I cannot find the metrics for the font NimbusSanL-Regu. The file n019003l.afm 
is not in the font_path. I'll use the metrics for Times-Roman instead.
... immediately followed by:
Cannot load '-urw-nimbus sans l-regular-r-normal--89-*-*-*-*-*-iso8859-1 [32 
72 100_101 108 111 114 119]': no such font
Comment 5 Gérard Milmeister 2007-02-03 10:41:12 EST
I made a new build, that should work with all fonts available from the font
menu. Please try it out, then close the bug if ok.
Comment 6 Andrew Baumann 2007-02-03 15:53:37 EST
Thanks, this seems to have fixed the problems. I still get the error messages 
at startup about ruler fonts, but that is only a minor annoyance.
Comment 7 Kazuyoshi Furutaka 2008-02-05 06:47:48 EST
Hi,

I encountered the same problem on Fedora 8.

According to the README in skencil-0.6.17.tar.gz, the "Cannot load
'MyFont-Bold': no such font" can have two reasons:

1. Skencil tries to use fonts that are not installed in the X-server.
   Refer to the ``User's Guide'' on how to install fonts and configure
   Skencil.

2. Your server cannot handle transformed fonts or maybe not even scaled
   fonts. See the next section for details.

Just after the above notice the README also says that the latter can be checked
by doing `$ xlsfonts -fn '-*-*-*-*-*--[0 0 0 0]-*-*-*-*-0-*-*'`; I saw many font
names printed on my machines running Fedora 8, and this fact indicates we don't
have transformed-font problem.

So I consulted the User's Guide and found in
http://www.skencil.org/Doc/usersguide-4.html that, although on my machine .afm
and .pfb files of urf-fonts-2.4.3.fc8 (in place of ghostscript fonts) are
installed in /usr/share/fonts/default/Type1/, these are NOT useable for skencil,
because there's no fonts.alias file to bind these font files to proper (adobe)
font names.  (the fonts.alias file is included in skencil-0.6.17.tar.gz as
Doc/fonts.alias.)  The problem was caused by lack of proper postscript fonts.

So, the easiest fix should be to Requires: urw-fonts and to copy contents of the
Doc/fonts.alias file to the /usr/share/fonts/default/Type1/fonts.alias.  (I
couldn't find how to remove these entries when uninstalling, though.)

Yours,
Kazuyoshi 
Comment 8 Kazuyoshi Furutaka 2008-02-05 07:56:30 EST
Hi,

I encountered the same problem on Fedora 8.

According to the README in skencil-0.6.17.tar.gz, the "Cannot load
'MyFont-Bold': no such font" can have two reasons:

1. Skencil tries to use fonts that are not installed in the X-server.
   Refer to the ``User's Guide'' on how to install fonts and configure
   Skencil.

2. Your server cannot handle transformed fonts or maybe not even scaled
   fonts. See the next section for details.

Just after the above notice the README also says that the latter can be checked
by doing `$ xlsfonts -fn '-*-*-*-*-*--[0 0 0 0]-*-*-*-*-0-*-*'`; I saw many font
names printed on my machines running Fedora 8, and this fact indicates we don't
have transformed-font problem.

So I consulted the User's Guide and found in
http://www.skencil.org/Doc/usersguide-4.html that, although on my machine .afm
and .pfb files of urf-fonts-2.4.3.fc8 (in place of ghostscript fonts) are
installed in /usr/share/fonts/default/Type1/, these are NOT useable for skencil,
because there's no fonts.alias file to bind these font files to proper (adobe)
font names.  (the fonts.alias file is included in skencil-0.6.17.tar.gz as
Doc/fonts.alias.)  The problem was caused by lack of proper postscript fonts.

So, the easiest fix should be to Requires: urw-fonts and to copy contents of the
Doc/fonts.alias file to the /usr/share/fonts/default/Type1/fonts.alias.  (I
couldn't find how to remove these entries when uninstalling, though.)

Yours,
Kazuyoshi 
Comment 9 Kazuyoshi Furutaka 2008-02-05 08:57:46 EST
(In reply to comment #8)

First of all, sorry for posting the same comments twice...

A few more additional notes:

1. I think it's much better if the urw-fonts contains a fonts.alias file like
the one included in the skencil distribution.

2. In case the fonts.alias file is installed by skencil package, to be complete,
you need `xset fp rehash` when (un)installing the package.

Yours,
Kazuyoshi

Note You need to log in before you can comment on or make changes to this bug.