Bug 225625 - Merge Review: bridge-utils
Merge Review: bridge-utils
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:47 EST by Nobody's working on this, feel free to take it
Modified: 2012-01-13 07:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-13 07:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jima: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:47:13 EST
Fedora Merge Review: bridge-utils

http://cvs.fedora.redhat.com/viewcvs/devel/bridge-utils/
Initial Owner: dwmw2@redhat.com
Comment 1 Jima 2007-02-09 09:22:04 EST
Review time! :-)

OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
43bbd2a67b59cac3e15d545f8b51df68  bridge-utils-1.1.tar.gz
43bbd2a67b59cac3e15d545f8b51df68  bridge-utils-1.1.tar.gz.1
OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.
OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
See below - No rpmlint output.
OK - final provides and requires are sane.

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have dist tag
See below - Should package latest version
2 bugs - check for outstanding bugs on package.

Issues:

1. The recommended value for BuildRoot is:

%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

You may want to use that.

2. rpmlint says:

rpmlint on ./bridge-utils-1.1-2.fc7.src.rpm
W: bridge-utils setup-not-quiet
E: bridge-utils no-cleaning-of-buildroot %install

Easily fixed.  Add -q to %setup, and "rm -rf $RPM_BUILD_ROOT" after %install.

3. Latest version not used

http://sourceforge.net/project/showfiles.php?group_id=26089 says 1.2 is
available (and has been since 2006-09-20).  Please evaluate whether you
should be using this release instead.

4. Bugs open

There are two open bugs against this package:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205810
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169723

I'm not sure either bug is still particularly valid (one is against FC4,
the other looks like it should be resolved).

If you can address the issues above, I think we can call bridge-utils
APPROVED.
Comment 2 Jima 2007-02-09 10:17:24 EST
Other notes on the bump to 1.2: You can (well, need to) drop patches 1-5, as
they've been merged upstream, and you need to add a BR and call to autoconf
before %configure, since they didn't ship a pre-made configure script in 1.2. 
Just a reminder for when you get back.
Comment 3 Jima 2007-02-09 11:18:13 EST
*punts the ball back to dwmw2*
Comment 4 Jima 2007-12-10 09:31:39 EST
As requested by David, I've gone ahead and made the changes I recommended. 
(Thanks David!)  For the record, the recommended BuildRoot tag has changed since
I started this review:

http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473

I've labelled the spec 1.2-3, but haven't tagged it or kicked off a new build.

Got a couple more open bugs than before (4 now), but that's life, so I don't
think that's a blocker.  IOW, APPROVED.
Comment 6 Alexander Kurtakov 2012-01-13 07:13:44 EST
This has been approved long time ago.
Closing.

Note You need to log in before you can comment on or make changes to this bug.