Bug 225645 - Merge Review: cleanfeed
Merge Review: cleanfeed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cleanfeed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:50 EST by Nobody's working on this, feel free to take it
Modified: 2015-02-12 21:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-12 07:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:50:13 EST
Fedora Merge Review: cleanfeed

http://cvs.fedora.redhat.com/viewcvs/devel/cleanfeed/
Initial Owner: stransky@redhat.com
Comment 1 Rafał Psota 2007-02-25 17:51:51 EST
Needs work:
* Source 0 is not available
(ftp://ftp.exit109.com/users/jeremy/cleanfeed-0.95.7b.tar.gz)
* BuildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  (wiki: PackagingGuidelines#BuildRoot)
* Spec file: some paths are not replaced with RPM macros
* The package should contain the text of the license
  (wiki: Packaging/ReviewGuidelines)
* Each %files section should have a %defattr line
  (wiki: Packaging/ReviewGuidelines)
* Some files (CHANGES & README) should be in %doc

rpmlint output:
Source RPM:
W: cleanfeed summary-ended-with-dot A spam filter for Usenet news servers.
W: cleanfeed invalid-license distributable
W: cleanfeed no-url-tag
E: cleanfeed hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/news/bin/filter
E: cleanfeed hardcoded-library-path in
$RPM_BUILD_ROOT/usr/lib/news/bin/filter/filter_innd.pl
E: cleanfeed hardcoded-library-path in /usr/lib/news/bin/filter
E: cleanfeed hardcoded-library-path in /usr/lib/news/bin/filter/filter_innd.pl
W: cleanfeed no-%build-section

rpmlint of cleanfeed:
W: cleanfeed summary-ended-with-dot A spam filter for Usenet news servers.
W: cleanfeed invalid-license distributable
W: cleanfeed no-url-tag
E: cleanfeed only-non-binary-in-usr-lib
W: cleanfeed conffile-without-noreplace-flag /etc/news/cleanfeed.conf
E: cleanfeed non-readable /usr/lib/news/bin/filter/filter_innd.pl 0750
E: cleanfeed non-standard-executable-perm
/usr/lib/news/bin/filter/filter_innd.pl 0750
Comment 2 Thomas Spura 2010-07-18 19:01:55 EDT
(Adding all current maintainers)

Any progress here?
Comment 3 Roman Rakus 2010-07-23 11:00:22 EDT
cleanfeed-20020501-4_fc14 built. What about this one?
Comment 4 Lukáš Nykrýn 2011-08-17 05:53:22 EDT
Checked git commit:
a79564bb2bc60af43dde6748eafb23d853f80bde

YES source files match upstream
YES package meets naming and versioning guidelines. 
YES specfile is properly named, is cleanly written and uses macros consistently
YES dist tag is present
YES clean section and buildroot present
YES license field matches the actual license
YES license is open source-compatible 
YES License text included in package
YES latest version is being packaged
N/A BuildRequires are proper
N/A compiler flags are appropriate
YES package builds in mock (Rawhide/x86_64)
N/A debuginfo package looks complete
YES rpmlint is silent
YES final provides and requires look sane
	-- dependence on perl is added automatically, but maybe it would by good to define it explicitly
N/A %check is present and all tests pass
N/A no shared libraries are added to the regular linker search paths
YES owns the directories it creates
YES doesn't own any directories it shouldn't
YES no duplicates in %files
N/A scriptlets must be sane
YES code, not content
N/A large documentation files must go in a -doc subpackage
YES %docs are not necessary for the proper functioning of the package
YES no headers
YES no pkgconfig files
YES no libtool .la droppings.
YES not a GUI app.

Additional comments:
User news is not by default in system, so it use root, I don't know if it is desired behavior.
Comment 5 Cole Robinson 2015-02-11 15:35:42 EST
Mass reassigning all merge reviews to their component. For more details, see this FESCO ticket:

  https://fedorahosted.org/fesco/ticket/1269

If you don't know what merge reviews are about, please see:

  https://fedoraproject.org/wiki/Merge_Reviews

How to handle this bug is left to the discretion of the package maintainer.
Comment 6 Dominik 'Rathann' Mierzejewski 2015-02-12 07:36:00 EST
I did some clean-ups and the package seems to be fine WRT the packaging guidelines.
Comment 7 Parag AN(पराग) 2015-02-12 21:54:21 EST
Awesome! thanks Dominik for cleaning this up. Good to see this merge-review is not closed without fix/review.

Note You need to log in before you can comment on or make changes to this bug.