Bug 225647 - Merge Review: compat-db
Merge Review: compat-db
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On: 816124
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:50 EST by Nobody's working on this, feel free to take it
Modified: 2013-02-07 10:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 10:19:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:50:32 EST
Fedora Merge Review: compat-db

http://cvs.fedora.redhat.com/viewcvs/devel/compat-db/
Initial Owner: jnovy@redhat.com
Comment 1 Jochen Schmitt 2010-08-25 09:44:06 EDT
I would suggest, that you should splitt this package into three main packages. One for each version of the BerkleyDb which should be supported.
Comment 2 Jon Ciesla 2012-04-05 09:55:39 EDT
Good:

- rpmlint checks return: 

Lots of unversion-explicit provides and obsolete-not-provided which should be fixed/dropped etc.

compat-db.spec:209: W: macro-in-comment %{_libdir}
There is a unescaped macro after a shell style comment in the specfile. Macros
are expanded everywhere, so check if it can cause a problem in this case and
escape the macro with another leading % if appropriate.

Trivial fix.

compat-db45.x86_64: E: devel-dependency compat-db-headers
Your package has a dependency on a devel package but it's not a devel package
itself.

Fix, if possible.

compat-db45.x86_64: W: only-non-binary-in-usr-lib
There are only non binary files in /usr/lib so they should be in /usr/share.

Ignore, I suspect.

Lots of no-man-page-for-binary.  Ignore.

Lots of rpath warning.  Fix if at all possible.

- package meets naming guidelines
- package meets packaging guidelines
- license ( BSD ) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
- package compiles on devel (x86_64)
- no missing BR
- no unnecessary BR
- no locales
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file
- devel package N/A
- no .la files
- post/postun ldconfig ok
- devel requires base package n-v-r N/A

The requires situation is unorthodox, but logical given the nature of the package.

Really looks like it's just the rpmlint stuff, let me know if you'd like me to commit any of this.
Comment 3 Jon Ciesla 2012-04-26 08:52:18 EDT
Ping?  I'll commit the macro fixes if that's ok?
Comment 4 Jindrich Novy 2012-04-26 09:02:09 EDT
(In reply to comment #3)
> Ping?  I'll commit the macro fixes if that's ok?

Jon, thanks for looking into it. Maybe better is to review libdb4:

https://bugzilla.redhat.com/show_bug.cgi?id=816124

so that we can get rid of both compat-db and db4 in rawhide. Could you please have look at it?
Comment 5 Jon Ciesla 2012-04-26 10:10:11 EDT
Indeed, good idea.
Comment 6 Jon Ciesla 2013-02-07 10:19:47 EST
Retired, APPROVED, closed.

Note You need to log in before you can comment on or make changes to this bug.