Bug 2256548 - Review Request: rust-pollster - Synchronously block the thread until a future completes
Summary: Review Request: rust-pollster - Synchronously block the thread until a future...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michel Lind
QA Contact: Fedora Extras Quality Assurance
URL: https://crates.io/crates/pollster
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2024-01-02 23:33 UTC by Onuralp Sezer
Modified: 2024-02-08 00:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-08 00:45:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Onuralp Sezer 2024-01-02 23:33:52 UTC
Spec URL: https://thunderbirdtr.fedorapeople.org/rust-pollster/rust-pollster.spec
SRPM URL: https://thunderbirdtr.fedorapeople.org/rust-pollster/rust-pollster-0.3.0-1.fc40.src.rpm
Description: Synchronously block the thread until a future completes
Fedora Account System Username: thunderbirdtr

Comment 1 Fedora Review Service 2024-01-02 23:39:41 UTC
Copr build:
https://copr.fedorainfracloud.org/coprs/build/6850752
(succeeded)

Review template:
https://download.copr.fedorainfracloud.org/results/@fedora-review/fedora-review-2256548-rust-pollster/fedora-rawhide-x86_64/06850752-rust-pollster/fedora-review/review.txt

Please take a look if any issues were found.


---
This comment was created by the fedora-review-service
https://github.com/FrostyX/fedora-review-service

If you want to trigger a new Copr build, add a comment containing new
Spec and SRPM URLs or [fedora-review-service-build] string.

Comment 2 Michel Lind 2024-01-08 04:35:25 UTC
This is not installable without pollster-macro. Please use mock --postinstall to test

Error: 
 Problem 1: conflicting requests
  - nothing provides (crate(pollster-macro/default) >= 0.1.0 with crate(pollster-macro/default) < 0.2.0~) needed by rust-pollster+pollster-macro-devel-0.3.0-1.fc40.noarch from @commandline
 Problem 2: package rust-pollster+macro-devel-0.3.0-1.fc40.noarch from @commandline requires crate(pollster/pollster-macro) = 0.3.0, but none of the providers can be installed
  - conflicting requests
  - nothing provides (crate(pollster-macro/default) >= 0.1.0 with crate(pollster-macro/default) < 0.2.0~) needed by rust-pollster+pollster-macro-devel-0.3.0-1.fc40.noarch from @commandline
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 3 Package Review 2024-02-08 00:45:40 UTC
This is an automatic action taken by review-stats script.

The ticket submitter failed to clear the NEEDINFO flag in a month.
As per https://fedoraproject.org/wiki/Policy_for_stalled_package_reviews
we consider this ticket as DEADREVIEW and proceed to close it.


Note You need to log in before you can comment on or make changes to this bug.