This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 225673 - Merge Review: cyrus-sasl
Merge Review: cyrus-sasl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 12:54 EST by Nobody's working on this, feel free to take it
Modified: 2008-01-28 07:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 07:48:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:54:53 EST
Fedora Merge Review: cyrus-sasl

http://cvs.fedora.redhat.com/viewcvs/devel/cyrus-sasl/
Initial Owner: nalin@redhat.com
Comment 1 Jon Ciesla 2008-01-23 14:26:57 EST
rpmlint on srpm:

cyrus-sasl.src: W: strange-permission make-no-dlcompatorsrp-tarball.sh 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

cyrus-sasl.src: W: strange-permission saslauthd.init 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.


Probably acceptable.

rpmlint on rpms:

cyrus-sasl.i386: E: executable-marked-as-config-file /etc/rc.d/init.d/saslauthd
Executables must not be marked as config files because that may
prevent upgrades from working correctly. If you need to be able to
customize an executable, make it for example read a config file in
/etc/sysconfig.

cyrus-sasl.i386: W: conffile-without-noreplace-flag /etc/rc.d/init.d/saslauthd
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here

Fix these, or explain in spec.

cyrus-sasl.i386: W: incoherent-init-script-name saslauthd
The init script name should be the same as the package name in lower case,
or one with 'd' appended if it invokes a process by that name.

Would correcting this break anything?


cyrus-sasl-debuginfo.i386: W: spurious-executable-perm
/usr/src/debug/cyrus-sasl-2.1.22/include/sasl.h
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.

cyrus-sasl-debuginfo.i386: W: spurious-executable-perm
/usr/src/debug/cyrus-sasl-2.1.22/include/saslplug.h
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.

cyrus-sasl-debuginfo.i386: W: spurious-executable-perm
/usr/src/debug/cyrus-sasl-2.1.22/include/hmac-md5.h
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.


These need fixing.

cyrus-sasl-devel.i386: W: no-dependency-on cyrus-sasl

Fix.

cyrus-sasl-gssapi.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

cyrus-sasl-ldap.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

cyrus-sasl-md5.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

cyrus-sasl-ntlm.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

cyrus-sasl-plain.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

cyrus-sasl-sql.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.


Can probably ignore, but I'd rather see it fixed if there are docs that are
broken out into similar units as the packages.


Source0: tag needs to include the url to the tarball included in the SRPM.  IF
this is a modified version of an upstream tarball, provide a script that
converts the upstream tarball into the one provided.

The Guidelines forbid the inclusion of .la files, these should be removed.

Other than the above, no blockers.
Comment 2 Steve Conklin 2008-01-25 18:07:06 EST
I just tagged and built cyrus-sasl-2.1.22-11.fc9

> rpmlint on srpm:
>
> cyrus-sasl.src: W: strange-permission make-no-dlcompatorsrp-tarball.sh 0755

> cyrus-sasl.src: W: strange-permission saslauthd.init 0755

> Probably acceptable.

I left these alone.

> rpmlint on rpms:
>
> cyrus-sasl.i386: E: executable-marked-as-config-file
> cyrus-sasl.i386: W: conffile-without-noreplace-flag /etc/rc.d/init.d/saslauthd

Fix these, or explain in spec.

Fixed

> cyrus-sasl.i386: W: incoherent-init-script-name saslauthd
>
> Would correcting this break anything?

There are two reasons not to change this:
1. It will likely break something else, as it's been named this for a very long
time.
2. The name of the init script does accurately reflect the name of the daemon,
it just doesn't match the rpm name because the rom also includes libraries, etc.

I think this should remain, and haven't changed it.

> cyrus-sasl-debuginfo.i386: W: spurious-executable-perm
> cyrus-sasl-debuginfo.i386: W: spurious-executable-perm
> cyrus-sasl-debuginfo.i386: W: spurious-executable-perm

All Fixed

> cyrus-sasl-devel.i386: W: no-dependency-on cyrus-sasl
>
> Fix.

Fixed

> cyrus-sasl-gssapi.i386: W: no-documentation
> cyrus-sasl-ldap.i386: W: no-documentation
> cyrus-sasl-md5.i386: W: no-documentation
> cyrus-sasl-ntlm.i386: W: no-documentation
> cyrus-sasl-plain.i386: W: no-documentation
> cyrus-sasl-sql.i386: W: no-documentation

> Can probably ignore, but I'd rather see it fixed if there are docs that are
> broken out into similar units as the packages.

There's no documentation for these that can even be broken out of the upstream
source, so I didn't change anything for this.

> Source0: tag needs to include the url to the tarball included in the SRPM.  IF
> this is a modified version of an upstream tarball, provide a script that
> converts the upstream tarball into the one provided.

This is documented in the spec file. The link to upstream is provided, and the
script which does the conversion.

> The Guidelines forbid the inclusion of .la files, these should be removed.

All removed.
Comment 3 Jon Ciesla 2008-01-28 07:48:17 EST
Ok, looks great.  Thank you!

APPROVED.

Note You need to log in before you can comment on or make changes to this bug.