Bug 225676 - Merge Review: dbus
Merge Review: dbus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 12:55 EST by Nobody's working on this, feel free to take it
Modified: 2008-02-05 11:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 11:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mclasen: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:55:24 EST
Fedora Merge Review: dbus

http://cvs.fedora.redhat.com/viewcvs/devel/dbus/
Initial Owner: johnp@redhat.com
Comment 1 Matthias Clasen 2007-11-14 22:42:43 EST
Ok, taking this one.

rpmlint output:

[mclasen@localhost devel]$ rpmlint i386/dbus-1.1.2-8.fc8.i386.rpm 
dbus.i386: E: executable-marked-as-config-file /etc/rc.d/init.d/messagebus

Should probably be fixed to follow the packaging guidelines.

dbus.i386: E: non-standard-gid /lib/dbus-1/dbus-daemon-launch-helper dbus
dbus.i386: E: setuid-binary /lib/dbus-1/dbus-daemon-launch-helper root 04750
dbus.i386: E: non-standard-executable-perm /lib/dbus-1/dbus-daemon-launch-helper
04750
dbus.i386: E: non-standard-executable-perm /lib/dbus-1/dbus-daemon-launch-helper
04750

This has all been carefully reviewed when dbus system bus activation was
implemented, so is ok.

dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/COPYING
dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/ChangeLog
dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/NEWS

Should be fixed.

dbus.i386: W: conffile-without-noreplace-flag /etc/dbus-1/session.conf
dbus.i386: W: conffile-without-noreplace-flag /etc/dbus-1/system.conf

I think these should probably be %config(noreplace)

dbus.i386: W: conffile-without-noreplace-flag /etc/rc.d/init.d/messagebus

Shouldn't be %config

dbus.i386: W: service-default-enabled /etc/rc.d/init.d/messagebus
dbus.i386: W: service-default-enabled /etc/rc.d/init.d/messagebus

This is of course not a bug, but necessary.

dbus.i386: W: incoherent-init-script-name messagebus

Not sure what this is about, spurious warning.



[mclasen@localhost devel]$ rpmlint i386/dbus-x11-1.1.2-8.fc8.i386.rpm 
dbus-x11.i386: E: explicit-lib-dependency libX11


[mclasen@localhost devel]$ rpmlint i386/dbus-libs-1.1.2-8.fc8.i386.rpm 
dbus-libs.i386: W: no-documentation
dbus-libs.i386: W: obsolete-not-provided dbus

Should be fine in this case, since dbus-libs requires dbus, ie it does
provide dbus via a Requires.


[mclasen@localhost devel]$ rpmlint i386/dbus-devel-1.1.2-8.fc8.i386.rpm 
dbus-devel.i386: W: no-documentation
dbus-devel.i386: E: only-non-binary-in-usr-lib

These are ignorable, rpmlint is confused about /lib vs /usr/lib


Package name: ok
Spec name: ok
Packaging guidelines: 
  - uses of BuildPreReq and PreReq should be removed
  - the conflict with cups is somewhat curious and deserves a little comment
  - the -devel subpackage should probably requires the -libs package, not 
    the main package
  - should not mix $RPM_BUILD_ROOT and %{buildroot}
  - Should the service be stopped in %preun before deleting it ? The wiki 
    seems to imply that
  - %{_datadir}/man should perhaps be %{_mandir}
  - -devel should probably requires devhelp for /usr/share/devhelp/books
    directory ownership
license: ok
license field: ok
license file: ok
spec language: ok
spec legibility: ok
upstream sources: ok
buildable: ok
excludearch: n/a
build requires: ok
locale handling: n/a
shared library symlinks: ok
relocatable: n/a
directory ownership: see above
%file list: ok
file permissions: see above
%clean: ok
consistent macro use: see above
large docs: are included in -devel, ok
%doc content: ok
headers: ok
static libs: n/a
pc files: ok
shared libs: ok
devel deps: ok
libtool archives: ok
gui apps: n/a
directory ownership: see above
%install: ok
utf8 filenames: ok
Comment 2 John (J5) Palmieri 2007-11-15 00:23:43 EST
> dbus.i386: W: incoherent-init-script-name messagebus
> 
> Not sure what this is about, spurious warning.

messagebus is a different name than the package I am guessing.  I can fix the
issues tomorrow.
Comment 3 Matthias Clasen 2007-11-15 09:08:07 EST
> messagebus is a different name than the package I am guessing.  I can fix the
> issues tomorrow.

Or maybe != daemon name. Who knows. The warning is unclear, and I am not aware
of any rules mandating either pairs to be equal, so just ignore this one.
Comment 4 Ville Skyttä 2007-11-15 12:42:47 EST
$ rpmlint -I incoherent-init-script-name
incoherent-init-script-name :
The init script name should be the same as the package name in lower case,
or one with 'd' appended if it invokes a process by that name.

Note: this is just what rpmlint thinks, it is not mandated by current packaging
guidelines.  I think changing the name in this case would not bring enough
benefits to outweigh the pain.
Comment 5 John (J5) Palmieri 2007-11-15 13:06:50 EST
also messagebus is the upstream name people expect
Comment 6 John (J5) Palmieri 2007-11-15 14:28:19 EST
Fixed most of the items in the devel branch

(In reply to comment #1)
> [mclasen@localhost devel]$ rpmlint i386/dbus-1.1.2-8.fc8.i386.rpm 
> dbus.i386: E: executable-marked-as-config-file /etc/rc.d/init.d/messagebus
>
> Should probably be fixed to follow the packaging guidelines.

removed the %config macro

> dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/COPYING
> dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/ChangeLog
> dbus.i386: W: spurious-executable-perm /usr/share/doc/dbus-1.1.2/NEWS
> 
> Should be fixed.

did a chmod in prep because the upstream tarball has these bits set though
curiously upstream git does not.  May be fixed in next upstream release or
something is wrong during tarball packaging.
 
> dbus.i386: W: conffile-without-noreplace-flag /etc/dbus-1/session.conf
> dbus.i386: W: conffile-without-noreplace-flag /etc/dbus-1/system.conf
> 
> I think these should probably be %config(noreplace)

Done

> dbus.i386: W: conffile-without-noreplace-flag /etc/rc.d/init.d/messagebus
> 
> Shouldn't be %config

fixed
 
> dbus.i386: W: incoherent-init-script-name messagebus
> 
> Not sure what this is about, spurious warning.
> 

Sticking with the upstream default
 
> 
> [mclasen@localhost devel]$ rpmlint i386/dbus-x11-1.1.2-8.fc8.i386.rpm 
> dbus-x11.i386: E: explicit-lib-dependency libX11
> 
Remove libX11 requires.  

rpm -qp dbus-x11-1.1.2-9.fc9.i386.rpm --requires shows libX11 was properly picked up

> Packaging guidelines: 
>   - uses of BuildPreReq and PreReq should be removed

Moved them to BuildRequires and Requires(pre) respectively 

>   - the conflict with cups is somewhat curious and deserves a little comment

Comment added from Tim Waugh's changelog

>   - the -devel subpackage should probably requires the -libs package, not 
>     the main package

This is a multilib thing I am told but the main package does require the -libs
package as it contains the actual versioned libraries

>   - should not mix $RPM_BUILD_ROOT and %{buildroot}

switched to using %{buildroot} exclusively

>   - Should the service be stopped in %preun before deleting it ? The wiki 
>     seems to imply that

Done

>   - %{_datadir}/man should perhaps be %{_mandir}

Done

>   - -devel should probably requires devhelp for /usr/share/devhelp/books
>     directory ownership

I really don't like this since it would require KDE to have a GTK+ requirement
to build on Fedora.  As much as I have an I don't care attitude I know there are
plenty who do care.  Suggestions welcome.  We could make a -devhelp sub package
but I think that is just a waste.

> directory ownership: see above

Again - see above

> file permissions: see above

Fixed

> consistent macro use: see above

Fixed
Comment 7 Matthias Clasen 2007-11-15 23:16:07 EST
Suggestions welcome.  We could make a -devhelp sub package
but I think that is just a waste.

I'd call it -docs, but yeah, thats the suggestion I'd have.

Everything else is fine now.
Comment 8 Patrice Dumas 2007-11-16 04:48:47 EST
I think it is better to call is -doc to be consistent with all the
other packages and the suggestion in the guidelines.
Comment 9 Matthias Clasen 2007-11-16 18:03:49 EST
sure, -doc works too
Comment 10 Michel Alexandre Salim 2008-01-25 13:07:20 EST
Until /usr/share/devhelp/books is owned by some other package, I guess putting 
the books in -doc is the best we can do. I split out the vala package the same 
way when it started using devhelp for documentation.
Comment 11 John (J5) Palmieri 2008-01-25 13:14:55 EST
yep, already done when I pushed the latest D-Bus to rawhide
Comment 12 Matthias Clasen 2008-02-05 11:55:41 EST
Approved.

Note You need to log in before you can comment on or make changes to this bug.