This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 225696 - Merge Review: diffutils
Merge Review: diffutils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 13:27 EST by Nobody's working on this, feel free to take it
Modified: 2008-01-03 06:03 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.8.1-20.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 12:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
kevin: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:27:42 EST
Fedora Merge Review: diffutils

http://cvs.fedora.redhat.com/viewcvs/devel/diffutils/
Initial Owner: twaugh@redhat.com
Comment 1 Kevin Fenzi 2007-12-22 13:38:11 EST
I'd be happy to review this. Look for a full review in a bit. 
Comment 2 Kevin Fenzi 2007-12-22 14:03:22 EST
OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
OK - Spec has consistant macro usage.
OK - Meets Packaging Guidelines.
See below - License
See below - License field in spec matches
See below - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
71f9c5ae19b60608f6c7f162da86a428  diffutils-2.8.1.tar.gz
71f9c5ae19b60608f6c7f162da86a428  diffutils-2.8.1.tar.gz.1
OK - BuildRequires correct
OK - Spec handles locales/find_lang
See below - Package is relocatable and has a reason to be.
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.
OK - Package has rm -rf RPM_BUILD_ROOT at top of %install

OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
See below - No rpmlint output.
OK - final provides and requires are sane.

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have dist tag
OK - Should package latest version
OK - check for outstanding bugs on package.

Issues:

1. On the License here, most files are GPLv2+, some are LGPLv2+, one is "public
domain"
and one (src/side.c) seems to be "GNU DIFF General Public License", which just says
to refer to the included file with the license, which doesn't seem to be there.
Not sure what to do on this... perhaps ask upstream to clarify what the
"GNU DIFF General Public License" is. Hopefully it's just GPLv2+.

2. Any reason for the Prefix here? relocatable packages are frowned on.

3. Please use the fedora buildroot:
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

4. Does the program really need %makeinstall? Will 'make DESTDIR...' work?

5. rpmlint says:

diffutils.src: E: non-utf8-spec-file
/tmp/diffutils-2.8.1-19.fc9.src.rpm.5954/diffutils.spec

Suggest: run iconv on the spec?

diffutils.src:16: W: redundant-prefix-tag

Suggest: remove Prefix (per issue 2)

diffutils.src:17: W: prereq-use /sbin/install-info

Suggest: Switch to:
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info

See:
http://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets#head-17ab0c9ff7c520fbf0c9f60afacde58ddcfc6981

diffutils.src: W: summary-ended-with-dot A GNU collection of diff utilities.

Suggest: remove . at end of summary

diffutils.src: W: invalid-license GPL

Suggest: Might be GPLv2+ (but needs clarification)

I would be happy to provide a patch for the items above, just check in changes, or
let you make the changes. Just let me know.
Comment 3 Tim Waugh 2008-01-02 12:20:25 EST
All fixed in 2.8.1-20.fc9.  I've written to Paul Eggert to ask for clarification
of the license for src/side.c.
Comment 4 Kevin Fenzi 2008-01-02 16:41:54 EST
Cool. Thanks for the prompt fixes... 

Note that for Merge reviews, you should have the reviewer approve before closing
the bug. Not that it matters in this case, as everything except the one file's
license is fixed. Hopefully that will get cleared up soon. 

This package is APPROVED. 
Comment 5 Tim Waugh 2008-01-03 06:03:11 EST
Thanks.  Paul Eggart has replied to confirm that the "GNU General Public License
version 2 or (at your option) later" is in fact what is intended in that file,
and that it is fixed in upstream CVS now.

Note You need to log in before you can comment on or make changes to this bug.