Bug 225697 - Merge Review: distcache
Merge Review: distcache
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:27 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-15 12:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 03:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:27:54 EST
Fedora Merge Review: distcache

http://cvs.fedora.redhat.com/viewcvs/devel/distcache/
Initial Owner: jorton@redhat.com
Comment 1 Steve Traylen 2009-10-01 14:56:15 EDT
Hi,

I presume a merge review is the same as a normal review just
a different starting point:

Comments:

1) $ rpmlint distcache.spec 
distcache.spec:57: E: use-of-RPM_SOURCE_DIR

Yes you should not install from the SOURCE_DIR
but instead in %prep move things to unpacked
directory. i.e.
cp -p %{SOURCE1} .
after your %setup.

2) The 3 patches have no comments or upstream bugs attached.

3) The useradd section in the %post could be a litte more complicated as
   recommended here:

https://fedoraproject.org/wiki/Packaging/UsersAndGroups

(It's odd its in the %post and not in the %pre, is it really not needed
 till then? It looks like it may be in the passwd file already though.

4) The two scripts in the .src.rpm should not be executable.

5) What about splitting to a client and server package? Is that sensible?

6) You could mark /etc/sysconfig/distcache as a %gfile
Comment 2 Steve Traylen 2009-10-26 13:09:19 EDT
Ping?
Steve
Comment 3 Steve Traylen 2009-11-21 13:08:22 EST
Ping
Comment 4 Steve Traylen 2009-11-24 13:07:45 EST
For me no response, removing myself.

Steve
Comment 5 Jon Ciesla 2012-04-03 10:05:46 EDT
I'll give this a go.
Comment 6 Jon Ciesla 2012-04-03 10:29:31 EDT
- rpmlint checks return:

distcache.spec:57: E: use-of-RPM_SOURCE_DIR
You use $RPM_SOURCE_DIR or %{_sourcedir} in your spec file. If you have to use
a directory for building, use $RPM_BUILD_ROOT instead.

distcache.src: W: strange-permission dc_client.init 0775L
A file that you listed to include in your package has strange permissions.
Usually, a file should have 0644 permissions.

distcache.src: W: strange-permission dc_server.init 0775L
A file that you listed to include in your package has strange permissions.
Usually, a file should have 0644 permissions.

I'm willing to fix the above if you like.

distcache.x86_64: E: incorrect-fsf-address /usr/share/doc/distcache-1.4.5/LICENSE
The Free Software Foundation address in this file seems to be outdated or
misspelled.  Ask upstream to update the address, or if this is a license file,
possibly the entire file with a new copy available from the FSF.

Minor.


- package meets naming guidelines
- package meets packaging guidelines
- license ( LGPLv2 ) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
- package compiles on devel (x86_64)
- no missing BR
- no unnecessary BR
- no locales
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok - SEE ABOVE
- %clean ok
- macro use consistent - SEE ABOVE
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file
- devel package ok
- no .la files
- post/postun ldconfig ok
- devel requires base package n-v-r 

So it's really just the minor things from rpmlint, which I'll commit fixes for unless you object, so we can close this.  Then there's the systemd migration, but there's already a BZ open for that.  I can do that if you like.
Comment 7 Joe Orton 2012-04-10 03:56:00 EDT
This package is not used in the distro any more, I've retired it, sorry for your wasted time on the review.
Comment 8 Jon Ciesla 2012-04-10 07:50:49 EDT
Not at all, the review is closed, the time was not wasted. :)
Comment 9 Parag AN(पराग) 2012-06-15 12:27:13 EDT
This bug just popped out when I searched for packages under review but this looks like this package was retired already.

Dropping the flag fedora-review?

Note You need to log in before you can comment on or make changes to this bug.