Bug 225723 - Merge Review: elfutils
Merge Review: elfutils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 13:32 EST by Nobody's working on this, feel free to take it
Modified: 2008-09-09 11:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 11:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:32:30 EST
Fedora Merge Review: elfutils

http://cvs.fedora.redhat.com/viewcvs/devel/elfutils/
Initial Owner: roland@redhat.com
Comment 1 Jon Ciesla 2008-01-23 12:58:48 EST
rpmlint on srpm:

elfutils.src:37: W: unversioned-explicit-obsoletes libelf
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

elfutils.src:37: W: unversioned-explicit-obsoletes libelf-devel
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

I assume this is probably OK, but it'd be better to version this, on the off
chance we move back to libelf.

elfutils.src: W: mixed-use-of-spaces-and-tabs (spaces: line 287, tab: line 287)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

Cosmetic, but worth fixing.

elfutils.src: W: no-url-tag
The URL tag is missing.

Are we the upstream?  If so, it needs a spot on "hosted" so se can have upstream
there.


rpmlint on rpms:

elfutils.i386: W: obsolete-not-provided libelf
If a package is obsoleted by a compatible replacement, the obsoleted package
must also be provided in order to provide clean upgrade paths and not cause
unnecessary dependency breakage.  If the obsoleting package is not a compatible
replacement for the old one, leave out the provides.

elfutils.i386: W: obsolete-not-provided libelf-devel
If a package is obsoleted by a compatible replacement, the obsoleted package
must also be provided in order to provide clean upgrade paths and not cause
unnecessary dependency breakage.  If the obsoleting package is not a compatible
replacement for the old one, leave out the provides.


See above.

elfutils-devel.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

Minor, might not be applicable.

elfutils-devel.i386: W: no-dependency-on elfutils
elfutils-devel.i386: W: summary-ended-with-dot Development libraries to handle
compiled objects.
Summary ends with a dot.

elfutils-devel-static.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

elfutils-devel-static.i386: W: summary-ended-with-dot Static archives to handle
compiled objects.
Summary ends with a dot.

elfutils-libelf.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

elfutils-libelf.i386: W: summary-ended-with-dot Library to read and write ELF files.
Summary ends with a dot.

elfutils-libelf-devel.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

elfutils-libelf-devel-static.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

elfutils-libs.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

elfutils-libs.i386: W: summary-ended-with-dot Libraries to handle compiled objects.
Summary ends with a dot.

These are cosmetic also, but need fixing.

elfutils-libelf-devel.i386: W: no-dependency-on elfutils-libelf

This is an absolute MUSTFIX unless there's a compelling reason not to.

Also, license tag is GPL, should be GPLv2.

Other than the above, no blockers.

Comment 2 Patrice Dumas 2008-01-23 13:53:48 EST
(In reply to comment #1)
> rpmlint on srpm:
> 
> elfutils.src:37: W: unversioned-explicit-obsoletes libelf

> elfutils.src:37: W: unversioned-explicit-obsoletes libelf-devel

> I assume this is probably OK, but it'd be better to version this, on the off
> chance we move back to libelf.

This is definitely not ok. Unversioned obsoletes are very bad.
In my opinion this is a blocker, except if there is a good reason 
not to version the obsoletes, but I can't see one.
Comment 3 Jon Ciesla 2008-01-23 14:00:26 EST
Agreed.
Comment 4 Roland McGrath 2008-02-20 03:22:52 EST
I've committed elfutils.spec updates to devel/ CVS, though there won't be a new
build til the next elfutils release in a week or two.  Please eyeball the spec
changes.

The %doc files don't really have to be copied into each subpackage, do they?
They are in elfutils.

I added versions to the obsoletes for the RHL8.0 version that was obsoleted in
RH8.0.1 by elfutils-libelf.  I added a Provides: libelf-devel to
elfutils-libelf-devel.  libelf is a pure DSO package, so an explicit provide
does not make sense.  (These obsoletes/provides are so old we might just punt
them--we don't support upgrade paths from RHL8 anyway.)

rpmlint is not clever enough to see that elfutils-libelf-devel depends on
elfutils-libelf-%{_arch} because a plain elfutils-libelf dependency is not
really sufficient for biarch machines.

I think I fixed all the cosmetic items.
Comment 5 Jon Ciesla 2008-02-20 07:50:53 EST
Fix the license tag on the subpackages, which still say GPL.  Also, the -devel
packages need to Require the main packages, both for elfutils and elfutils-libelf.

As for the RH8 Obsoletes, I'd just as soon leave them there, but I'm OK with
dropping them.

Also, I see the fh.o URL, but I there's still no URL in the Source tag, and I
can't find the tarball there.
Comment 6 Roland McGrath 2008-02-20 14:15:24 EST
Oh, subpackages shouldn't have a separate License: tag at all, should they?

As I just said in comment#4, the -devel packages do have the correct
dependencies.  The mindless rule is not sufficient to tell.

There is no separately published "upstream" package.  The rawhide srpm is the
canonical location of the source tar file.
Comment 7 Jon Ciesla 2008-02-20 14:27:57 EST
(In reply to comment #6)
> Oh, subpackages shouldn't have a separate License: tag at all, should they?

Correct, generally.

> As I just said in comment#4, the -devel packages do have the correct
> dependencies.  The mindless rule is not sufficient to tell.

Ah, I see. I misunderstood.

> There is no separately published "upstream" package.  The rawhide srpm is the
> canonical location of the source tar file.

My point was that it'd be good to have a current tarball placed at the hosted
site, so that the Source0 tag could be set appropriately.  Or, comment the above
in the spec.  Your call.

Fix that and the License tags and we're set.
Comment 8 Jon Ciesla 2008-05-16 11:04:42 EDT
Any updates?
Comment 9 Jon Ciesla 2008-09-09 11:50:56 EDT
All fixed in current rawhide, approved.

Note You need to log in before you can comment on or make changes to this bug.