Bug 2257443 - Missing dependency on 'python36-zipp'
Summary: Missing dependency on 'python36-zipp'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-importlib-metadata
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Frank Crawford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-09 16:57 UTC by Scott K Logan
Modified: 2024-01-22 02:08 UTC (History)
2 users (show)

Fixed In Version: python-importlib-metadata-0.23-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-01-22 02:08:01 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Scott K Logan 2024-01-09 16:57:38 UTC
Description of problem:
The python3-importlib-metadata package is missing a dependency on the `zipp` package, which must be present for the package to load.

Version-Release number of selected component (if applicable): python36-importlib-metadata-0.23-4.el7


How reproducible: 100%


Steps to Reproduce:
1. yum install epel-release -q -y && yum install python36-importlib-metadata -q -y
2. python3 -c "import importlib_metadata; print('OK')"

Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3.6/site-packages/importlib_metadata/__init__.py", line 9, in <module>
    import zipp
ModuleNotFoundError: No module named 'zipp'

Expected results:
OK

Additional info:
Installing the missing `python36-zipp` package resolved the issue.
I have not experienced this issue on any other platforms except EPEL 7.

Comment 1 Frank Crawford 2024-01-10 08:27:20 UTC
Okay, will check it out in the next week and probably submit an updated package.

Comment 2 Frank Crawford 2024-01-13 14:49:53 UTC
The issue is that for EPEL7 the automatic generator does not exist and all dependencies need to be manually added.  For all other releases it does run and picks up the dependency.

Comment 3 Fedora Update System 2024-01-13 14:57:24 UTC
FEDORA-EPEL-2024-c60b2f080d has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2024-c60b2f080d

Comment 4 Fedora Update System 2024-01-14 01:13:15 UTC
FEDORA-EPEL-2024-c60b2f080d has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2024-c60b2f080d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2024-01-22 02:08:01 UTC
FEDORA-EPEL-2024-c60b2f080d has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.