Bug 225752 - Merge Review: filesystem
Merge Review: filesystem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 13:36 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 10:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:36:56 EST
Fedora Merge Review: filesystem

http://cvs.fedora.redhat.com/viewcvs/devel/filesystem/
Initial Owner: pknirsch@redhat.com
Comment 1 Gwyn Ciesla 2008-01-29 14:05:01 EST
rpmlint on srpm:

filesystem.src: E: non-utf8-spec-file
/tmp/filesystem-2.4.11-1.fc8.src.rpm.12176/filesystem.spec
The character encoding of the spec file is not UTF-8.  Convert it for
example using iconv(1).

Fix.

filesystem.src:78: E: hardcoded-library-path in /lib
A library path is hardcoded to one of the following paths: /lib,
/usr/lib. It should be replaced by something like /%{_lib} or %{_libdir}.

Special case, ok.

filesystem.src: W: no-%build-section
The spec file does not contain a %build section.  Even if some packages
don't directly need it, section markers may be overridden in rpm's
configuration to provide additional "under the hood" functionality, such as
injection of automatic -debuginfo subpackages.  Add the section, even if
empty.

Fix.

filesystem.src: W: mixed-use-of-spaces-and-tabs (spaces: line 31, tab: line 28)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

Cosmetic, but easy to fix.

filesystem.src: E: tag-not-utf8 %changelog
The character encoding of the value of this tag is not UTF-8.

Fix.

filesystem.src: W: no-url-tag
The URL tag is missing.

Fix.  If we're upstream, get a spot on hosted for this.  Also, since the license
is listed as Public Domain, we either need something in the one file of source
there is, the lang-exceptions file, or have something in %doc stating the license.


rpmlint on rpms:

filesystem.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

Is there anything to include here?

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man4x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/include
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/games
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /tmp 01777
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/src
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /var/lock 0775
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man2x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/bin
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/info
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man7x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /proc 0555
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/sbin
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/applications
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-mnt /mnt/cdrom
A file in the package is located in /mnt. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /var/spool/mail 0775
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/lib
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man3x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man9x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man6x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/libexec
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/mann
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /root 0750
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man4
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man5
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man6
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man7
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man1
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man2
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man8
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man9
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: non-standard-dir-perm /var/tmp 01777
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: non-standard-dir-perm /usr/share/empty 0555
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man5x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/etc
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man8x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man1x
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-usr-local /usr/local/share/man/man3
A file in the package is located in /usr/local. It's not permitted
for packages to install files in this directory.

filesystem.i386: E: dir-or-file-in-mnt /mnt/floppy
A file in the package is located in /mnt. It's not permitted
for packages to install files in this directory.

These are all fine.  Special case.

filesystem.i386: E: tag-not-utf8 %changelog
The character encoding of the value of this tag is not UTF-8.

Will be fixed in SRPM, above.

filesystem.i386: W: no-url-tag
The URL tag is missing.

See above.

filesystem.i386: E: no-binary
The package should be of the noarch architecture because it doesn't contain
any binaries.

Should this be made noarch, or would that break the _lib arch conditional?

Duplicate files:
warning: File listed twice: /usr/share/locale/ca_ES@valencian
warning: File listed twice: /usr/share/locale/ca_ES@valencian/LC_MESSAGES


Otherwise, looks good, no other blockers.
Comment 2 Gwyn Ciesla 2008-05-16 11:05:04 EDT
Any updates?
Comment 3 Phil Knirsch 2008-05-27 11:26:15 EDT
> filesystem.src: E: non-utf8-spec-file
> /tmp/filesystem-2.4.11-1.fc8.src.rpm.12176/filesystem.spec
> The character encoding of the spec file is not UTF-8.  Convert it for
> example using iconv(1).
> 
> Fix.

Fixed. Was only Trond's name that caused problems.

> filesystem.src: W: no-%build-section
> The spec file does not contain a %build section.  Even if some packages
> don't directly need it, section markers may be overridden in rpm's
> configuration to provide additional "under the hood" functionality, such as
> injection of automatic -debuginfo subpackages.  Add the section, even if
> empty.
> 
> Fix.

Added an empty %build section. Fixed.

> filesystem.src: W: mixed-use-of-spaces-and-tabs (spaces: line 31, tab: line 28)
> The specfile mixes use of spaces and tabs for indentation, which is a
> cosmetic annoyance.  Use either spaces or tabs for indentation, not both.
> 
> Cosmetic, but easy to fix.

Fixed. Only the 2 tabs in the echo commands remain, but those are output
redirected to a config file where tabs are commonly used, so that should be ok.

> filesystem.src: E: tag-not-utf8 %changelog
> The character encoding of the value of this tag is not UTF-8.
> 
> Fix.

Fixed already by UTF-8 conversion.

> filesystem.src: W: no-url-tag
> The URL tag is missing.
> 
> Fix.  If we're upstream, get a spot on hosted for this.  Also, since the license
> is listed as Public Domain, we either need something in the one file of source
> there is, the lang-exceptions file, or have something in %doc stating the license.

Hm, good point. Would a webpage on fp.org be enough you think? I could a
standard Public Domain copyright notice there and add that to the
lang-exceptions file as well and use this as the URL/homepage for the project,
too. As there is no source whatsoever i think a single webpage should be enough.

> filesystem.i386: W: no-documentation
> The package contains no documentation (README, doc, etc).
> You have to include documentation files.
> 
> Is there anything to include here?

Not really. The filesystem component really only provides the directory skeleton
structure for the OS and owns those "general" directories. Adding a doc file to
it would kind of contradict this skeleton function of this component, so if
possible i'd rather not do it.

> filesystem.i386: E: no-binary
> The package should be of the noarch architecture because it doesn't contain
> any binaries.
> 
> Should this be made noarch, or would that break the _lib arch conditional?

The problem is with /lib vs /lib64 and /usr/lib vs /usr/lib64, so yes, it's
because of the _lib arch conditional. If you see a way to avoid that without
adding all 4 trees with all subtrees to the noarch package i'm all ears.

> Duplicate files:
> warning: File listed twice: /usr/share/locale/ca_ES@valencian
> warning: File listed twice: /usr/share/locale/ca_ES@valencian/LC_MESSAGES

Hm, i've ran an rpmlint on the latest Feodra Devel package and don't get that
error. Could you reverify that you get this error and with which packages and
installation?

I've already done the changes which were easy to fix and await your answer for
the remaining points. In the meantime i'll build a new package that already
contains those fixes.

Thanks a lot,

Read ya, Phil
Comment 4 Gwyn Ciesla 2008-05-27 11:48:22 EDT
The following is against -15, built moments ago. . .

> Hm, good point. Would a webpage on fp.org be enough you think? I could a
> standard Public Domain copyright notice there and add that to the
> lang-exceptions file as well and use this as the URL/homepage for the project,
> too. As there is no source whatsoever i think a single webpage should be enough.

Yes.  With a comment in he spec near the Source tags, explaining the situation.

> The problem is with /lib vs /lib64 and /usr/lib vs /usr/lib64, so yes, it's
> because of the _lib arch conditional. If you see a way to avoid that without
> adding all 4 trees with all subtrees to the noarch package i'm all ears.

I don't, actually. :)

> Hm, i've ran an rpmlint on the latest Feodra Devel package and don't get that
> error. Could you reverify that you get this error and with which packages and
> installation?

Actually, i's not an rpmlint error, I see this at build time:

<snip>
+ mkdir -p -m 755
/var/tmp/filesystem-2.4.15-1.fc8-root-limb//usr/share/locale/sr@latin/LC_MESSAGES
+ read a b
+ mkdir -p -m 755
/var/tmp/filesystem-2.4.15-1.fc8-root-limb//usr/share/locale/uz@Latn/LC_MESSAGES
+ read a b
+ mkdir -p -m 755
/var/tmp/filesystem-2.4.15-1.fc8-root-limb//usr/share/locale/be@latin/LC_MESSAGES
+ read a b
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-python-bytecompile
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: filesystem-2.4.15-1.fc8
warning: File listed twice: /usr/share/locale/ca_ES@valencian
warning: File listed twice: /usr/share/locale/ca_ES@valencian/LC_MESSAGES
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: setup >= 2.5.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/filesystem-2.4.15-1.fc8-root-limb
Wrote: /usr/src/redhat/SRPMS/filesystem-2.4.15-1.fc8.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/filesystem-2.4.15-1.fc8.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.44676
+ umask 022
+ cd /usr/src/redhat/BUILD
+ rm -rf /var/tmp/filesystem-2.4.15-1.fc8-root-limb
+ exit 0


Do you see this on local builds?  It's in the koji build logs,
too:http://kojipkgs.fedoraproject.org/packages/filesystem/2.4.15/1.fc10/data/logs/i386/build.log



Comment 5 Phil Knirsch 2008-05-29 11:01:24 EDT
Ok, i'll set up a webpage then on fp.org somewhere, just need to figure out whom
to bug about this.

Regarding the arch problem, are you ok with keeping it as a arch package then?

And i've found the problem with the double listing, it was a duplicate entry in
the lang-exceptions file and i've fixed that now as well.

Thanks again,

Read ya, Phil
Comment 6 Gwyn Ciesla 2008-05-29 11:09:36 EDT
(In reply to comment #5)
> Ok, i'll set up a webpage then on fp.org somewhere, just need to figure out whom
> to bug about this.

https://hosted.fedoraproject.org/web/faq

> Regarding the arch problem, are you ok with keeping it as a arch package then?
>
Yes.  Seems the sanest.

> And i've found the problem with the double listing, it was a duplicate entry in
> the lang-exceptions file and i've fixed that now as well.

Excellent!

> Thanks again,
> 
> Read ya, Phil

Comment 7 Phil Knirsch 2008-06-18 10:40:08 EDT
Ok, homepage created and added the specfile and the language exception file:

https://fedorahosted.org/filesystem/wiki

As soon as git is working properly for the project i'll add both files to git
there and remove the attachments from the wiki page.

Thanks a lot,

Read ya, Phil
Comment 8 Gwyn Ciesla 2008-06-18 10:53:38 EDT
Awesome.  Minor nitpick, though.  Source0: should have the full URL to
lang-exceptions, i.e.
https://fedorahosted.org/filesystem/attachment/wiki/WikiStart/lang-exceptions

Once that's updated, you can have the git version as well, but that will need to
stay.
Comment 9 Phil Knirsch 2008-06-23 12:08:06 EDT
Git repo working now, added filesystem.spec and lang-exceptions files to it and
changed the Sourc1 URL to

https://fedorahosted.org/filesystem/browser/lang-exceptions

Build for filesystem-2.4.17-1.fc10 is running as i type this.

Thanks,

Read ya, Phil
Comment 10 Gwyn Ciesla 2008-06-23 12:38:30 EDT
<Sigh>

lang-exceptions in cvs/devel !=
https://fedorahosted.org/filesystem/browser/lang-exceptions

The latter contains HTML tags.  Is there a URL that will retrieve it in plain text?

Comment 11 Phil Knirsch 2008-06-24 06:53:48 EDT
Well, yes, but it looks like this:

https://fedorahosted.org/filesystem/browser/lang-exceptions?format=raw

which is bad for putting in Source tags as i'd then get a local file called
"lang-exceptions?format=raw" when i wget it which then would be packaged liked
that into the srpm. :/

Welcome to the wonderful web interface of GIT. :/

Read ya, Phil
Comment 12 Gwyn Ciesla 2008-06-24 08:48:20 EDT
Can you include that URL in a comment, so when they run the BADSOURCE/BADURL
script, there's documentation for an exception to be added to the whitelist? 
The "lang-exceptions?format=raw" md5sums to the same as lang-exceptions, so
that'd be perfect.
Comment 13 Phil Knirsch 2008-06-24 09:24:30 EDT
OK, building a new package now with the following comment above the Sourc1 tag:

# Raw source1 URL:
https://fedorahosted.org/filesystem/browser/lang-exceptions?format=raw
Comment 14 Gwyn Ciesla 2008-06-24 10:29:43 EDT
Brilliant.

APPROVED.

Thanks, sorry for the hoops. :)

Note You need to log in before you can comment on or make changes to this bug.