Bug 22576 - ps can not recognize the user defined format expressions.
ps can not recognize the user defined format expressions.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 08:06 EST by Dong Yan
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 10:57:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dong Yan 2000-12-20 08:06:34 EST
ps can not recognize the user defined format expressions.

such as ps -o %p
Comment 1 Preston Brown 2001-02-01 15:50:15 EST
does seem to be very broken.
Comment 2 Russell McOrmond 2001-03-27 12:45:58 EST
  The PS also doesn't match the MAN pages, which give examples which don't work.

  I have many scripts which have broken.  Should I attempt to fix it and submit
a patch, or is someone at RedHat already working on it?
Comment 3 acahalan 2001-06-01 01:03:51 EDT
If you want to work on this code, please
read ps/HACKING which the author so kindly
provided. You broke the retry logic when
you blindly added the code to complain
about unknown format options, and you
obviously did not run examples from the
man page.

Comment 4 Alexander Larsson 2002-08-08 09:24:49 EDT
Works for me at least in 2.0.7-23

Note You need to log in before you can comment on or make changes to this bug.